Jump to content

Classic II- No start up


Recommended Posts

I picked up a Classic II yesterday for $3 at a church rummage sale. Today I finally got the chance to power it on and check it out. Unfortunately I was greeted with this: IMG_0605 Upon flipping the switch I *usually* get this screen. Otherwise I get nothing. The screen is cramped and completely blank. No bong or any response from the KB/mouse.

 

So I opened it up and saw some capacitor goo, expected, and some corrosion. I cleaned up some of it with some alcohol and a q-tip. I tried it again, but to no avail. Here's a picture of the worst corrosion. IMG_0606 I'm aware it's a horrible picture but at the moment it's the best I have.

 

So I remembered a spare Classic I board, and tried it in place of the II board. It turned on to this: IMG_0604 Partial success! So the analog board is good, and the logic board is not.

 

So, aside from replacing the logic board, which is likely going to have to happen, what could I do?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...