Jump to content

Mac SE/30 partial boot to HD then "Failed to Initialize Disk" error


Recommended Posts

Hi everyone ... first post for me here. Have a bunch of early model macs most of them working but having trouble reviving my SE/30. 

 

Recently had the logic board recapped, just got it back and was happy to see the happy mac icon after reassembly. Looks like it boots to Sys 7.X on the internal (original) 80MB HD but near the end of the boot sequence after all the Sys 7 icons are displayed and I'm expecting to see the internal HD icon in the upper right corner, I get a pop-up message saying the disk failed to initialize. Also seeing that the floppy drive isn't recognized, as I tried to boot from floppy disk and got nothing.

 

Tried connecting a good external 1GB SCSI HD, which I had some trouble getting to connect and boot but then same error ... which leads me to suspect this is not just a HD problem. 

 

Will take the machine apart and put a known good HD in and retest ... but wondering if anyone here has seen this partial boot then "failed to initialize disk" popup error?

 

Thanks,

 

Craig

Link to post
Share on other sites
  • 68kMLA Supporter

I'd try it with the internal floppy disconnected. This is acting like it thinks there's a disk in the drive when there's not. The fact that you can't boot from floppy further makes me think it's something with the drive.

Link to post
Share on other sites

Thanks for the suggestion. Problem solved with a new (old, but working) hard drive. Apparently the partial boot succeeded until a read of bad sectors or other drive failure. Never saw this kind of error message before, which is what threw me. The floppy drive wasn't working because it had become disconnected at the drive itself, so when I reconnected it to the newly recapped motherboard it wasn't really connected.

 

All back together and working beautifully. 

 

~C

Link to post
Share on other sites

I have a working (for how much longer?) Quantum 40meg. I would love to save it if possible, any suggestions? That being said though, I have put the HDD away in my SuperComputerCloset , and replaced it with a 4.5GB IBM, but it would be nice to save it if possible.

Edited by Themk
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...