Jump to content

Yet another Macintosh Portable repair thread.


Recommended Posts

  • 3 weeks later...

I'm back: same portable, different issue.

 

I mentioned before that I have been having problems with the hard drive. I've tried a few things; bear with me as I list them out.

 

I had a few successful boots from the drive (with a 6v battery clipped to the battery bay connectors, and the adapter plugged in) before I did anything to the hybrid, though it progressively got less reliable, sometimes crapping out after the initial spin up, only to "catch" on the second spin up. Sometimes it would never get going.

 

I cracked the drive open and cleaned out the goo. It all appeared localized to the groove. This had no appreciable effect.

 

Around this time I did the hybrid board work. Battery only from this point on.

 

Post hybrid board work, behaviour remained the same... Very rare for the drive to 'catch' and read on a spin-up, but it would on occasion.

 

I decided to try swapping in the Conner HD from my IIsi, by swapping controller boards. The IIsi drive didn't work in the portable with the low-power board, and the portable drive didn't work in the IIsi with the regular molex/scsi board. The IIsi drive worked fine in the IIsi when reunited with its original board.

 

Assuming that the low-power board and drive were dead, I built an adapter cable as described here: http://antinode.info/mac/port_scsi.html

 

I connected the IIsi drive up in the portable with this adapter cable, and on boot, the portable showed me the 'Welcome to Macintosh' screen... And then the drive spun down, and got stuck in a spin up / spin down loop.

 

I tried again a few times, with similar results. It seemed like it was having the same problem that it had with the low power drive.

 

AND THEN IT WENT BOINK.

One boot game me the chimes of death.

post-2642-0-03507100-1492478941_thumb.jpg

I disconnected the hd, but it didn't have any effect. I figured I had well and truly wrecked it, as it came up exactly the same on several reboots.

 

...Then, 10 minutes later, it chimed up as fine, and gave me the disk missing icon. It booted fine off of a floppy, and off of FloppyEmu after that.

 

Curious to know if anyone has any ideas, given this scenario. The portable still boots fine off of a FloppyEmu​, so it's not just a pretty prop, but I'd love to get an internal HD back into the mix. I'm a little leery of trying anything to that end at the moment, given this misadventure.

Link to post
Share on other sites

Now, another guy here just discovered the little switch in the back of the battery compartment became intermittent and was doing very strange things similar to what your having. 

 

There are 2 red wires on the 4 pin molex connector that go down to the logic board, both red wires have to be HOT at battery voltage at all times! if one of them drops out (because of the switch being bad or completely dis-engaged with the cover removed) it will never ever ever work properly. 

 

Also CD34/CD36 is a PMGR read fault. usually occures at the nexus between the VIA and the PMGR IC. But I wouldn't trust that until you iron out your voltage issues. 

Edited by techknight
Link to post
Share on other sites
  • 5 weeks later...
  • 1 month later...

I hate to leave a thread like this open ended, in case someone else is pursuing the same issue in the future.

I pulled out the portable this weekend, as I finally had some free time to address this issue.

I set it up and powered it on to refresh my memory regarding its unusual behaviour.

 

It booted right up -- no problem.

 

It ran solidly all weekend, both off of battery, and off of power adapter.

It worked through an HDD init and OS install; it worked though software intstall from floppies; it worked through software install from FloppyEMU; it worked through AppleShare serial file transfers.

I shut it down, restarted it, sent it to sleep and awoke it I don't know how many times, and it always worked perfectly. I moved it from place to place, still worked.

Even the HDD inactivity spindown and corresponding spinup worked perfectly.

 

Here's the thing, though -- I didn't do anything since my last post.

The problem seemingly resolved itself.

 

The only two variables I can think of are:

1. It is now summer - ambient humidity is higher.

2. It was stored in the Macintosh Portable bag in a vertical orientation for the past few months.

 

I'm thinking that the latter is more likely to have had something to do with it - perhaps there was some stress on the board that was causing a cracked solder joint or an iffy trace to open up.

Maybe the 'rest' time in the bag allowed the stress to ease.

 

 

 

 

Link to post
Share on other sites
  • 6 months later...

Done for now:

 

Best I can figure: there's something off in the charging circuit which causes my portable to act up after charging a battery in the bay. 

 

If I charge a battery in the portable with the original portable AC adapter, it sometimes gets unstable, and will not boot afterwards for a while.

 

Fortunately, I have the external battery charging tray; charging the battery exclusively on the tray, and not in the portable itself, has been a consistently workable solution for me. 

Link to post
Share on other sites
  • 9 months later...

hello all!
sorry for my bad english... i can't write so more here
This is my topic from another forum:
http://www.vcfed.org/forum/showthread.php?35664-Macintosh-portable-not-starting

my macintosh portable not starting and i think i have problems with hybrid IC
I can understand about what resistor you speaking all? i need add 10 mOm resistor to the chip contact?
and what about black capacitor?
mac_500.jpgi.gif
i need to replece this? if yes, what is parameters?

Also maybe at some point of the board i can connect dirrectly GND, +5 and +12v from standart normal AT power supply
and it will be possible to test the board

Link to post
Share on other sites

anybody here? ))))

One time i can start notebook
I was add one resistor 1.5 mOm at hybrid IC and remove one capacitor
like this photo:
http://piccy.info/view3/12741639/d11111aa2fd9c56748034fe63b1c484f/

IMG_9327_thumb_jpg_3b7b91c57cf9ef9e0a76ai.gif
 

And connect 6v from my universal power supply and i was able to hear the sound from normal mac starup
But this has been only one time(((

Next time notebook not starting
I think i have some power problems, this is my start video:

https://www.youtube.com/watch?v=Mr2Fwf5GF8U

 

Also i was found this photo:
http://piccy.info/view3/12741644/853cab99253e1e87a03d5e95506f2f66/
post_6801_0_55939900_1491853567_thumb_50i.gif

I think maybe at this point of the board i can directly connect GND, +5 and +12v from standart AT power supply
and motheboard starting, or this is bad idea?
yes i know this is some another motherboard but few points are the same

Edited by monoxrom
Link to post
Share on other sites
On 10/31/2018 at 4:45 AM, monoxrom said:



Also maybe at some point of the board i can connect dirrectly GND, +5 and +12v from standart normal AT power supply
and it will be possible to test the board

 

If you do that, you are asking for a disaster. Electronics equivalent to Chernobyl. There is a little IC that will get in your way, and thats called the PMU. it looks for the 6V to be present before unlocking RESET and some other things for the system to come online, as well as the voltage regulators themselves. 

Edited by techknight
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...