Jump to content

Mac IIfx turns on but no chime


Recommended Posts

Yes the speaker was connected. I am lucky enough to have another logic board. I replaced many logic chips and still no luck. I'm thinking the main 68030 CPU might be blown. It happened before on another Mac II. I played around with the scope, but it's a bit hard without the schematics.

 

I'll hunt for a new CPU.

 

Do you know if I should at least get the startup chime *without* the 68882 co-processor?

 

Also, to get it, I must have at least for banks of RAM filled. Is that right?

 

Thank you.

 

Pitou!

Link to post
Share on other sites

Ah, in my case it turned out to be the ROM. I tried a ROM-inator II from BMWOW and it's working now.

So now the question is: Is it possible to repair the bad ROM? How do I go about troubleshooting it? I don't see any replacement Mac IIfx ROMs available anywhere but I'm interested in restoring OEM parts as much as possible..

Link to post
Share on other sites

if the ROM is bad, then it COULD be suffering from bit-rot if it started life as a PROM so it works exactly like EPROM but with no window. So you burn it and its done. 

 

if its mask-ROM its likely something different like failing buffer circuits etc internal to the IC. 

Edited by techknight
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...