Jump to content

Recommended Posts

Hi everyone,

I recently got back into my Apple /// repair, and I've come to a point where I need some help.

I have the 5V RAM board, 256k model.

Earlier this year, I tested my power supply, and although the +12V line was stable, the +5V line was jumping all over the place. I replaced all the electrolytic and filter caps on the supply, as well as a faulty transistor. 

The supply now is stable, and I measured these output voltages with no load:

For the +12V supply: +12.03V

For the +5V supply: +5.12V
For the -5V supply: -3.96V
For the -12V supply: -10.38V

Obviously, the -5V and -12V supplies are a bit low for comfort, but I don't know where to look next to fix this.

 

Also, now the supply powers on the computer, and the screen displays a flashing configuration of random characters. I've since recapped the RAM board and the main logic board, but nothing has changed. When I run the machine without a RAM board, the screen just displays all white. The LED on the main board lights up, as well as the keyboard light. The Control-Reset key combination still works as well. 

 

I don't exactly know where to proceed from here. I've got a couple //e's here that I'd be happy to salvage parts from, if need be. I'm under the impression that they use the same RAM chips as well. Once, I tested all the RAM from the /// in my //e, and it all checked out fine (as far as I remember), but that was a while ago.

 

I've got a multimeter here that can check voltages, resistances, continuity, etc. Unfortunately, I don't have access to my scope at the moment.

 

Pictures of anything available upon request.

 

Thanks!

- fri0701

Edited by fri0701
Link to post
Share on other sites

Hmm - I just recapped a /// power supply myself, and got almost identical low readings on the -5 and -12 lines as you did.

 

Like you, I'm not sure where to look next for that, or if (based on what you got as well as me) it's normal for this supply. Previous to the cap job the values were almost exactly the same.

 

Of course, there's always this guy:

 

https://www.ultimateapple2.com/catalogzen154/index.php?main_page=product_info&cPath=1_16&products_id=106

Link to post
Share on other sites

According to the original Apple /// repair manual, the three voltages are +11.8V, +5V, -5V, and -12V. 

 

Talking to someone who's familiar with older supplies like this, he says that the acceptable range is -4.75V to -5.25V for the -5V supply, and -11.4V to -12.4V for the -12V supply. Can anyone confirm this?

 

Admittedly, I've been tempted by that universal supply before, but where's the fun in buying a replacement?  [:)]]'>

Link to post
Share on other sites
  • 6 months later...

Hi everyone,

I'm back for the holidays and am giving another go at this stubborn Apple ///. I'm happy to announce that I think I'm getting somewhere finally!

 

When I recapped my power supply a while ago, I found a suspicious testing transistor in place of where IC1 should go. After researching it a bit, I discovered IC1 is a voltage regulator (there was no information on the transistor that was taking its place). I just ordered and installed the original IC1 chip, as specified in the original Apple schematics (TL431CP). With this chip installed, at first, it looked as if nothing had changed. Then I examined a bit further...

 

It turns out that now, the screen no longer flashes random characters, as it used to. Now, it simply shows a non-moving screen full of "characters" (more like a character-sized pixel pattern, all the same, filling up the entire screen). I am only running a single row of RAM on the upper row. Even when I remove any subset of these chips, even all of them, the same pattern comes on the screen.

 

Furthermore, I tested the supply under load from the computer while it was running. Here's what I got:

+12V supply: +12.66V (5.5% error)

+5V supply: +4.98V (0.4% error)

-5V supply: -4.90V (2% error)

-12V supply: -12.34V (2.83% error)

 

I believe these voltages are all within reason! (ScutBoy, perhaps this is why our supplies both had the -5 and -12 supplies measure lower than expected, since we weren't measuring under load)

 

I think now that the PSU is stable, the next thing I might try would be to simply replace all of the RAM chips. My testing strategy of placing them in my //e has proven unreliable, and I wouldn't be surprised if any of them have gone bad in the process. I believe they should all be D4164C chips. Does anyone know a good place to buy these from? I don't believe you can buy them new anymore, and so far, the only place I've seen to buy them in the quantity I need is off eBay. I'd really appreciate any thoughts on this, as well as any insight anyone might have into the current repair state of my machine.

Link to post
Share on other sites

Anchor Electronics in the South San Francisco Bay area has 4164 RAM chips, but I don't know what, if any, difference there are between those and D4164C chips.

 

http://anchor-electronics.com/price-list.pdf

 

 

Where are you located?  I have a 5V RAM board from my spare (re: board needs to be recapped) Apple III.  Before I blew a capacitor on that board, the machine worked just fine.  If you are somewhat close, I could lend you the RAM board and see if you get any different results.

Link to post
Share on other sites

Thanks for your input. I've ordered some new RAM and we'll see what happens.

I appreciate the offer, khannonnd, but I'm in Michigan and I doubt you'd like to send it off that far.

 

I've already replaced the one electrolytic capacitor on the RAM board, checked the continuity of all the pins and traces, and am ordering new RAM. Is there anything else on that board I should check or anything else that could go wrong on it, to anyone's knowledge?

Link to post
Share on other sites

Im faced with the same questions on an apple ii psu. +12.2, -11.2, +5.3,-4.9 volts.

 

I have recapped the psu thinking the -11.2 would increase a bit but the recap resulted in no change at all

 

From reading this thread it seems a voltage regulator controls the output voltage. Would this be correct for an apple ii psu? If so what chips does this

 

Ment to add... those are the readings of the psu unloaded. Would the readings be different if it was plugged in and running the board.... I guess the readings would be even lower

Edited by falen5
Link to post
Share on other sites

Do not EVER test PSU voltages without a load connected. Period. They will not be accurate unless a load is connected. And yes, this often manifests as the voltage appearing too low with no load connected. The regulator circuit just does not work right without a load connected.

Edited by techfury90
Link to post
Share on other sites

techfury90 - just re - metered the psu while plugged into the board, read the values from the back of the board and all values within .3 of where they should be!!

 

looks like i recapped it for nothing..........but sure news caps wont do it any harm anyway and i got a good clean in the process

 

great stuff

 

 

 

thanks man

Link to post
Share on other sites
  • 5 months later...

Hi everyone,

Well, once again, I'm back to attempting to fix this stubborn ///. I've made some progress, and I'm hoping someone experienced enough can recommend what I should try next. 

 

I've caved, and purchased a Reactive Micro Universal PSU and installed it in the ///, with no change. At least now I can be definitely sure that the power to the system is clean and functional. All voltages check out.

 

I also (finally) got my oscilloscope up and running, and probed some chips based on this guide: http://www.willegal.net/appleii/appleii-repair.htm

The 6502 CPU is running correctly, it seems, with the reset pin jumping to high as I start the system. The reset pin jumps to low and back to high whenever I push Control-Reset on the keyboard, which is a good sign. I can see activity on the various address and data lines, as well. My RAM chips are new, and I doubt they're the problem. I've tested the Vcc supply on all chips, and they are all at the correct voltage.

 

However, my screen is still a flashing mess of jumbled characters. When I remove the 5V RAM board from the system and turn it on, the screen is solid white.

 

Is anyone here experienced with digital logic troubleshooting, who can guide me through where to check next with my scope? I unfortunately don't have any spare chips to swap and try here, although I do have some spare Apple //es that I could harvest from, and I could definitely order replacements if needed.

 

I'd really appreciate any help to finally resurrect this beast!

- fri0701

Link to post
Share on other sites
  • 4 weeks later...

UPDATE:

Looking at the voltages on the 6502 processor, something doesn't seem quite right. The address lines look like clean square waves, but they are only about 3.5-3.7V peak-to-peak. The data lines look very distorted and jumpy. The clock signal on pin 37 is only running at ~1MHz, and also is around 4V peak-to-peak. The Apple III should run at 2MHz, and transition to 1MHz when the processor is reset. However, it seems mine runs at ~1MHz, and doesn't transition when the processor is reset.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...