Jump to content

Start-up problem Centris 650


Recommended Posts

Hello Again,

 

Having got my maxxed-out Centris back up and running a couple of months ago, I've suddenly hit a problem. I was installing Mathematica on the Centris a few weeks back, when suddenly it all went awry; I don't think it was anything to do with the installation of Mathematica, but after doing that the Centris stopped working properly. In a nutshell, here is what has happened:

 

  1. The Centris started having real problems reading the SCSI2SD which is the main drive for the computer;
  2. I tried a whole range of different things relating to the SCSI2SD, but started getting system faults and errors, especially with regard to reading from any SCSI device; This culminated in the computer failing to start up at all. I cant remember whether I got a sad mac or bomb at start up, unfortunately.
  3. I removed the SCSI2SD completely, wiped the SD card and have been trying to do a re-install of the system 7.5.3 software, both from CD-ROM and Floppy Disks; Despite repeated attempts, the computer kept losing sight of the SCSI2SD and failing to install the system software. The computer sometimes saw the SCSI2SD, and would ask to initialise, but this would always fail after a short time. After one or two efforts, as well as not seeing the SCSI2SD, the Centris no longer read or recognised the CD drive
  4. Thinking it might be an issue with the SCSI2SD, I tried to install using a blank (but known to be working) Apple Hard Disk, from floppy disks. Still no joy; 
  5. I have then just tried to get the computer to start up fro the Disk Tools 1 floppy. The computer starts up, and I get a happy mac icon, and the system boots up to the desktop, with the menu bar across the top of the screen. However, I don't get any disks appearing on the desktop (not even the floppy disk that is being used to drive the system), and the pointer just sits as the wristwatch, which is initially spinning (accompanied by sound of the floppy disk being read), but then freezes, and there is no noise from the floppy disk. At this point the computer hangs up; I can still move the pointer around the screen, but the computer is no longer responsive. 
  6. I have repeatedly tried this startup, with the same result, even after leaving the computer for over an hour to see if it can get over the hang-up, but with no joy.

I have checked the SCSI2SD in my mac Classic, and that is working just fine, as is the Disk Tools/System floppy disk, so it has to be something in the Centris. I have taken it apart, and checked cables, connectors etc on my Classic, and these are all working fine, and a visual check of the logic board hasnt highlighted anything obvious.

 

Any suggestions regarding what I can try next? I will take the logic board out of the computer and give it a thorough check and (another) clean, but does anyone have any ideas where I should be looking? It cannot be a major problem, as the Centris seems to nearly get there, and when I boot from floppy the Centris passes all the initial checks that allow a happy mac to show, but I'm completely stumped!

 

Cheers,

 

Simon

Link to post
Share on other sites

Thanks for the responses, although sadly I have already tried both of these suggestions with no joy. The SCSI2SD works fine, as I checked it using my Mac Classic, just switching the microSD cards over as System 7.5.3 runs dreadfully on the classic. No problems with the hardware or firmware, which has been upgraded and repeatedly replaced. The MicroSD card is fine too, checked on my eMac and everything opened fine in BasiliskII.

 

The CD drive has been disconnected for quite a while now, and is currently sitting in a plastic crate with much of the other innards of my Centric (additional RAM, HDDs, NuBus card etc...). Right now, it is just the floppy drive, logic board and power supply in there! I've also checked the SCSI cable (fine), so it must be something either in the on-board ROM, or elsewhere on the logic board that is causing the computer to hang at the very final stage of startup, before it mounts files and disks on the desktop. I don't know whether there is a specific area that deals with SCSI connections, but that would be my next guess, but I do not have the faintest idea where to start!

 

Keep the ideas coming!

Link to post
Share on other sites

SOLVED!

 

It turns out there were a couple of separate things that needed sorting out...

 

  1. The installation of Mathematica messed up the Desktop File on the Mac SSD (My SCSI2SD), which I believe is stored in the NVRAM, so no matter how many times I zapped the PRAM (which I did many times), was resulting in the hang-up whenever I tried to start up, be it from the SSD or from the Disk Tools 1 floppy disk. Good old command/alt during startup allowed the rebuilding of both the SSD Desktop File and the Disk Tools Desktop File, which allowed the Centris to reach full booting up.
  2. It turns out my SCSI lead was defective, albeit only intermittently (last time I use a new cheap Chinese replacement part bought on eBay!). I went back to basics, and used a simple (just one SCSI connector) cable from another Classic, and managed to get the SCSI2SD detected and working! I've now added a two connector cable (again scavenged from an old mac), and both the CD and SSD are detected.

So, hopefully the problem is solved... I'm currently re-installing 7.5.3 from a disk image kept handily on the MicroSD card, and it has just told me it was successful. Now for a restart to see if it boots properly from the SSD.... and, YES, WE HAVE LIFTOFF!

 

So it took a bit of going back to basics, but I think I am finally back up again!

 

Thanks for the suggestions, and I'm relieved to have this back up and running, I have spent a few pounds/dollars on this Centris, and would have been very upset if it was no longer working!

 

Cheers,

 

Simon

Link to post
Share on other sites
  • 3 months later...

The Deshtop file is on the "hard drive" not NVRAM. Back in the System 6 days, WDEF, MVir and several others infected the Desktop files on disks and spread infection passing an infected disk into clean systems.

 

You got a copy of Disnifectant? Get is and run it through the system. To me it sounds like Mathematica is infected with something.

Link to post
Share on other sites
  • 2 months later...

Sorry for the late response but I do have a copy of Mathematica installed on one of my hard drives, but I don't know how good or complete it is. It actually came with the Centris when I bought it (along with early MATLAB, and a few other scientific data analysis packages), but since these startup (and a few other) problems arose I have removed the drive, cloned its contents into a disk image for safe keeping against the day when I get my Centris fully back up and running...

 

Not sure whether the application folder contains all the files and additional bits needed to install Mathematica, but once the Centris is fully back online (literally), I will see what I can do!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...