Jump to content

Flaky ethernet on SE/30


Recommended Posts

Have an SE/30 that I had added an Diimo 030 accelerator board and an Asante MacCon ethernet card added in series into the PDS slot. I had lost sound, so I sent the logic & analog boards off to uniserver to have them recapped. I DID NOT send the power supply for recapping. 

 

 

Once I got the logic/analog cards back, I put the machine back together, and re-installed the add-on cards. With both add on cards back in the machine, the accelerator card seemed to work, but the ethernet card did not, not even getting a link light on the daughtercard (next to the RJ45). I pulled them both out, and put only the NIC back into the SE/30, and I got a link light... But when I tried to use the card, it would connect to the web, but downloading was sporadic... stalling often. Asante troubleshooting showed that the card was having errors about half the time. 
 
My question is: Could the power supply be causing this? Should I have the power supply re-capped? Or does it sound like some other issue -- maybe with the NIC? 
 
My guess is that maybe the power supply is weak, which is why the NIC would not work at all when the accelerator was in there with the NIC. Was wondering what any of you may think. Any advice would be appreciated.
 
Should I have uniserver recap the PS? Are there chips on the NIC that need recapping???
 
Thanks in advance..

 

Link to post
Share on other sites

Sounds like you've done a good job of troubleshooting so far. I expect it's an internal hardware issue as you suspect. For the sake of fastidiousness, have you tried connecting another computer to the same Ethernet cable coming out of your 10-base T hub? Your power supply hypothesis makes sense to me, but I'll let the experts weigh in there.

Link to post
Share on other sites

knowing what i know about SE power supplies... and how much heat those DIMO cards make... my suggestion is the psu...  ARTMIX is well aware of the general PSU issues with the SE... even with good caps.....  The psu in the se is pretty weak, and with a CPU up grade AND the nic on that....  yeah...  I haven't met a SE psu yet that didn't have leaking caps.  Artmix sells this crazy re-done psu for people that like to mod their SE/30's  but they are pretty expensive.. he basically rips the guts out and shoehorns in modern high output SMPS guts in there...  I am fairly confident that changing the caps in that psu will make it good...  considering you are unnaturally loading it down with that High Output CPU card + NIC card ontop of that.

Edited by uniserver
Link to post
Share on other sites
  • 6 months later...

Update: So Uniserver has recapped all parts of the SE/30, but still no joy. We recapped the motherboard, the analog board, the power supply, the ethernet card (and it's daughter card) and the accelerator card. But the SE/30 still acts the same way -- with no cards in it, it works fine. With ONLY the ethernet card installed, the computer can see the ethernet card, Open transport loads, and it can send a few packets - I've even printed using it. But trying to transfer a file just does not work. It starts the file transfer, and eventually just fails. When using the Asante troubleshooting tool, it reports random errors with the packets sent. 

 

When the ethernet card is installed WITH the accelerator card, the accelerator card works fine, but the SE/30 cannot see the ethernet card at all. 

 

Both cards worked well in the machine before any recapping was done, and I know that recapping was needed, but would it be possible that one of the new caps on the motherboard might be out of spec, and might be causing this? Tantalum caps. Any other ideas???

Link to post
Share on other sites

Uniserver did the recapping, and word is around these parts is that he does excellent work. But the problem did start when it was recapped. But otherwise the computer works fine, and works fine with only the accelerator card in it... 

 

It's just the wierd thing that the ethernet card is seen by the computer when it's in the machine by itself, but not seen at all when it's connected atop the accelerator card... This was the exact same configuration that it was in before I sent it off for recapping - and both cards worked fine then.

 

I don't think it's the cable. I've tried both a standard 4 port 10MB hub, and also an 8 port 10/100 switch. 

Link to post
Share on other sites
  • 4 weeks later...

The problem ended up being the ethernet card itself. Bought another MacCon ethernet card off eBay, and though it did not work at first either, after examining it, and cleaning up a bit of dribbled rust on one of the ICs, it worked fine. Switched back and forth, and isolated that my original card must have something hosed on it... SE/30 working fine now with both the Diimo accelerator card and the ethernet card inside. Thanks for all the suggestions. and thanks to Uniserver for a great job recapping.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...