Jump to content

It wouldn't let me navigate to make sure this wasn't already covered.

Recommended Posts

OK, so I'm stumped on this one. I've tried to look all over here as well as everywhere Bing and Google would show me and they were not taking me to where I needed to go.


I have an Apple EtherTalk NB Card running in my 8MB RAM, 80MB HD, 32KB cache card Macintosh IIci and it wants to connect to the network. It can't get a link. It's running System 6.0.8 with Network Software Installer 1.4.5 installed, and MacTCP 2.0.6.


I have to give the Comcast DNS servers rather than making the wireless router the DNS server like Open Transport on Mac OS 8.6 and later. I read that sometimes MacTCP needs different defaults than Open Transport, and so I put the Comcast DNS servers in rather than letting it use my AirPort Base Station as a DNS server the way you can with Open Transport.


The current networking hardware setup is a 802.11b AirPort Snow/Dual Ethernet UFO base station along with a 10/100Base-TX Ethernet switch I occasionally use that both of them features System 6 obfuscating features such as auto-negotiation as regards duplex, auto-sensing as regards whether it's 10baseT or 100Base-TX, full duplex (because all other Macs on my network support operation that is supposedly a toxic trio for a System 6 Mac with a 1989 vintage Ethernet card that just barely supports AppleTalk Phase 2.)


What happens when I have it hooked up using the best available connection system is that the IIci properly initializes the card and goes ahead and sets MacTCP to connect via Ethernet, and AppleTalk to connect via EtherTalk the way it says you should do under the article about Classic Mac Networking.


If I change the settings software or hardware-wise from what I read should work (and does work as much as possible) for my situation, I get the famous error that "There was an error starting your AppleTalk connection. The built-in LocalTalk port will be used instead."


According to years of research, if it doesn't say that message, that means your settings are correct for the network you want to use. But since the network is auto-negotiating, auto-sensing, and full duplex (because all my other devices support those three items), the IIci can't light up the link signal on the transceiver. At least that's what I am theorizing.


If the transceiver wasn't compatible with the card, then it would fail to get EtherTalk going according to everything I've read. But yet with those three advanced features on the router end, that combination is what to me seemingly not allowing it to establish a connection. It even works well enough that if you disconnect the Ethernet cord, it knows it's been disconnected and you have to zap the PRAM in order to get the IIci to not display the expected error message until you fiddle with it again (i.e by moving it to a different port, such as a port on the external 4-port 10/100Base-TX switch or on a different router.)


If I'm barking up the wrong tree here, then I want to know why it seems to work in all areas except getting a link (and of course, through the link that it wants to have but does not, being able to work with my other computers and the Internet.)



Link to post
Share on other sites

OK, so I found a PDF of the Apple Ethernet NB Card installation guide. It says the DB-15 connector I am using is a standard Ethernet port of that type (i.e. a standard AUI port.) If it's a standard AUI port, it should just work the way I've got it, especially since the AUI cable's pinout matches that of the pinout on the DB-15 port on the card.


The ROM may prevent it from fully working on a 10baseT MAU, but I can always (once I have more money) get a 10base2 to 10baseT media adapter, but I'd really like to be inventive and find a way to make the "standard Ethernet port" on the Apple EtherTalk NB Card become fully useful by modifying the driver so that the card's firmware lock-in to ThickNet coax on the EtherTalk NB Card isn't removed, as it would be by changing the ROM chips on the card, but instead bypassed. This would not just be cheaper. but it would be far more fun.


I want to utilize the IIci as a network terminal that can take what I love from newer Macs and gets them to the System 6 space, as well as doing some retro web browsing.


At this point I don't know whether it's a card limitation (which would have to be worked around) or if it's an issue at the router end.


Thanks everybody for listening.

Link to post
Share on other sites

From my experience, the Apple Ethernet NB card will work with any standard MAU. I don't ever remember needing special MAUs. Then again, I was running System 7, and perhaps the A/ROSE extension was newer and provided some changes.


If I remember correctly, you can set the port speed and duplex on the Airport. Can you try setting to to 10base-T at half duplex, then connecting directly to the Airport and see what happens?


Another thing to test is to statically assign your TCP/IP information and use a Unix(y) machine to run tcpdump to see if there's any traffic coming from the Iici.

Link to post
Share on other sites

The AirPort Utility software for 9 and X doesn't seem to offer a port speed selection option. If it is there, I've never been able to find it in Mac OS 9.2.2, X 10.1, or X 10.3 (my Jaguar install CDs died and so I can't see if Jaguar offers that.) It's miraculous that the IIci will work with a standard one of these things. If I was to put System 7 on the IIci, then it would be more stressed and that's what's got me running System 6 as I'm not interested in speed so much as stress, but if I can get the IIci's hard drive with a stable System 7.0.1 install that might just go a whole lot better. The only thing other than stress that makes it inconvenient is my Power Mac G4 Quicksilver I use to load a full OS onto the IIci (that's how I got System 6 on there) when I install the 80MB hard drive with System 7 the Quicksilver will try to boot from the 80MB SCSI hard disk instead of the startup disk selected in the Control Panel and there's no way to bypass it. Which means that once I put System 7 on the IIci I can't make any other changes.


I wish I knew how to force the LAN port on the AirPort to go to 10baseT half duplex because your reply has been so very helpful. I'd be more enthusiastic, but I'd get in trouble ;)

Link to post
Share on other sites
  • 1 month later...

Update on my IIci as regards networking:


I finally gave up on the MAU for AUI to 10baseT, bit the bullet, and bought a 10base2/RG58/BNC to 10baseT media converter. That got me a link to a 10baseT half-duplex vintage hub that connects to the Ethernet switch attached to my AirPort Base Station, which attaches to my cable modem. Since the media converter only does 10baseT half duplex, efforts to try to connect it directly to the switch fail. Now I'm try

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...