Jump to content

Search the Community

Showing results for tags 'not power on'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 1 result

  1. Hi everyone. I'm new to this forum. I have a collection of about 35 machines and with my brother we're planning an exibition in my kid's school for the sience week. I've been away from my loved machines for a while, since life with small kids demands a lot of my free time.... Ok. So I went back to the shelves I've started turning on some machines among then my "pet" a IIsi. Din't power on. So. Open the lid and found the battery leaked. I cleaned the acid with alcohol, but don't know what else can be wrong. The oscilator's metal cover have rusted since the last time I recall. Perhaps I can
×
×
  • Create New...