Jump to content

Search the Community

Showing results for tags '520'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 5 results

  1. Every time I try to boot from my LC 520's internal SCSI hard drive bay, it hangs. My external SCSI drive never fails to fully boot, however. I have also swapped the drives and the same thing happens, so I'm led to believe it's the internal hard drive bay itself. All pins are intact, unbent and clean. I have tested both drives on numerous other systems, both 68k and PowerPC, and they work fine every time. Can this be a logic board issue? I've never heard of the internal bay not working while the external does, especially if they're on the same bus. Could it be a capacitor issue? They are long o
  2. Hopefully, this would come in handy for anyone curious about the PCMCIA module made for the PowerBook 500 series. I've posted as many pictures from various angles of the board assembly and parts (in case anyone has interest in planning modifications and how much space is inside the module) as I don't intend to open this up very often. If at all. There are three hex screws, one plastic tab, and a sticker holding my Rev C module together. I didn't have a hex bit of the correct size, but a Torx T6 proved a snug fit that allowed me to remove the screws. When I depressed the plastic ta
  3. Hello! At some point around high school (somewhere around '99 or '00), my parents got my nephew and I "new" Powerbook 540c's which at the time gave us intermittent problems, but which I got some use out of nevertheless. After years of neglect, I turned mine on briefly back in 2011 to see what was on it and to retrieve a few things, but otherwise it has basically been sitting around unused for quite awhile. I decided recently to try pulling it out once again but was disappointed to find that, other than a meek squeal, followed by the boot chime, it wasn't loading the system, not even a bl
  4. I need a bit of help to fix a powerbook 500 series battery. Battery recondition doesn't work. The computer used to sense the battery, but now it is not usable. However, the battery still gives off some power. I'm thinking of recelling the battery in the future. Anyone got suggestions? (because i'm not paying 200$ for a new battery.)
  5. So my PB has issues. I don't care- THE MODEM CONNECTOR IS MISSING! WHERE HAS IT GONE?! THIS IS THE END!!
×
×
  • Create New...