Jump to content

iMac600

68020
  • Content Count

    2541
  • Joined

  • Last visited

1 Follower

About iMac600

  • Birthday 01/01/1991

Profile Information

  • Location
    Australia

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Alright, LeopardAssist III Release Candidate 2 is now available. http://leopardassist.sourceforge.net (SourceForge, 3.1MB ZIP) https://www.macupdate.com/app/mac/26562/leopardassist (MacUpdate mirror) It has some extensive under-the-hood changes from v3.0-preview (RC1). So many that It could have been considered a version increment to 3.1. The changes include: Extensive rewrite of the UI code Extensive rewrite of the Backend (interfacing with OS/NVRAM) code Minor UI changes Limited customisation of startup options now available on G5 systems. Added option to boot f
  2. Just had the chance to listen to the attached MP3. Definitely not the Floppy Drive, but similar to the sound my 512Ke was making with the Floppy Drive disconnected. Mine is a 220v version of the Analog Board, so the component layout is a little different and the solder joints on the Flyback may be a little different. However, considering the symptoms, I wouldn't rule out the solder joints on the Flyback as a possibility.
  3. My Macintosh 512Ke did exactly the same thing. The Plus uses the same Analog Board, so it's relevant here too. No Video / Loss of Video on Display "Flup", "Whup" or "Blip" noise from inside machine First of all, I think you'll find that the noise is from the Floppy Drive, as it attempts to start up over and over again. Listen closely to the drive from the opening on the front of the machine. It sounds like you have a solder joint issue. In the case of my machine, the problem was simply the result of cracked solder joints on the Flyback Transformer. Like yourself, I left the
  4. It took a few days for the smell to completely clear out of the room. The machine still smells like it somewhat. What makes matters worse is that the capacitor leaked everywhere, both inside and outside the power supply. After moving the machine following the smokeshow, I found it had made its way out of the case and onto my desk too. Of course, anywhere the fluid ends up, the smell ends up as well. Here's a tip. If you clean this stuff out of the PSU, wear gloves. Five days later, my hands were still stained with the stuff that came out of that cap.
  5. Cheers Techknight - I'll see what I find. The iMac is easy, I'll just run a couple of commands and grab the panel data, but the somewhat dead Studio Display will be a little more fun. Under Dog, I'm actually running iTunes 9 on OS X Leopard. I know it doesn't sound that fantastic, but since it handles the streams rather well and I can control it from my iPhone using the Apple Remote app, it's a surprisingly decent fit for the job. Other than that, all I've done is remove Spotlight, remove Dashboard and hide the Dock. Since yours is an iMac G3 it may run into some hurdles (mostly in that
  6. My iBook G4 did something very similar for a long time. You may wish to take a look at this page: http://www.xlr8yourmac.com/tips/ibookg4_vreg_repair/ibookg4_vreg_repair.html In a nutshell, the solder joint fractures on one leg of that chip, causing anomalies with the system such as random freezes, loss of video during operation or an inability to boot, among others. Performing that repair solved my problem. It could also possibly be something else, perhaps something GPU related, but those failures were much less common in iBook G4s compared to the iBook G3. I'd start with the VREG
  7. I've recently turned my iMac G4 (15-inch USB 2.0) into a sweet little stereo system, streaming internet radio stations down and playing it back through Apple's Pro Speakers. The entire thing is controlled from my iPhone as a remote. It's pretty sweet. I can't help but notice though that its 15-inch screen is looking a little tired. I have a 15-inch Apple Studio Display here, you know... one of these: Which has a fantastic LCD in it, but a dead Logic Board. Does anyone know what the odds are of these displays being electrically and physically compatible? It's a long shot, b
  8. It's more like "I've removed the restrictions". While I was adding some new properties to LeopardAssist, I added one called "Frequency". If the frequency property is disabled for any reason, it will skip the Clock Frequency step. One side effect is that instead of having LeopardAssist fail completely on the G5, I could just disable the frequency property. So, when LeopardAssist is run on a G5, you can still select boot devices: CD/DVD Hard Drive USB Ethernet Select On Startup (Multi-Boot) and Startup Modes: Normal Startup Verbose Mode Safe Boot Single User
  9. For the 68kMLA. Here's the latest compile of LeopardAssist 3 (Release Candidate 2) for testing. https://app.box.com/s/pc9cubid70edtgrmw4dj I've successfully tested it on my iMac G4, however some changes that need particular attention: LeopardAssist should now throw an error when being run on Mac OS X versions lower than Panther 10.3. No such messages should occur when being run on Panther 10.3 or later. LeopardAssist now supports G5-based Macs! While it won't change clock frequencies, it can still customise the boot device and startup mode (boot-args). Boot From USB is no
  10. I didn't expect Jaguar to work. It sounds like there's two issues in play here, firstly the script isn't writing correctly, possibly due to limitations with the command line tools that LeopardAssist depends on (grep, head, machine, nvram, sed, sudo, sysctl, system_profiler, tr, whoami) or the flags passed on to those tools. Secondly it sounds like the REALbasic 2007 runtime, which implements its own controls, requires Panther or higher. So I think it's safe to say that LeopardAssist on Jaguar is a write-off. I've also made a couple of changes based on a couple of requests I've received
  11. LeopardAssist III is almost ready to be released in its final form. At the moment the code remains mostly the same, differing only with one small UI change, new documentation and a small tweak to the debugging code (which only matters when being run in Debug mode and doesn't get compiled into the final anyway). So before I sign off on this one, does anyone have any last minute feedback or requests for changes or additions that should be rolled into the 3.0 final? I'm considering holding off on the release until I can get some feedback (or set up my own test system) on how it runs on Ja
  12. I can confirm a moderately successful boot on my iMac G4 (15-inch USB 2.0). As expected, the video is limited to 256 colours, there's no sound and no AirPort wireless. I'm running OS 9.2.2 with Mac OS ROM 10.2.1. I've tried applying the Apple nVidia Driver Update with no change. So while it works, it's far from perfect. Also, I'm more than aware that this iMac G4 needs to be cleaned.
  13. The iMac (17-inch Flat Panel) from 2002 is listed as an OS 9 compatible machine, and that has a GeForce4 MX in it. That particular version used the Mac OS ROM v9.5.1 which I also have. The difference appears to be that the later iMac G4s use DDR for the video memory where as the earlier ones don't. Perhaps I'll attempt to apply the modification to that version of the ROM, load up an appropriate version of OS 9 and see if I can get some video acceleration working. I have the NetBoot9 image around here somewhere that appears to be a fairly driver-complete version of the system. As fo
  14. I'm very pleased to report that it appears we have some success here! CC_333 tested the above modifications in an attempt to boot OS 9 on an OS X-only Mac - in this case an iMac G4 - and had some positive news to report: With the ROM modification, OS 9 was able to start up on this machine, albeit without full video acceleration. (UPDATE: Thousands of colours also works correctly.) Hopefully this overcomes the challenge of letting an unsupported Mac see a Mac OS 9 system folder as a valid bootable system. However it's yet to be seen whether this will prove beneficial toward
  15. The machine I used to document for this thread was parted out a couple of years ago, but it took me a while to get around to writing up the findings. The case eventually went to a case modder who then turned it into a Core i7 thing. Of course, before anyone starts removing their Logic Board for a BGA repair, make sure you have the correct memory in it first! Incorrect memory or memory in mismatched pairs will cause exactly the same symptoms and is so much easier to resolve. I haven't attempted to mount a fan on the reverse side of the board before. It's possible somethi
×
×
  • Create New...