Jump to content
jake18125

Vertical failure on SE/30 - logic board issue, HELP

Recommended Posts

So I have a bit of a problem

I recently acquired an SE/30 that was showing symptoms of vertical failure - on boot up it only displayed a single horizontal line.

After reflowing the joints on the P1 connector, replacing the TDA1170 on the analog board without any improvement I finally put my SE logic board in the case to verify that it wasn't an analog board.

What do you know it wasn't, the analog board on the SE/30 worked perfectly.

After probing the logic board with a multimeter, I found that the video PAL IC responsible for generating Vsync (part number 341-0747-A) just wasn't outputting anything. The 60.25hz vertical sync signal was missing. 

This led me to source a replacement video PAL, which unfortunately didn't change the output whatsoever. It still has a complete loss of vertical sync. 

I have also checked every single connection in the area in accordance to the SE/30s schematics, and I am now at a complete loss. I am thinking it could be the 74xx

series ICs by the video PALs, but quite frankly I have no idea (unfortunately I don't have an oscilloscope).

Hopefully someone has encountered this before and can figure it out!

 

Also when a boot floppy is inserted it seems to boot from it (obviously I can't see whats going on but it does react to the keyboard commands to eject the floppy)

 

Finally I just want to stress that this is NOT an analog board issue. My SEs logic board works perfectly fine in the SE/30s case, and the SE/30 still has no vertical when it is in the SE case. 

73DE0BC8-6743-41B1-9065-488FA237AF45.heic

Share this post


Link to post
Share on other sites

The counter at UF8 is broken. Have seen this before on a few boards. It’s right next to the dreaded UE8 and is just as likely to get bathed in cap goo.

Never actually seen one of the PALs fail.

Share this post


Link to post
Share on other sites

HEIC is high efficiency image codec. It’s what iPhones save their photos as by default. Blindsided me as well: I only learned about the format a few months ago.

Edited by LaPorta

Share this post


Link to post
Share on other sites

 

On 7/29/2020 at 10:54 AM, Bolle said:

The counter at UF8 is broken. Have seen this before on a few boards. It’s right next to the dreaded UE8 and is just as likely to get bathed in cap goo.

Never actually seen one of the PALs fail.

Thank you so much, replaced UF8 and it worked!

Ee1J5szXkAAk9CW.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×