Jump to content
cheesestraws

GEMDOS on the Lisa can be built again!

Recommended Posts

The original First Word, which is probably a fairer test as it is about the same age as this version of GEM, works basically fine:

 

61555333663__F3E33023-93A9-4A3B-AA40-55BE61557F14.thumb.JPG.ac2ee9de2a1f2cbf3621c8310281c93a.JPG

 

The fonts are a bit funky, and I suspect that might be what scuppering the Plus version, it's when it tried to redraw the text area that it segfaulted.  But as a proof of concept, this is indeed a piece of Atari desktop software running on the Lisa.

 

Anyone want a boot disc image? :-)

Share this post


Link to post
Share on other sites
11 hours ago, stepleton said:

*waves arms* I'll take one!

 

8 hours ago, sunder said:

To quote Zoidberg, "I'll take 8!"

 

Here's a couple of disc images which will let you run off floppy or install on a hard disc.  These are 400K DiskCopy 4.2 images.  You should be able to boot from gemdos11-boot.dc, and it should give you a prompt that looks something like

 

Command v. 0.38 8/16/85 LTG
{a} _

You can run GEM from the floppy.  To run it, just use the 'gemvdi' command.  This will load the VDI and display a message; it will then load the desktop.  Very slowly.  If you double-click on the 'A' drive at the bottom left of the desktop, you should be able to fiddle with the files on the floppy through there.  HELLO.APP is a simple hello world GEM application that ought to load and work.

 

You can install it onto a hard disc in the following way.  It's a bit manual at the moment, apologies, and has a lot of limitations.  It will probably only work on a 2/10 with an internal hard disc; it might work on a 2/5 with a hard disc hung off the internal port as well.  I haven't tried it.  And it will only see 5 meg of that hard disc no matter how big it is.  I am using an X/Profile with a 5meg STAR, personally.

 

First of all, create a filesystem on the hard disc.  This is very rude and does not ask for permission first, and obviously it WILL wipe out anything else on the disc (this utility is just the filesystem-creating half of the old FORMAT command).

 

mkfs c

 

Then "install" the OS:

 

copy gemdoshi.sys c:
copy command.prg c:
putboot c: hboot.abs

It is important that gemdoshi.sys is the first file on the disc, because it's a 1-stage bootloader that can't read the filesystem, it just loads the first thing it sees.  You should now be able to reboot and the machine will come up into GEMDOS.  At this point, copy the rest of the contents of the floppy disc (possibly omitting GEMDOSFI.SYS which is the floppy version of the OS executable and both the ABS files which are the bootloader) to the hard disc:

 

a:
copy gemvdi.prg c:
copy gem.* c:
copy meta.sys c:
copy *.fnt c:
copy desk*.* c:
copy hello.app c:
c:

at this point, you should be able to eject the floppy (Cmd-NumPadEnter, for some reason) and run 'gemvdi' to get to the desktop.

 

The second disc image contains some applications which are either useless or don't work, but prove (or don't) the concept.  I'd suggest sticking them in a GEMAPPS directory to make it easier to delete them later:

 

c:
cd \
md GEMAPPS
cd GEMAPPS
copy a:*.* c:
cd \

then, again, run GEMVDI to get to the desktop.

  • 1ST_WORD is a word processor that very nearly works.  Text redraw is funky, expecially when you select things, but at least it doesn't crash on startup.
  • DOODLE is a DR demo application which is... exactly what it says on the tin.
  • RCS is the Resource Construction Kit, the GEM rough equivalent of ResEdit.
  • ST-GUIDE crashes immediately :-(

Hope this is enough to play with for the moment.  I'm going to take a break for this for a day or so now and then work out what to do next with it.

Share this post


Link to post
Share on other sites

So it boots off an X/Profile on a 2/5. HELLO.APP works, but 1ST_WORD.APP causes a complete system hang when trying to create a new document. Make sure to have a floppy disk inserted if you try to access the drive, otherwise it will crash the system with Lisa Error 47.

 

Also: don't forget to copy ASSIGN.SYS and LISA25.SYS to the hard drive when doing your file copies.

 

9059a078-8694-4069-99e2-7f1420c6d602.jpg

Edited by blusnowkitty

Share this post


Link to post
Share on other sites
8 hours ago, blusnowkitty said:

So it boots off an X/Profile on a 2/5.

Great!  I'm pretty sure the port was originally designed for the 2/5 (hence the "25" in "LISA25.SYS").

 

8 hours ago, blusnowkitty said:

Make sure to have a floppy disk inserted if you try to access the drive, otherwise it will crash the system with Lisa Error 47. 

This is one of the reasons I get a strong feeling that this wasn't ever really finished; it was a demo platform, rather than a serious port.  Error handling is nonexistent (if you get an abort/retry/ignore prompt and press 'r' for retry, it actually restarts the machine, at least here).  I have found so many ways to crash this so far :-)

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×