Jump to content

Search the Community

Showing results for tags 'se30'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 20 results

  1. Hello everyone, I thought I'd start a thread on my own SE/30 repair experience both to document what I did for others and to solicit some advice on a few stubborn issues I can't resolve. I picked up a nice-condition SE/30 from Craigslist that was listed as "something's wrong with it". It turned out to be externally in great condition. It is a later unit (manufactured in 91 I believe) with the Astec power supply, original hard drive, and 4 1MB sticks of RAM. When I got it home I powered it on to a muffled, indecipherable sound and classic somasimac screen. There was no hard disk activity on boot. Normal cleaning I took it apart and found the logic board in decent condition. The original PRAM battery was installed, so I removed that along with the ROM and RAM SIMMs. There was clearly leakage from the capacitors and corrosion of solder, particularly in the typical UE8 area. I removed the electrolytic capacitors with two soldering irons, though I now realize the twist method is probably better. In the process of removing the caps, I lifted the + pad on C9. I used some 3M DP460NS epoxy to glue it back down and verified continuity afterwards. I next cleaned all of the bare capacitor pads by hitting them with a flux pen and then using solder wick in a gentle scrubbing motion. They all came out nice and shiny. I spot-sprayed flux remover where I had been working and used q-tips. Then the board went into a tray of 99% IPA for about 24 hours. I occasionally scrubbed some of the worst areas (e.g. UE8) with a toothbrush while it was submerged. Once it was dry, I soldered on the new caps (tantalum) and also replaced the axials. I plugged it in and powered it up to the exact same: somasimac and a weird muffled sound. I figured that there must be more corrosion/residue under some of the ICs so I went for a vinegar bath (5% acidity). I popped the board in the tray and let it sit for about an hour, again scrubbing the UE8 area occasionally. I pulled it out, rinsed it thoroughly in tap water followed by a 1 hour soak in 99% IPA to displace any residual water. Pulled it out, let it dry, turned it on and it worked! Still weird sound, but no somasimac, just a flashing disk. In the process of scrubbing around C13, I managed to completely tear off Q3 including one of its pads. I ended up replacing the pad by epoxying down a piece of flattened wire and soldering it to the exposed trace. I then cleaned the leads on Q3 and resoldered it to the pads. The system would start up fine from a floppy, but no sound was produced from the system sounds. It also wouldn't recognize any SCSI devices (either the internal HD, a new SCSI2SD, or a PowerBook connected to the external port in SCSI target disk mode. At this point, the board looks like this: SCSI troubleshooting I decided to tackle the SCSI issue first. I used the schematics here to trace al connections out of JI12 (the 53C80 SCSI chip). I also found this thread immensely helpful. As a result, I discovered that two connections (D4 and D5) between JI12 and the VROM (UK6) were broken. I reflowed the solder on JI12 and the connections were still bad. I checked the continuity through the vias for these pins on the bottom of the board and it was good. I decided to wire jumpers on the bottom side of the board. When I added solder to the via for D4, it actually started showing continuity again. Thus, I only ended up putting in a jumper wire in for D5. It looks like this: I reinstalled the logic board and it worked perfectly! The system booted instantly from the SCSI2SD and sound was perfect. Unfortunately now that the machine was working better, the power supply decided to stop working. It was outputting nothing and may be a simple switch problem. I had a Sony power supply to swap in so I did so and the system was back to 100% Sad mac/freezing/crashing/somasimac when "warmed up" So this brings us to the current state. Now that everything seemed to be working well, I started trying to actually use the computer. At this point, the case was on and it was upright as you'd expect. After maybe 10-15 minutes, the mouse would freeze or I'd get a system bomb and have to restart the system. I took the case off and set the system on its side to do some troubleshooting. The voltages coming into the logic board look fine (5.036V, 12.541V, -11.79V, -4.982V) and there is less than 12mV of noise on the 12V and 30mV on the 5V rails. Thinking maybe that D4 SCSI via had gone open when heated, I checked it (and my D5 connection) when hot and they were good. I decided to let the machine be and come back to it the next day. The next day I turned it on and it again worked fine for maybe 20 minutes. I decided to try installing the case and it continued working fine for another 10 minutes before freezing. Restarting resulted in the sad mac chimes but no actual sad mac. I pulled the case off and restarted again and it made it to the happy mac but froze. Restarted again and it booted successfully. Figuring it could be heat-related, I started heating different parts of the logic board with a heat gun set to 200 F. This resulted in no freezing/crashes. I checked it out with a thermal camera and noted that UG12 along with the DIP packages including UC6/7, UE6/7, and UG6/7 were the hottest parts of the board. Nothing else really stood out. I restarted it several times during this and it would usually work fine, but occasionally freeze after boot or with a happy mac. Thinking it might have resolved itself, I put the case back on and it instantly responded with sad mac chimes but no display of the sad mac screen. It did this in the same orientation it worked without the case (e.g. on its side with the analog board down, propped up by the metal frame). Take the case off, and it worked again. I thought there must be something with the case shorting or causing a grounding issue but as soon as I was thinking that it started freezing without the case. I kept restarting it over and over and it would either give the sad mac chimes (never an actual sad mac), freeze during startup, or freeze shortly after startup. Finally, it got even worse and would consistently produce somasimac along with sad mac chimes on startup. That's where I am now. In the time it took to write this, the machine sat off and open for an 45 minutes or so. I just went down to turn it on and it started up just fine (to a blinking disk). I plugged the SCSI2SD in and it started up with a somasimac. Unplugged the SCSI cable from the logic board and it started up again to a blinking disk. Plugged just the cable back in. Blinking disk. Plugged the SCSI2SD in, full boot up just fine. Ugh, enough for tonight. Has anyone experienced anything like this? Any thoughts on what my strategy should be going forward?
  2. Hello I am doing a complete cleanup and visual inspection before I go through repairing the logic board. Anyway, I noticed that once I removed the anode cap a red sticky material was found on the anode cap and the anode aperture. I wonder what this material is, I imagine it is there to act as a glue to keep the cap in place, or at least help it stay in place. I am wondering if anyone has more info and whether this material is critical if so, I have wiped some off when it occurred to me that it is likely needed. I would truly appreciate any information. Kind regards —Alex Santos
  3. I've been working on a new video focused on SE and SE/30 fan upgrades over the last month and a half. I don't have any machines with the old squirrel cage fan, but I am aware many SE owners are. I want to add info in my video for those folks. I've searched this forum for "squirrel cage" and read through a lot of posts, but no one has provided a step-by-step upgrade with photos. Uniserver said that in his opinion it was the best fan because it moves a lot of air and is quiet, although he admits that it's noisy when dirty; and the reality is fans get dirty faster than you think. The boxer fans in contrast remain about the same in volume even with a bit of crud on them. Plus, the boxer fans are sold today whereas the squirrel cage fan is not. Anyway, I want to confirm with those of you who have done this squirrel-to-boxer fan upgrade how you did it. Specifically, if all you have is an older SE analog board with the squirrel cage fan, removing that fan means you have no metal bracket for mounting a replacement 60mm fan. (Newer analog boards had 60mm boxer fans.) I did find the following post: But "Velcro"? Really? Seems like it would wobble around after a while. In any case, I'd love to see a photo of that. Another post I found was this: But that is only for a 50x20mm fan, which I personally would not use because it's too small. Even most 60mm fans are rather small in terms of their airflow. Anything smaller would either not move much air at all or need to ramp up the rpms and be noisy to move sufficient air. If anyone knows of someone who created a 3D printable bracket, that would perhaps be the ideal solution. It might a bit more sound damping too as compared to the stock metal bracket, but one would need to print and test such a plastic bracket to know for certain. Any thoughts, suggestions and photos you are willing to share would be appreciated. Thank you.
  4. I just got a Macintosh SE/30 a few days ago and want to do an LCD conversion with original hardware (none of that silly Raspberry Pi or Mac Mini board business). CRT is damaged, so perfect excuse for a fun project (hopefully I don't eat those words). I would imagine this type of mod involves pairing the right screen and card together (computer came with a Radius FPDSE30 if that helps at all).
  5. I have a fully recapped SE/30 with 128MB RAM, ROMinator II Mega (with stock software still on it), and I'm booting from a FloppyEMU in HD20 mode. Even though FloppyEMU is basically a floppy emulator that connects to Macs via the floppy port, "HD20 mode" allows me to create a disk image (in my case, just over 200MB) on the SD card of the FloppyEMU and boot from it, just as an Apple HD20 hard disk would boot (via the floppy port). Normally the SE/30 cannot boot from an HD20, but the ROMinator II fixes that problem and allows booting from the FloppyEMU in HD20 mode and even from a real HD20. Currently, I am using System 6.0.8 on my FloppyEMU. Everything works fine and as expected EXCEPT for MultiFinder. For some reason I don't understand, MultiFinder won't load when I boot System 6 from my FloppyEMU in HD20 mode. (You always know when MultiFinder loads because you can see a little icon in the upper right of the menubar. When MultiFinder doesn't load, as in my case, that icon is missing.) No matter what I do, I can't get MultiFinder to load when booting from the FloppyEMU in HD20 mode. Yet if I boot from a spinning platter HDD (external SCSI drive) into System 6.0.8, MultiFinder loads just fine. I've tried copying MultiFinder from my HDD to my FloppyEMU without success, and I've tried a fresh copy of MultiFinder from System 6.0.8 install disks too, which doesn't work either. (I am booting in 24-bit addressing mode.) Those of you who have both a ROMinator II and FloppyEMU in HD20 mode booting System 6, have you experienced this problem with MultiFinder?
  6. I made a new walkthrough video about replacing all the electrolytic capacitors on the MicroMac DiiMO 50MHz 68030 accelerator for the SE/30. I explain my choice of Niobium Oxide capacitors over tantalum, show the replacement, then boot and run benchmarks. The SE/30 shown has a recapped motherboard, recapped analog board, and SEASONIC PSU. The video is 4K but if you're a Mac user who loves Safari, you'll need Chrome to view it in 1440p or 4K. Also, it was sadly during the making of this video that my Epic Blunder occurred. My humble thanks to all of you who are so kindly trying to help me in that thread. I make videos for the enjoyment of it and as a way to give back to the community. I currently don't allow ADs on my videos nor do I have a Patreon account, which is why I've never earned any monetary compensation at all from my videos. (The down side of that is Google doesn't suggest my videos as well as videos with ADs enabled.) I make videos that I really wish someone else had made for me. Even though what you see in my videos isn't necessarily groundbreaking or unique (some of you are far beyond me in terms of troubleshooting knowledge, repairs and mods, for example), I simply am transforming into an easy-to-digest video what otherwise has been exclusively found in "text form" in forums like this. For the new generation of younger people who don't prefer to read, videos are becoming increasingly important. (Even so, I still get Millennials complain my videos are too long, so we can't please everyone. I prefer to be thorough rather than worry about the clock though.) My next video endeavor will be to show the recapping of an SE/30 analog board, and then I will have yet another video showing the recapping of the SONY PSU. Anyway, I hope this information is useful not only for you DiiMO owners but also for those of you who need to recap 5V voltage rails, as the Niobium Oxide caps I chose work perfectly for that, assuming you need 22uF. They come in other sizes though so give them due consideration in your recapping jobs.
  7. livedot

    How to remove RAM from SE30

    Hi, I searched but couldn't find this info so I'm asking here. The RAM chips on my logic board seem stuck. Is there something special about removing them (and the ROM)? Hmm after review, I see I should have put this in the lounge. Sorry.
  8. SE30_Neal

    Currupt ram and rom

    Hi all, having problems installing rominator 2 and owc memory. tried installing both separately without sucess as i just get a grey corrupt screen on boot up and funny sound. I cleaned up the board and connectors with contact cleaner as i thought maybe my se/30 is afterall 27+ Years old and may not have had the simms installed/removed in that time but still no look, put the old rom and ram back in and it worked straight away. Now i have a new 1gb hdd with Mac os 7.5.5 installed and wasn’t sure if that was causing the rominator from working but as i cant even get a boot up screen that wasn’t the problem, any suggestions?
  9. MikeatOSX

    Dead SE/30 question

    Hi, I got a dead SE/30: no boing but short rustle from the speaker, black screen, no sound from floppy, SCSI2SD board blinks once, when the Mac is switched on. That's all. I've read "The dead Mac scrolls" and more and these books told me about a bad analog board when getting a black screen. More failures may come, when I get a working screen... So I bought a (working ! ?) analog board / power supply from ebay and replaced the old board and power supply. Same problem now. Could this failure be on the video board or logic board as well? Hope you can help me. Thanks!
  10. mjhagen

    SE/30 CRT issues

    Hi all, I received a dead SE/30 that I’m trying to bring back to live. When I first switched it on it started without a chime and on screen was just a vertical line. To fix the audio I did a manual cleaning and re-cap of the logic board. For the vertical line I read that it’s probably C15, however after changing that out I ran a smoke test and I heard a loud-ish squealing sound and I switched off the power supply. To test the logic board I figured I’d try a known good AB/power supply and it booted into the flashing question mark (yay), but after 10 or so seconds the screen started to flicker, show static, then the squealing sound happened on the new AB as well and I quickly switched off the machine. I then started smelling burning (boo). On the original AB there’s a brown spot on yoke connector at the green wire, and also at the CR2 diode. Is there anyone here that can think of a clear cause of this? I thought about it being the fly back, but why would that happen immediately to a working AB? Another possibility would be the yoke connection in the CRT side, which looks a bit messy and I haven’t looked into schematics for that thing yet. Or something else on the yoke itself because that along with the LB were the same in both cases. Mingo.
  11. cbmeeks

    SE/30 Green Fuzzies!

    I have this Mac SE/30 that was in pretty bad shape. I'm going to recap it hopefully soon. But after really looking close, I'm seeing this green "fuzz" all over the place. Pretty much every where a capacitor was, a nearby chip has the corrosion all over the pins. I'm really wondering if this board is a lost cause. I'm sure with enough time I could probably fix it. But some of those IC's look to be very hard to find. The worst example are UB10 and UB11 (Sony audio). But others are almost as bad including some of the VLSI chips. This is my only SE/30. I have three other classic Macs (SE FDHD, etc.) but this is the only '030 classic Mac I have. I'm not so much disappointed about not having a '030...I don't really need the speed. I just hate seeing a vintage computer become too damaged to repair. What do you suggest? I have the equipment to remove the IC's properly. But is it worth the effort? What would you do? Thanks for any suggestions.
  12. Hey all, I know our friends over at BMOW have their rom module for sale at 2mb and there's one on ebay thats 1mb, but I have a design in progress for a 8MB (ish) simm that would allow for the installation for bigger ramdisks and the like. Throwing out a feeler here, anyone interested? OW ill probably just fab up some boards for my own use. (oh and buy BMOW's programmer because finding 72 simm slots is impossible )
  13. I just picked up a nice SE/30 and on boot I got this pattern. I swapped the board into my known working SE/30 and got the same pattern, so I know its not AB/power related. I'm assuming this pattern is typical for a board needing a recap, but want to confirm as I didn't see it on the repair SE/30 site. The board itself is clean with no cap leakage and a perfectly intact battery (Tadiran, not Maxell), but of course visual inspection can only say so much. Board image attached (and yes, I know the CPU isn't on it in the photo, it was when tested tho ) Thanks!
  14. fimbulvetr

    Fimbulvetr's finds

    I picked up an SE/30 with keyboard and mouse off kijiji today. The seller was a young guy, and wanted CAN$140 for the thing. The ad said it was upgraded with a 2GB and worked great. I noticed it had an Ethernet card and looked clean and in nice shape, so I decided to check it out. The guy said it was a gift and he had no use for it. After giving it a test run I bought it, and of course the first thing I did when I got home was open it up to check the condition and look for a maxwell bomb that might need diffusing. Not only did I find that it was beautiful and clean inside, it had been recapped (with original style SMD electrolytics), had a new battery, an Asante MacCon Ethernet card, 2TB 50-pin HD, and ... a Daystar Digital 50 MHz 68030 powercache! Somebody must have really liked that guy to give him such a nice SE/30 as a gift.
  15. doug.smith

    Mathematica 1.2 Mac

    Anyone have a copy of this software (Mac version)? i found an old dos version online but i think itd be cool on the SE30! I even tried contacting wolfram who said that version 1.2 is no longer supported. Really? its only released in 1989 about 10 releases ago...Id love to get the .img in mac form. maybe the dos version will work but i doubt it...ill try but just wondering anybody got a copy?
  16. TimHD

    Asante PDSCon

    From the album: AsanteMacConSE30

    PDS connector on Asante Card
  17. TimHD

    SE30 UE8 Back Motherboard

    From the album: AsanteMacConSE30

    Backside of where UE8 is.
  18. TimHD

    SE30 UE8 Front MB

    From the album: AsanteMacConSE30

    Front side of motherboard where UE8 is
  19. shailesh001

    Macintosh SE/30 SCSI I/O Problem

    I recently bought a Mac SE/30 which would boot from the Floppy and briefly from the SCSI drive after cleaning. But during a fresh install of System 7 the SCSI drive developed a fault and stopped being identified. The sound also didn't work at boot up. I recapped the logic board and the sound came back but the SCSI connection did not. So I decided to trace all the pins from the controller as recommended by many on these forums and found that 53C80 Pin 32 (I/O) failed a continuity check on SCSI (50-PIN) Pin 50 and DB-25 Pin 3. I have got this working by bridging the SCSI controller Pin 32 to SCSI 50-PIN Pin and now the drive is identified again. Does this mean the PCB track on the board has failed and is not recoverable? Or could it be some other fault on the board? The machine is now fully working but the bridge wire solution looks messy.
  20. massiverobot

    SE/30

    From the album: SE30

×