Jump to content

Search the Community

Showing results for tags 'repair'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 26 results

  1. Hello All, I need your help to identify the IC part number located at U9 on my 840AV logic board. I recently purchased this 840 from eBay as not working and I started removing the leaky SMT electrolytic capacitors. I discovered that the IC at location U9 is missing. Bomarc schematics appear to have it as part of the analog sound circuit for the headphone output. I have uploaded a picture of its Empty location. Please share it’s part number, so I may purchase a replacement. Thanks, Bama
  2. i am having very weird issues with a powerbook 160, i have suspicion that it has to do with an interconnect cable as it has been bent a lot and looks pinched in some places. it gets worse over time and sound will stop working after time VID_20200822_212607.mp4 VID_20200822_213010.mp4 VID_20200822_212120.mp4 VID_20200822_213010.mp4 VID_20200822_212120.mp4 VID_20200822_213010.mp4
  3. Hi! New here Was going to post this here first, but as my activation email didn't get thrue until today, I posted this already in Reddit /r/vintageMac. I came across a local ad for a Mac 512K keyboard and mouse. Reading the ad, I noticed that it actually noted "a non-working Mac 512K can also be included". This was interesting as I rarely see Macs of this vintage locally, and this was only a short distance away from me. From the photos I could see that the machine was a 120V which was interesting (living in a 220V country). Ok, I went to bought the set for less than 100$. What I have observed so far: Serial number dates the unit to a late 1985 A battery was still inside, but it had leaked only a very little and after cleaning and scraping the battery contacts they look Ok. There was no damage to the PCB where the holder sits. The floppy drive is a Sony MP-F51W, meaning that it has been upgraded (800k) ROMs are 23512-1010 and 23512-1007 (ie. "old ROMs" if I am not mistaken?) The analog board is marked 630-0102-J (ie. US, 110V non-switchable?) The digital board looks pristine and all the solder joints look original as well. Keyboard (M0110, 1985 per serial) and mouse (M0100, 1985) look intact and are reasonably clean. Keyboard cable is missing (seller said he might still have it, I might get it later). Externally the computer is in average condition, only major issue being a burnt spot in the plastic at the top left (covering part of the vent and also a bit of the front panel's top). The two short T15 screws were missing, perhaps a repair-attempt was made but they never get the case open due to the two recessed screws in the handle-space I have not tried to power up the unit yet. There was no backstory of how it failed, but being a 120V set in a 220V country, it's most likely that it was plugged in without step-down transfomer and was struck with overvoltage mains. Looking at the analog board, I see very little obvious damage. The fuse and resistor R51 next to the mains input have obviously burnt. On the bottom of the board resistors R46, R47 and R49 have slight discoloration and all three had their values gone very high. I have also done some measurements according to the books "Macintosh_Repair_&_Upgrade_Secrets_1990" and "The_Dead_Mac_Scrolls_1992" (there are plenty of in-circuit resistance measurements to go by). At the moment I am thinking about replacing the obviously burnt (/gone-high value) resistors, keep measuring around to find anything else obvious, and then power up (with a proper step-down converter). Adding to a larger component order (need to do this during the weekend), I'll also buy some spares of the nearby components (next to the burnt resistors in the schematics) like Q11, Q9 and perhaps the opto-coupler U3 too? Also some electrolytics, but I am not bothing a full re-cap yet. At first I'd like to see if replacing the obvious faults would give me any signs of life. Now my main question is; has anyone experienced a similar 120/220V over-voltage repair? How much was damaged etc. Any other pointers on what to keep an eye on?
  4. Hi, I just bought a slightly parted out imac g4 online. It was missing a PSU, drive cage and heatsink. I have aquired these items, but now I need the screws to mount them. I have sourced most of them, but I still need the long ones which are used to mount the dome to the bottom case, and the ones used to mount the logic board. I was wondering if anyone could give me the sizes of these screws. Macman0512
  5. Many good strategies here. Check it out!
  6. Here is a new video I just made for you 400k floppy drive owners. A fairly easy but effective task we should all perform on these old drives. https://youtu.be/Se10T6gPl-c
  7. I finally kicked out my Apple TechStep video today. This has been long in coming. Be sure to check out the text description beneath my video on YouTube because it contains a link to a SIT file containing Disk Copy images of the two included floppies, one of which has a pretty neat HyperCard stack.
  8. I recently acquired a 'cosmetically good' PowerBook 5300ce that had some issues. I've had a few attempts to work through the symptoms using the Service Source and reading other Forum posts, but am having little success getting it up and running and would ask for any further tips you have (short of recapping etc, but appreciate that might be a cause/something needed). The seller acknowledged it had some issues when booting ('occasionally operational' eBay Link) and as such it either gets to (i) Mac Chimes of Death (4/8 chimes); (ii) Restart - Bomb ("Bus Error"?) or (iii) failing to boot (Hard Drive shuts down mid boot as Finder Screen is being populated). I've done a basic strip down and re-assemble and noted that I can solve the first 2 issues via (i) removing/reseating the RAM Board (NB: the PB seems to be missing the GASKET under the keyboard which might mean the RAM Board is slipping out - any tips as to what makes a good substitute as a small foam insert (5mm high) seems too much?) and (ii) booting with Extensions Off (Shift). But despite a check of the various components and careful re-assembly, I still find the PB is shutting down mid-boot (Hard Drive shuts down hard, screen goes black). A secondary issue/symptom is that the PB boots once the PS is plugged in. I have done the PRAM reset and Power Manager Reset (per the Service Source Manuals) and can see no visual issues with the Power Board (no bloated caps or goo visible) short of electrical testing. The Hard Drive seems to be ok (per the eBay images, it can boot) but I seem to not to be getting that far, crashing about 10-15 seconds after booting with Extensions Off and just as the Finder is setting up the Desktop (don't get as far as seeing any icons, but it does get past the extensions/boot screen). The PB has no battery, which appears to have leaked a little, but not onto the MB as far as I can see - it appears to have corroded 2 of the pins on the battery connector - so I am booting from mains with the correct Apple PB 45W power supply - see image gallery for high res details. Welcome any suggestions you have for next steps to help get this going again in its full 800x600 603e 117Mhz 32MB splendour.
  9. After a diskette completely jammed in the floppy drive, I was forced to pry it out with pliers. Unfortunately, such a procedure is far from delicate, and the top drive head was damaged and put out of place. (Actually, I managed to damage the head before even attempting the pliers; they were simply a last resort..) Attached are photos of its current state. Shoulda-woulda-coulda, the deed is done; is it repairable, or is it time for a replacement? I should say, the drive was never ejecting properly in the first place, even after cleaning and relubricating, as well as replacing the drive motor gear. I would get the disk inserting and ejecting seemingly fine when out of the machine, but the moment I fastened it in its bracket and installed in the Mac, the drive would never eject on its own without helping it with tweezers or similar. Then it just jammed up. :\ Thank you!
  10. It took me a while but I finally got my SE & SE/30 Analog Board recapping video published to YouTube today. Safari users, note that you'll need Chrome or FireFox to watch it in 4K. Don't forget to watch it on YouTube so you can check out the links I put in the text description (click SHOW MORE to see all of it), including the Mouser Cart that includes all the capacitors you will need. Enjoy.
  11. Hi everyone. I have a Macintosh classic. The battery is leaked and corroded a part of the mainboard and I'm trying to repaire it. There is three bad resistors on the under side (R88,89,90). I need to replace them, but I don't know the value of R88 and R89.I think they are both 104 ohm like R90. Can someone help to me please, what are the correct values?
  12. Hi all, Picked up a Mac Portable 5120 (non-backlit) last week; before powering it up, I removed the logic board, removed the caps from it - all of them, except the tantalum cap on the hybrid board - cleaned the board, replaced the caps, and got a new black 6v 4.5ah brick battery. Putting it all back together, it won't boot off of the battery alone - the screen flickers, and it either hangs on a flickering mouse-pointer screen, or flips over to the chimes of death. With the original Macintosh Portable power adapter and new battery connected, it will boot 90% of the time. When it falls, it simply does nothing. Based on previous threads here, I'm suspecting the hybrid board. I did find one bad trace on there, which I have bridged, but no change. Wondering if anyone here has any ideas to help narrow down the next vector of attack. I want to test continuity on all of the hybrid board traces, but I lose some of them beneath ICs.
  13. I am starting this thread to see if there is some possibility of getting my two SE/30 motherboards repaired or replaced. In 2012, I went through my collection and realized I had two SE/30 logic boards which showed the Horizontal Lines (Simasimac) at cold boot. Those lines were stable on-screen and would display forever, meaning the SE/30 would never boot. Prior to 2012, I had recapped both boards but found they both had identical Simasimac symptoms. The two boards were recapped at different times, one being one of the very first SE/30 logic boards I ever recapped -- I used electrolytic capacitors at the time and a dab of hot glue to ensure the traces at the feet of the caps wouldn't break if I accidentally applied pressure on them. That board worked fine for a while and then suddenly stopped working. The other bad motherboard was acquired by me and recapped later using yellow Tantalum capacitors, thanks to Trag's capacitor replacement kit he sold back in the day (not sure if he still sells that now in 2018). At that time in 2012, I referenced my SE/30 schematics and spent many hours testing PCB trace integrity, not finding the root problem that was causing the horizontal lines on both boards. Eventually, I mentioned my two defective motherboards in the 68kMLA forum, and a forum member who I will simply name "TK" said he could fix them if I would ship them off to him. I am in Japan, and he is in the USA. I shipped both boards to TK in March 2012. I followed up with TK at various times, but ultimately it took 2.5 years before the boards were shipped back to me. Unfortunately, the boards were not packed properly, and although I was assured they worked before they were shipped, they both did not work when I received them. They showed horizontal lines at the time I received them, which is the same problem they have to this day. I am going to provide repair details now, but let it be know that I am not trying to speak negatively of TK. Rather, I simply need to state certain details as relevant facts for consideration by those who may be able to kindly assist me in repair or replacement. TK discussed some of the repairs in our forum, but sadly those threads were apparently lost in a forum disk crash some years back and I can no longer link them for you. However, I still have my old PM's from many years ago, thankfully. I will now list pertinent details from my old PMs for the purpose of showing what was diagnosed and what was repaired on my two SE/30 logic boards. Again, my aim is to provide detailed information to those of you who might have the knowledge and skill to repair these boards, keeping in mind that TK was quite skilled at repairs. March 2012: TK began exchanging PM's about SE/30 experiences and the board mistakes of others. He told me he saw one of my old YouTube videos showing a SimasiMac SE/30 logic board and that I should send him my board to see what he could to with it. That led to the beginning of my discussions with him and ultimately sending both of my boards to TK for repair. Upon receipt of my boards, TK told me, "One of your boards has almost a near short on the 5V rail. not a short-short, but a semi-short. So one of the ICs is bad somewhere. I am going to have to do micro-resistance analysis to find out where..." Some days later, TK said that the tantalum-recapped board "shows a cascading short on RP2, meaning several ceramic caps inside the filter are leaky/shorted." TK also said, "the other board (electrolytic-recapped) has a short on RP3 between 10 and 11 on a single chain and none of the others." TK used a heat gun to pull RP2 from the tantalum-recapped board, but he said that the heat sensor in that heat gun failed, causing the heat to rise above 800 degrees (°F?) and resulted in burn marks on the bottom side of that board. (Scroll to the bottom and see my board photos, one of which shows that burn mark.) TK said that his heat gun did NOT kill the board though. However, TK said that pulling RP2 did not fix the problem with that board. He did note that the "UD1 74F240 buffer is corroded pretty good" but did not say if that was a problem. TK saw some corrosion on the SIMM connectors and cleaned it. (Tantalum-recapped board) Even after cleaning the SIMM banks (tantalum-recapped board), the board would work only if both banks were used (1 bank couldn't be used, apparently due to a broken trace). Apparently, the Simasimac on this board was caused by "CASLL broken to the SIMM1 Bank A and B." (A broken trace to RAM.) I was told that this broken trace would cause the other negative side effect of being forced to use both banks instead of being able to use just 1 bank of RAM. TK determined that both boards had a bad BOURNS filter which needed replacing. He said he didn't have spare BOURNS filters to do the repair, however. I decided to wait and see if he could source them. TK uploaded a YouTube video his work on my board: TK told me (regarding which board he never made clear): "the ROM select line pulls low and right back high again and nothing happens from there. All data and address lines check out, so I know this isn't the issue. With ROM removed, select line remains high until NMI invoked, then it pulls low and holds, which is NORMAL. So the next thing I am going to do is check the overlay flag. If the overlay flag isn't being flipped, the GLU chip is bad." May 2012: With it having been more than 1 month, I decided to pay $18 to Trag, who very kindly was able to source 6 BOURNS filters and ship them directly to TK. I informed TK of the shipment. May 2014 (yes, 2 years later -- and yes, I had followed-up during those 2 years): Regarding Tantalum-recapped board: One BOURNS filter was determined to be bad and replaced. TK said there might also be "a bad GLU." A "bad trace to RAM" on the tantalum-recapped board was bad, and he soldered in a wire to fix. After those fixes, the board apparently still wasn't stable, resulting in death chimes on occasion during cold boot. August-September 2014: Apparently, the CPU was dead in one of the SE/30 motherboards. TK speculated that must have been caused from a bad PDS card, although I don't think so myself since my PDS cards work in my working SE/30s. So the cause of the dead CPU is a mystery. TK took a heat gun (now with repaired temperature sensor) and removed the 68030 CPU, then put it in another board and tested and confirmed the CPU to be bad. It was at this point TK decided to install CPU sockets to make insertion and removal easier. TK remarked that he has repaired "thousands of boards" but it was the first time he'd ever seen a failed CPU. TK said that long ago he had accidentally connected a NuBUS card into a PDS slot and fried the CPU, which is why he suspected something similar must have happened for my CPU to have been killed. (Which would of course mean that my case of having a fried CPU was actually the 2nd case TK had seen.) TK said the CPU tried to run but all the data bus I/O lines were pulled close to 1.8v when they should have been a little over 4v. That led TK to believe that they must have been shorted in some way to cause damage to the CPU. He went on to say that "the only cause for those is a voltage spike, or maybe an overload of the address/data bus" and that "it is unknown if there was any damage to any of the other ICs." TK quoted me $39.90 for a replacement 68030 CPU and sockets, which I promptly paid him via PayPal. October 2014: A certain knowledgeable forum member (currently, no longer a member) sent me a PM to say that TK had repaired both of my SE/30 motherboards. I asked him how he knew that, and he said, "I speak to TK privately 3 times per day!" I then added TK to our PM conversation and the following facts were explained to me: Tantalum-recapped board needed a BOURNS filter, which TK finally installed in Oct. 2014. (Most likely using 1 of the 6pcs purchased and shipped to TK via Trag in May 2012.) TK confirm both boards were fixed as of Oct. 2014. TK requested $75 for the repair, which included shipping. TK said he reduced the price due to the long time he had the boards. I received both boards in December 2014. Metal prongs that stick up in either side of the connector side of the board were bent due to the lack of soft packing material inside the box. I mention this not to case blame (although I certainly would have packed the box better), but rather to explain that the boards could have been damaged during transport, assuming they were perfectly fixed by TK prior to him shipping them to me. I never mentioned to TK that the boards failed testing on arrival because (1) I was already out a fair amount of money and no better than when I started, and (2) because it had taken 2.5 years. I put the boards back in their anti-static bags and stored them in my closet until now (Sept. 2018). Here are high resolution photos of the top and bottom sides of both of my boards, shot today: https://www.dropbox.com/sh/sandxdkcxdss6h1/AABOOjMnrcSKhlD1neFlHOCna?dl=0 One person based in Germany has sent me a PM about these boards; but of course, I must consider the cost of shipping. I am providing all these details primarily for his benefit, but also for others to read too. I would like to hear varied opinions. All said, I've invested $30 (cost of shipping from Japan to USA) + $18 (BOURNS) + $39.90 (new 68030 & sockets) + $75 (repair & return shipping fees) = $169.90, which doesn't include the cost for the capacitor replacement and doesn't include the cost I originally paid to get the boards in the first place. Wow! Your thoughts would be greatly appreciated. Thank you.
  14. AlexTheCat123

    Macintosh Color Classic Sound Issue

    Hello! I recently purchased a broken Color Classic off of eBay and it arrived in the mail a few days ago. The capacitors on the logic board are leaky and I ran the board through the dishwasher to get all of the goo off. After doing this, I managed to get the computer to work and I plan to recap the logic board in the next few weeks. However, the sound suddenly stopped working when I booted it up today and at first I thought that the volume was just turned down. After turning it up, there was still no boot chime or any audio of any sort. Then I realized that the Color Classic was producing sound, but it was so quiet that even the case fan in the computer overpowered it. Trying to narrow down the cause of the problem, I plugged headphones into the machine and powered it up, hoping for the best. I got a perfect boot chime at normal volume! This leads me to believe that the logic board is not the culprit, although I still plan to recap it since the capacitors were leaky. I have a suspicion that the analog board is causing the problem and that it needs a recap. Can someone confirm this before I order a bunch of capacitors and start the painstaking process of replacing all of the caps on the analog board? It would be great if someone could point out the capacitors on the analog board that deal with the audio so that I would only have to replace those. Also, if I am on the wrong track and the problem is something totally different, please let me know! Thanks! Alex
  15. Tsiatric

    Classic II beyond repair?

    I got a Classic II with assorted goodies off Craigslist for a good deal, with the only problem being the infamous leaking logic board caps. Not having a decent iron at the time, I decided to clean the board as best I could with q-tips, alcohol, and patience, just to see if the system would work at all. And it did! For a time. But when it came time to properly replace the caps, that's when it all went wrong. Pads and traces starting lifting left and right, with some traces snapping off the pads entirely. I tried different temperatures and techniques, but nothing made it better. In the end, about half of the pads came off. Is there anything I can do to salvage this? Everything else about the machine works great, even the hard drive, so it'd be a shame for this to become a shelf ornament.
  16. I got it. I am overly pleased to say the least. by the way, did I mention I got all of this for $300? everything is in mint/brandnew condition. Everything. Zero corrosion anywhere and besides the slight yellowing, its basically brand new. The mouse and keyboard, software, and the entire macintosh and carying bag are mint. The software is still sealed and also looks brand new. The motherboard is the old one with the purple ceramic CPU. The CRT is also one I have not seen yet and has a slightly more yellow tint to the picture. There is no burn in and the screen is very bright, Brighter than my 512ke. The picture is slightly warped and rotated and IDK how to fix this. It also has a Macsnap 2mb upgrade board which is awesome as I can just pop it into any 512k board and upgrade the ram without soldering. The old ram was upgraded on the board from 128k to 512k as removing the macsnap results in 512k of reported ram. The floppy drive is also the 800k drive which I want to replace with the original 400k drive and sled. If anyone has one to sell. Please email me at zastin17@gmail.com. I have not been able to get the hard drive to work but I have no idea how to use it in the first place so I will look into that. The clock battery believe it or not still has a charge. One thing I thought was odd was the dark amber colored flyback suction cup which is usually black, I think. However its definitely original as all the components used on the anolog board are from the time period and non of which have been replaced. The CRT seems to be different then anything else on the newer macintoshes and is Made by Samsung. The scsi board has the rom chips which are marked "apple 84-86" which are upgraded to obviously make the 800k drive work. Also what is the little board soldered near the ram? Anything else I should check? serial numbers ect? The crazy part is the seller lost over $100 in shipping. I paid $100 for shipping and it cost over $200 to ship. Se he only made a little over $100 in profit which I kind of feel bad as he did not know how to use ebay properly.
  17. This Youtube playlist, https://www.youtube.com/playlist?list=PL958FF32927823D12goes through rework procedures. The videos are professionally put together and although these videos are perhaps 30 years old, they should provide you an invaluable set of skills, approaches and best practices. I hope you find these of value. Rework & Repair Lessons 1 - 8 Videos on Rework & Repair Applications. https://www.youtube.com/playlist?list=PL958FF32927823D12 Kindest regards —Alex
  18. Hello you wonderful bunch of Mac'ians! While my my "other Mac project" is currently on-hold I dived into a PB140 restoration... initially it went quite smooth -thanks to the great videos of Ferrix97 (Grazie mille, mio eroe!)- replaced the fuse, reanimated hard-drive and recapped the screen/inverter. The last issue I have now are 2 black bars in the lower left quadrant - Does one of you brave souls have a hint for me, where to look? So far I've re-checked all caps, had a close look at the flexible flat-cables, chips and traces with a microscope, no goo or visible shorts... Thanks a ton for helping, Cheers, Axel
  19. Hi folks. Yesterday, I finished reassembling the PM G5. It is, as you probably know, a long and tedious process. Plugged it to the outlet and immediately after that, 3 LEDs lit up: Processor A, Processor B and Trickle Power. I thought the Processors weren't aligned properly but no. It seems the PSU isn't outputting anything on the processor side... I get 0 Volts at the power bus bar, and 0V at either CPU terminals. The logic board gets power though through the connector located near the plug. The other connector (towards the front of the unit) doesn't appear to be doing anything. LED #3 "Power On" isn't on. (The air deflection sensor works: The Trickle power LED is off when the air deflector (aka plastic translucent door) is on and off when the door isn't there.) So I definitely have a bad PSU. So now, I have to tear it down again! Damn thing! [Rant mode engaged] What were they doing? Why is it so complicated to remove the PSU? Why isn't there a door on the bottom of the Mac to take the PSU out? Grrr!!! [Rant mode disengaged] Rant aside, does anybody have an idea why it does not work? I got this Mac for under $10 so I'd like to get a cheap fix. If not I'll probably have to get a replacement part (bit costly though!) What do you think of that reseller? I did take it apart to clean it before even testing the PowerMac (I'm a dummie). So maybe there's something missing in there? Will report back with pictures of the insides next Sunday.
  20. spaceinvader12

    Strange Mac SE startup anomaly

    So, I was pulling out my favorite SD, my FDHD model. I haven't used it at all this month because I've been so busy with other projects. And now, an old problem I thought was gone is back. Essentially, I flip the switch and it doesn't start up right away. Rather than describe the symptoms I'll attach a dropbox link to the video of me showing it https://www.dropbox.com/s/vqydlzlqikiyyei/V_20170412_191041.mp4?dl=0 So, here are the details that are hard to see in the video. The flyblack sounds like it's clicking (not audible over speaker popping) and the hard drive spins up and down, but gradually gets louder and faster as time goes on (pulses with the drive LED). Similarly, the checkerboard pattern gets more and more grey pixels on it as time goes on, but eventually snaps to the right screen and it finally has the correct startup bong. The time can be anywhere from a few seconds to several minutes before it boots correctly, but so far, it always has done so. It happened to be relatively short the time I videoed the issue. I've checked the voltages, which read around 5.1V and 12.2V on the floppy port. My only guess is that it could be flyback or heat related. The problem seems like it disappears entirely in the cold as I only had it last summer, less in the fall, none in the winter, and now it's showing up again. The flyback clicking suggest it may be voltage related, is it likely that it's bad and needing replacement? I've done a lot of googling but found nothing like this anywhere and I'm stumped. What should I do?
  21. just.in.time

    MiniScribe 20, what to do?

    Hi, I have an Apple Hard Drive 20SC. The original 5.25" drive stopped working. I decided to put in my SE's old MiniScribe drive since the mounting bracket is already drilled for that drive as well. Good news, the drive still works great after being stored for 8 months. Bad news, the rubber seal around the perimeter of the MiniScribe is getting incredibly soft and oily, like it is about to turn to sludge. Is there anything that can be done to prevent it from failing? Or if there is no saving the rubber, is it possible to replace the rubber parts on the MiniScribe? I know the quantum drives can have their head stopper rubber piece replaced with a piece of aquarium air tube. Are there similar tricks to keeping a working MiniScribe going?
  22. Hi all, and thanks for existing. This forum has helped me many times repairing old stuff. I have just bought a Classic II in excellent conditisions, and the previous owner said that it smelled smoke. So without even powering it on I took it apart and started cleaning/recapping the analog and digital boards. I saw that a large leak was present in the low voltage part of the power transformer, so I ordered the new caps and cleaned it all. Also the power MOSFET was shorted, so I replaced it along with the controller and the fuse. After reassembling everything it actually started working! It boots to the desktop, no smell of smoke, lasted for two hours perfectly working. Then I turned it off and on again, and it never came on. Hard disk spinned, but no startup sound nor screen. Everything works except for the logic board. Shortly after it started working again. Tried resoldering some chips that were partially flooded with capacitor leaks, cleaned with demineralized water and alcohol, nothing changed, it sometimes starts and sometimes not. It works after a while, so it must be something related to heat expansion. When using it I swapped many floppies, and it formatted them just fine. One dreadful floppy and... when it entered with a "clack" the screen started increasing brightness and scanlines appeared. Panic, switched it off immediately. I'll make it short, searched everything on the internet, the problem is documented, and Larry Pina's book (page 173, Mac Classic) said it's related to some solder cracks (it makes sense after all). So I took it apart again and checked nearly every solder point in the analog board, I saw some cracks only on the yoke connector (which isn't related to brightness), but soldered everything anyway. The diode DL6 seems non-existant on the Classic II board. It's still the same. Washed the MLB again, nothing changed. Checked the contacts, they are perfect. It MUST be something mechanic, like a contact, but I cannot think of anywhere else where to look. Hitting it when powered on doesn't make a change. So... I'm here asking for desperate help. One thing I didn't do is a TOTAL recap of the analog board, I only changed the brown (defective) caps, the others seemed fine. I tested some of them. Removed the RAM, reseated the ROM, the blue (brightness) cable goes directly to the VLSI chip with no shorts, the system boots even with the monitor defective. The variable resistor that controls the brightness cutoff works but has no effect. All other guides refer to SE or Plus macs, so the boards are different. I'm currently stuck. There is no circuit diagram for this board, and I'm not extremely good at reverse engineering live 15kV circuits. Please help Mc128k
  23. Hello all, I wanted to hear your thoughts on this; I recently acquired a recapped SE/30 (which as of this past weekend is now using a CF card for solid state storage and super-fast startup!) The machine is beautiful, but what has proven a mixed blessing is the damage to the plastic of the front casing that occurred during shipping (I say this because I ended up getting the machine for free via UPS shipping insurance due to the damage and an unseated ROM SIMM which caused SimasiMac) To cut to the chase: Has anyone had any experience repaired cracked or broken off plastic on these compact macs? My plan is to reattach a piece, fill in the cracks (pictures below) with some kind of material), then sand it down so it is flush with the rest of the casing. Here's a link for a two-step plastic I found, if you have any suggestions or alternative solutions, I'm all ears. http://www.plast-aid.com/ // mdent23
  24. jua958

    Powerbook Revival Fight

    Hi guys! I bought this Powerbook 165 on eBay for 10 quid last week, the seller already stated that it was broken but I liked the idea of having a project to repair a Powerbook. At the end I would like this to become a big guide so other people with similar problems will find it helpful. So far I found these problems: [solved] Power Adapter: At first the Powerbook won't turn on, testing the PSU with my multimeter I found that it wasn't given the correct voltage (the correct is 7.5V), a quick recap and it was up and running! (well, up and giving power). Now the Powerbook boots but I found other problems. Trackball: When I use the trackball it only moves the cursor vertically, disassembling it I found something interesting: When the ball is inserted on the centre of the board, due to the weight of it the wheel mechanism is slightly moved, The y-axis sensors can still capture movement but the x-axis sensors cannot, if I take away the ball and turn the wheels manually both sensors work. Maybe the x-axis sensors doesn't have enough power? I replaced the 2 transistors on the board and it still gives the same result. I tried to bend the sensors a bit but it still won't work and I don't think is the correct solution. Here are some pics to understand the mechanism: Here is the trackball board, the x-axis sensors are on the upper-right corner This is the trackball board with the wheels And finally a zoomed picture showing the x-axis sensors with the front wheel, it slightly move left when the ball is inserted Screen: Ugly lines appear until I mess with the contrast and brightness controls, capacitor problem or irreversible? Energy distribution: This is odd, sometimes the hard drive only turns on when I turn off the screen, and sometimes the laptop shuts itself down, the PSU is giving the correct voltage. Hard drive: Doesn't appear to detect it, does some strange sounds when it turns on. ​ Any help, and I mean ANY will be VERY appreciated, I'll be updating the list and posting solutions as we go.
  25. Trying to clean the floppy drive of a Macintosh Plus, now every time I insert a floppy it will automatically eject it. Disassembling the 800k floppy drive I realised that when I put a floppy in it, the motor doesn't spin and then the disk is ejected. Anyone know how to repair it? Any help will be appreciated.