Jump to content

Search the Community

Showing results for tags 'portable'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 10 results

  1. Good morning everyone from spain, I have restored a 1989 portable macintosh, model m5120, it has been recped, cleaned and baked following the teacher's instructions techknight. But I still do not work 100% perfect. I tell you the problems he has to see if you can help me: The first problem is the screen, after half an hour of use more or less it begins to darken until it becomes completely black; If I turn it off and leave it off for a long time, it returns to normal. I've checked the capacitors and they seem fine, I don't dare to disassemble the frame and I don't know what to do. I leave you some images of the screen when it begins to darken and with the loading icon. The second problem is battery management. The computer charges the battery, but it discharges quickly, the battery is rebuilt and it is new, in another of the portables that I have it works perfectly, but in this one the charge is intermittent and the icon charges - does not charge, and so on all the time If I unplug the power cord, the battery discharges (or says it discharges in 10 minutes). I don't know what to do either. Any ideas? Some help? Thank you very much.
  2. glay78

    Macintosh Portable Sad Mac

    Hi I’ve recapped my M5120 and it has sad Mac now. It works previously before capping. I’ve check both battery and power adapter that’s working great so power shouldn’t be the issue. It chimes but has the error as shown. Also swapped out the ram but it’s the same. Any help?
  3. BlaBla1985

    Macintosh Portable audio issue

    I'm having a weird issue with the audio in my portable, it often starts to "chirp" for lack of a better term. sometimes it's a continous chirping sound, sometimes it's random chirping and buzzing. And sometimes it's completly quiet unless it's supposed to make a sound. The chirping will usualy mean the system is not running stable, so it will randomly crash if a sound should be played or a floppy it accessed. I've tried to use the system without the harddrive, but the problem remains, no floppy drive, the problem remains. Disconnecting the speaker didn't help alwell (although the noise was gone offcourse). I was wondering if the mosfet that provides the 12V to the soundsystem can be taken out of circuit to test it without any audio stuff connected... but i don't know it the computer will like that. Will it then just burb out random errors or boot with no sound?
  4. Dear Mac enthusiasts, Finally I could figure out what was wrong with my Mac Portable backlit model and I brought it back to life yesterday afternoon. Not a really big deal, just a broken path, but it was under a chip, so it was quite difficult to find. Anyway, now that it works fine I have a couple questions: -First: when should the screen backlight turn on? I thought it came on at the same time I turn the computer on, but for some reason it doesn't until it loads the first extension. I don't really care, as it works perfectly fine, it's just curiosity. -Second and more important: I have an official 1MB external RAM card that prevents the mac from booting. It gets in a boot chime loop and, if I press the interrupt switch I get a sadmac error 03001300 // 00001FFA or 03001382 // 00001FFA. I assume I have a bad RAM card, but reading the thread about @techknight 9MB project (incredible work, so sad it's no longer available) I seemed to understand that RAM cards were different for models M5120 and M5126, so maybe I have a wrong card. I leave a picture here, in case someone may check it. I looked in Ebay, but currently there is nothing available. I'd appreciate if someone have one laying around that may want to sell it to me. Thank you!!!!!
  5. The flaky and stripy video was a broken 26-pin LCD monitor cable. Has anyone had this problem, and how was it fixed? Where would you find this kind of cable today and what is it called?
  6. North Hedge Ned

    Macintosh Portables Dead

    Hello, I know that there is much discussion around the Mac Portables and their woes with powering up. So much information, in fact, that I have become lost in it all and have no idea where to start. So, if I may, some simple questions, and some directional guidance required. I have several of these beasties and they all do not seem to start up. Some don't boot at all, some boot then power off, some boot, show a mouse, and the drive tries to spin up then shuts off. One I had boot and went straight to sad Mac. It even ran off the replacement battery that I had in it (6v 5maAh lead-acid, new, fully charged), in this sad Mac state. However when I disconnected power and tried again, it would not boot. I always had the cutoff switch engaged when trying to boot from the main battery. With adapter connected (a real Portable Adapter) I am getting the 7.1 v reading at the main terminals inside the computer with the cutoff engaged. With my battery connected, I get the same. When I activate the cutoff (as in have the switch open) and my battery connected, I am reading the 6.3v of the connected battery at the terminals. Questions: 1. Must the 9V battery be installed for the unit to function properly? 2. If I were to pul the board, is there a concise step by step with photos of how and what to test with my multi-meter? Would this resource also tell me what to replace and how? I do not have the means to remove old solder. Looking for guidance and a resource to dive into. I ultimately wish to sell these things, and suspect that the cost to fix is more than recovered by the sale of a functional unit vs a dead one. Thank you all in advance! Paul
  7. MacMan1984

    Macintosh Portable M5120 Repairs

    I just got a Macintosh Portable in the mail today, and I was told it boots to a floppy disk screen. Turns out, that wasn't true. It doesn't even boot at all. The startup is very erratic, sometimes doing one thing and other times doing another. It will sometimes: - Boot to the mouse cursor, but then the screen flashes and glitches. - Boot to the zebra stripes, but become caught in an endless loop of booting. - Boot to the zebra stripes, but then display a Sad Mac with error code 00000012 0000CD36. A little while after that happens, the screen begins to flash and glitch while the floppy disk and hard disk make this combination of a click and a buzz a few times a second. No startup or death chimes are heard, either. Sometimes, I'll also get random Sad Mac error codes, but sometimes it will be 00000012 0000CD36. If anyone can help me, that would be greatly appreciated. I can safely assume that it is due to the battery because it has the original battery and that it will need to be replaced, but I hope I don't have to recap anything. Many thanks in advance!
  8. Hello all, It’s been quite a while since I’ve posted here, and it’s good to be back! I had a quick question for you Portable people out there: I just recently recapped a clean-looking backlit model, and it seems to be working fine off of my bench supply running at 6.8v. The problem is, lowering the voltage to 6.7, 6.6, or 6.5v makes booting either hit-or-miss or impossible. Also, I bought a new 6V 5Ah SLA battery (not the cyclon pack) to power the system. Even after being charged up to its max of 6.6V, while connected to the original charger, the machine refuses to boot completely. Sometimes it gets farther on just the battery, but never all the way. I guess my question is this: is this normal for a backlit Portable? Is there some difference in the Cyclon battery that would bring it within spec? I would imagine the system should function properly at 6.5V given it’s designed to run for hours. Any insight is appreciated. Thanks guys!
  9. Hi all, excited to be a new member. My friend and I have been debugging a recapped 5126 lately and are looking for some advice. Once again this machine was recapped some time ago The machine is in OK shape overall with a well-behaved 40MB hard drive. Unfortunately, leakage from the three caps under J13 (left-hand kb/trackpad port) took a toll on the circuit board. We've recently bridged two pins of J13 that were attached to broken traces over to their cousins on the other side of the board. Also, I just now finished wiring the interrupt switch directly to the Misc GLU to work around a rotten via just above RP201. The board has a flaky SWIM. There is a replacement on standby. However, we suspect the power regulation may also be off, and this may have caused the SWIM to break in the first place. So we'd like to fix the power first before we exchange that chip. The problem is similar to the behaviour discussed in this thread from 2015. Plugged into the wall and with the battery installed, the system runs well enough, although some screen flicker occurs when the drive spins up. Unplugged, the battery meter shows the power plunging very quickly. It takes about 15 seconds or so before the computer gives up the ghost and shuts down altogether. The thread just linked suggests to me that bad continuity in the region south of J13 can cause problems like these, and given all of the continuity problems seen so far in that area, I wouldn't be surprised if more continuity issues were at fault, so it seems useful to check for that first. The thread suggested measuring continuity between C26 and pins 14/15 of the op-amp U1M, but those seem to be fine. What else might be worth probing? For what it's worth, we're using the original charger and a replacement 6v sealed lead-acid battery of the usual kind. Thanks for any help! --Tom
  10. zuctronic

    Macintosh Portable Power Issues

    So I recently acquired a Mac Portable. As soon as it arrived I took it apart, re-capped the motherboard and hooked it up to a replacement battery. Everything was going well, actually no issue at all last night. I was able to mount some Appletalk volumes and play some games, it seemed pretty stable. This morning I decided to break open the original apple battery and toss my new cell in there. While testing this configuration, I accidentally hooked up the battery with reversed polarity... I know, this was dumb. Now I'm having issues again. Here are the symptoms: 1. Will not power on at all without wall charger plugged in. 2. Randomly crashes when doing anything. 3. It will go to sleep, but when it wakes up it either crashes with a crash chime or it just reboots. 4. System 6 "battery" meter shows battery slightly above middle charge all the time now (I doubt its accuracy!) 5. When I try to change the date, the system crashes / reboots. Any ideas? Could it be just a fuse? Is there an easy way to troubleshoot this without a meter? Thanks in advance! I hope I can get this back to life again...