Jump to content

Search the Community

Showing results for tags 'lisa'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 14 results

  1. GEM and GEMDOS, which are perhaps best known from the Atari ST series, were also ported to the Lisa. Both were designed to be portable, and DRI sent the source for the Lisa port to OEMs that were considering porting GEM as their 'example implementation'. When Caldera/SCO open sourced GEM, part of the random dump of stuff they threw at the folks requesting it was this porting kit. The FreeGEM folks were mostly interested in PC GEM (I was on the periphery of this, fiddling with programming language bindings), and Atari GEM had gone its own way anyway. Bits of it did end up in EmuTOS, though. The practical upshots of this, though, are: the code for Lisa is out there, and so is the original toolchain to build Atari GEMDOS. And @gilles already did a bunch of work to get GEMDOS booting on the Lisa. My "discovery" of the last few days is: not only can you use an Atari emulator and the GEMDOS-on-Atari toolchain to build application code for GEMDOS on Lisa (in fact, for at least my simple applications so far, there's not even a need to recompile), but you can use it to build the OS itself (after a little mucking about - one component was completely missing and I had to hack a replacement together from a combination of Atari GEMDOS and CP/M code). I'll write up instructions for building it soon, but if anyone wants the files let me know. This is a photo of GEMDOS running on my Lisa. You'll have to take my word for it that it's a new build of the code, rather than the GEMDOSFI.SYS that DRI shipped. Now, this is supremely useless, except for historical interest. But I'm kind of tempted to see if I can get GEM itself to run and whether, if so, I can try to run some old Atari software on it, or backport some of the FreeGEM goodies to it. Can anyone else think of fun things to do?
  2. Does anyone know if it is possible to recreate a 5 1/4 Twiggy Floppy Disk and/or Floppy Drive for use in an Apple Lisa 1 or a prototype Macintosh? I have read somewhere that you could modify a high Density IBM disk physically to fit the specs, but I want to hear your opinions on this topic. Edit: Why doesn’t this forum have a prototype Twiggy Macintosh emoji!!??
  3. When the Lisa (2/10, if relevant) boots and shows a 'mouse error' (the mouse with ? icon), what does that actually mean? For context: I recently built a joystick controller for my Lisa because there isn't room for a mouse by it. But it makes the Lisa come up with a 'missing mouse' icon at startup, even though it actually works fine when the pointer appears. I'm currently assuming that this is because for the first second or so the pins on the mouse port are in an indeterminate state and probably look like nothing is plugged in. But I want to check that this doesn't mean "you're doing something that will cause issues later" (e.g. drawing too much power from the 5v line, or something). Here's info about the controller:
  4. I recently figured out how to use BLU (Basic Lisa Utility) to transfer an image of the entire Widget hard disk on my Lisa 2/10 over a null-modem serial cable to my MacBook Pro as what appears to be a raw binary file. The file size is about 10 MB, which seems appropriate, and by looking at it with a hex editor, I can clearly see some of the data in there, including some of raw text data found in the documents that were written in LisaWrite. I wish to be able to use this disk image with a Lisa emulator, such as LisaEm or IDLE, but so far, I have had little luck. IDLE uses .raw files, but when I rename my disk image to "profile.raw", which is the file name that IDLE expects for the virtual hard drive, it fails to boot, with profile error "84". I have tried this with IDLE in both "Lisa 1" and "Lisa 2" modes. According to The Apple Lisa FAQ at "https://lisafaq.sunder.net/single.html#lisafaq-hw-hd-error_84", this error means that the drive is either damaged, improperly connected, or has damaged system files. I doubt that any of these things are true, since the initial process of creating the disk image appeared flawless, and the Widget drive in my Lisa has 0 bad blocks, according to BLU, and has not exhibited any signs of damage or failure. It appears to me that the file format is simply wrong. LisaEm expects the Widget or Profile image to be in .dc42 format, so perhaps I might have more luck there, if I could somehow convert the raw BLU binary file to a .dc42 file. I have already attempted to use the raw file by itself with LisaEm, but after renaming it to "lisaem-profile.dc42", LisaEm simply acts as though there is no virtual disk, asking me instead to create one. This makes sense, given that it expects a .dc42 file, not a raw BLU binary file. Does anyone have suggestions for what I can do to work with this disk image? My ultimate goal is to be able to use this image with any Lisa emulator just as though I were using a real Widget with a real Lisa 2/10. I have also attempted to use a hex editor to try to fit the raw data into a working virtual disk image, to no avail. If it helps, I have attached the raw disk image file obtained from the Lisa with BLU. (NOTE: The original file had no extension, but for some reason, this website adds a long extension consisting of random hex code, along with underscores in place of spaces, and some other slight changes.) __-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk).e32be7a88805689cf1c9393d79ffb35e
  5. This was long in the making ! Almost 5 years ago, I purchased a Lisa 2/10, well technically a Mac XL, from someone on Craigslist. The story was actually very cool. The seller said that he was working as a cameraman for NBC News, and he was the one filming the 1984 Mac launch at the Flint Center in Cupertino, when Sculley talked him into buying the XL. So I loved the history behind it. It also came with a box set of Lisa software (System and Office) which I have never seen anywhere since (942-0595-A). The Lisa was not working, but it was in near mint condition, and I got in on the cheap. I actually got it to work fairly quickly, after discovering a short in the fan of the widget assembly. However, a few days later, it died again after I accidentally opened up the back panel while in use, triggering the EPO. This somehow fried the PSU (it shouldn't), and after many random attempts to revive it, I could not find what the problem was. Fast forward 4 years of the Lisa gathering dust in my garage, and last week, I decided to try again and see if I could fix this dead XL. I bought one of these neat and cheap USB oscilloscopes, and made good progress. Since I could not get any good DC voltages from the PSU, I had a hunch that the pulse width modulator chip Z2 (SG3524) on the PSU was defective, so I changed it. Great move as the Lisa woke up, made all the right beeps, and booted up. However, the video was quite a bit messed up. So, next step I took was to look at the video board and mesure voltages there. I noticed that resistor R1 was VERY hot to the touch, and thought that the voltage regulator U1 (7824CT) was probably leaking current to the ground. I changed it (costed me 20c at a great store - HSC Electronics - in Santa Clara, CA), and that fixed that problem, as R1 was now cool. However, I had messed up something else in the process, as the video was then seemingly dead, only showing a bright spot in the center of the screen. It looked like both vertical and horizontal deflections were not working. I checked with an external composite monitor that the logic board was in fact spitting out a valid TTL video signal (picture on the external screen is not great, as it's not syncing properly, but I could recognize the home screen). Well, this took me a few days to figure out, but I eventually realized that I had switched around the two 3 pin connectors from the CRT to the board . After fixing this mistake, I finally had a working screen. However the contrast was extremely poor, and countless adjustments of the potentiometers at the top of the board could not correct the issue. This is when the USB scope really helped me, as I was able to follow the TTL signal all the way through to the CRT, and realized that the signal really deteriorated past transistor Q2 on the video board. Changing Q2 and Q3 (thanks HSC electronics again) did the trick, and my XL now works great with a very crisp screen. So, this was very gratifying, and I cannot thank enough the fellow(s) that reverse-engineered the Lisa circuitry, and also all the members of this 68kmla and Lisalist forums. Without it, this clearly wouldn't have been possible. To conclude, I have a few comments/questions to the community 1) The connector from the board cage to the widget assembly says "PROTOTYPE" on it (see photo). Does this mean anything ? 2) I once was touching the Lisa chassis while turning it off, and I got a pretty good shock. This could have explained why I had all all these issues. Has anyone experienced the same thing ? Do I have a faulty home ground ? 3) I cannot get the front bezel to close neatly on the right hand-side "hook". It looks like the floppy drive protrudes a bit too much and prevents the bezel to engage all the way before it clicks. Has anyone encountered the same problem ?
  6. Hi, Am working on a long term restoration project of a Lisa 2/5. This is my first attempt at restoring a Lisa and I have a lot to learn. Fortunately, I have multiple copies of each board and a configuration of boards that work (except for some video adjustments I need to do to the CRT). I have one motherboard which works well EXCEPT does not register the mouse button as being pressed. The mouse pointer moves fine. When you press the button, no action on screen. The mouse itself is fine and works perfect on a 128K Mac. The mouse also works perfect when the motherboard is replaced. Any suggestions on what to look for on the motherboard? I've done one deep clean on the board and have not visually seen any broken traces in the general area of the mouse port. Thanks so much.
  7. I recently acquired a 5MB ProFile drive in an unknown condition for use with my Lisa. I promptly replaced the power supply caps in hope that the drive would be operational. Powering the system on resulted in a high pitched whine but nothing else, but when I disconnected the internal data cable between the controller board and the hard drive, it did begin to spin up. Any suggestions on what to try next? I've tried reseating all the chips. Are any particularly prone to failing? Is there any way to narrow down whether the controller board or the drive analog board is at fault?
  8. I'm in the process of replacing my Lisa keyboard's foam pads, and I realized that the caps lock key doesn't stick halfway down like it should. I'm afraid I may have lost something from the mechanism that makes this work. Does anyone happen to have any detailed pictures of the caps lock assembly (or would anyone be willing to take them, for science? )
  9. I restored a widget drive to a certain point. See my old posting: it it works on a “donor” external PSU. The problem is that it is very hard to start. To get it on I have to fiddle with the power on/off switch on the PSU. It helps if you spin the disk counter clockwise and then do the power trick. Some questions: - What can I do to let it start more easy? Can I lubricate it? Or can I adjust the motor? - I don’t have a power harness. Can I use some connections on the power supply or board? - is there a better way to power switch the disk on with its external power unit? Should I use a kind of special switch? - how to get the special power connector for the drive. Is it only for a widget or is it some kind of standard?
  10. Hello, I have a MacXL 2/10 and everything is working pretty well (including the widget hard drive). The only issue I seem to really have is the screen. The image is smaller than the displayable space on the CRT (and it is dim - see pictures). In reading the SunRem guide (ftp://ftp.apple.asimov.net/pub/apple_II/.../applelisa/Lisa_Do-It-Yourself_Guide.pdf) for the MacXL upgrade it seems that maybe the image is supposed to be smaller than the screen ("final raster of 8.44 inches in width and 5.99 inches in height). As far as I can tell, the system does not have the upgrade transformer installed either. So two questions really: 1) Is the screen/image normal? Can I make the image (raster) larger)? If so any advice on making it brighter? What about the 5V adjustment? 2) If I want to run Lisa OS I understand I can't have the screen mod installed and need to revert the Hi/Low and Video ROMS - or can I leave it the way it is? IE - revert to H from 3A. Thanks
  11. stepleton

    Announcing NeoWidEx

    (Crossposting from LisaList; hope this is OK. I know not everyone reads both forums---I didn't join 68kmla until very recently!) Hi everyone, I've made something that might be a useful addition to the Lisa fan's toolbox: a formatting and diagnostic utility for Widget hard drives. In the tradition of Apple's original Widex utility and Patrick Schäfer's UsbWidEx peripheral, the tool has the unimaginative name "NeoWidEx": NeoWidEx runs on your ROM H Lisa 2, booting from a floppy disk to a familiar user interface. It expects a ProFile-compatible hard drive to be connected to the built-in (internal, on a 2/10) parallel port, and if that hard drive is a Widget, all menu options will be available. You can execute a large subset of the Widget commands from the Widget ERS document, and you can perform some automated actions as well (like formatting a Widget, or searching all sectors on the disk for a byte string). It's pretty easy to read the contents of any sector, edit the data, and write it back. NeoWidEx isn't anywhere near as powerful as UsbWidEx can be (particularly when it's being driven by a program running on a modern PC), but you don't have to know how to do surface-mount soldering to get NeoWidEx running, so it might just be handy in a pinch. (Fun fact: in the time it took me to write NeoWidEx, I learned how to do surface-mount soldering.) Like all good low-level disk utilities, NeoWidEx makes it a breeze to destroy all of the data on your drive, so be careful! All of NeoWidEx's code (about 10k lines of 68k assembly) is released into the public domain. Some of the code may be useful for building the user interface for similar tools: as long as you don't mind your program jumping to unpublished routines in the boot ROM (why should I have to re-program all of that stuff?), you get menus, text, and forms for obtaining numerical user input. Storytime: NeoWidEx was written to investigate a mystery on my Widget, which had a bad evening in 2015 and decided that many of its blocks were failing. The Widget decided to "rescue" the data on these blocks by allocating some of the 74 available spare blocks to substitute for the bad ones. Unfortunately, the Widget decided that many of these spare blocks were also bad, including one of the two that it was already using to store copies of the "spare table"---the Widget's ledger for how the spare blocks are allocated. Fortunately, the Widget designers had a plan for that: simply copy the threatened spare table to yet another spare block. Eventually my Widget felt better about itself, but once blocks are spared, there's no easy way to get the drive to un-spare them. Worse yet, enough spare blocks were in use that the Office System warned me that the Widget needed servicing. I didn't understand why the drive had gone bad all of a sudden and decided to write a tool to investigate. A look at the spare table revealed the situation just described, and although it's possible to "reset" the original spare table copies with the Widget's "Initialize_SpareTable" command, this couldn't clear the "spared spare table" that had been saved on a different spare block. As long as the extra spare table was around, the Widget would find it on power-up and consider it authoritative. So, I wrote NeoWidEx's "grep" capability to find the errant spare table on the drive (this was before I fully understood where spare blocks were found on the disk). Overwriting the extra spare table with zeros meant that the "reset" spare table copies became authoritative. All those "bad" blocks passed the next surface scan with flying colours; my Widget was back to normal! (Well, the transient issue that made it decide that so many blocks were bad is probably still lurking, but fixing that will have to be a job for another time!) Anyway, here's where to find NeoWidEx: https://github.com/stpltn/NeoWidEx Lots of people have done things to help me make NeoWidEx, and most of them probably don't know it! Dr. Schäfer knows---his insights and project documentation were very helpful---but other essential aids include LisaEm, BLU, Floppy Emu, Bitsavers, and of course the whole Lisa community in general. Thanks everyone! I hope NeoWidEx is useful. Enjoy, --Tom
  12. Hi , i recently bought a Lisa 2/5 with keyboard and Profile 5MB on Ebay, The lady wasnt working due to corrosion on the motherboard and i/o board But after spending hours of cleaning and fixing some minor issues (like the reset was stuck on low because of a broken reset button) i finally could make it to the starting screen :b&w: Ok so far, but now i figured out that the keyboard doesnt work at all. Its not just the foam issue (most of the pads were still looking good..i assume :b&w: ),but i couldnt get it work even if i touched the pads on the keyboard pcb slightly with my fingertips after removing the keyboard tray. Does someone have an idea what i have to look for to get the keyboard working again? Or do i have to look for another keyboard.... Btw its an upgraded Lisa 1 (i assume) with Applenet id 00100075, Manufactured 83060 (march 1983) and ROMs F/A8. The Profile HDD fails self test (the drive cant read Track 77, for reason unknown). Any help would be appreciated I also need a mouse, if some1 could spare one very cheap...