Jump to content

Search the Community

Showing results for tags '512k'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 14 results

  1. Hi! New here Was going to post this here first, but as my activation email didn't get thrue until today, I posted this already in Reddit /r/vintageMac. I came across a local ad for a Mac 512K keyboard and mouse. Reading the ad, I noticed that it actually noted "a non-working Mac 512K can also be included". This was interesting as I rarely see Macs of this vintage locally, and this was only a short distance away from me. From the photos I could see that the machine was a 120V which was interesting (living in a 220V country). Ok, I went to bought the set for less than 100$. What I have observed so far: Serial number dates the unit to a late 1985 A battery was still inside, but it had leaked only a very little and after cleaning and scraping the battery contacts they look Ok. There was no damage to the PCB where the holder sits. The floppy drive is a Sony MP-F51W, meaning that it has been upgraded (800k) ROMs are 23512-1010 and 23512-1007 (ie. "old ROMs" if I am not mistaken?) The analog board is marked 630-0102-J (ie. US, 110V non-switchable?) The digital board looks pristine and all the solder joints look original as well. Keyboard (M0110, 1985 per serial) and mouse (M0100, 1985) look intact and are reasonably clean. Keyboard cable is missing (seller said he might still have it, I might get it later). Externally the computer is in average condition, only major issue being a burnt spot in the plastic at the top left (covering part of the vent and also a bit of the front panel's top). The two short T15 screws were missing, perhaps a repair-attempt was made but they never get the case open due to the two recessed screws in the handle-space I have not tried to power up the unit yet. There was no backstory of how it failed, but being a 120V set in a 220V country, it's most likely that it was plugged in without step-down transfomer and was struck with overvoltage mains. Looking at the analog board, I see very little obvious damage. The fuse and resistor R51 next to the mains input have obviously burnt. On the bottom of the board resistors R46, R47 and R49 have slight discoloration and all three had their values gone very high. I have also done some measurements according to the books "Macintosh_Repair_&_Upgrade_Secrets_1990" and "The_Dead_Mac_Scrolls_1992" (there are plenty of in-circuit resistance measurements to go by). At the moment I am thinking about replacing the obviously burnt (/gone-high value) resistors, keep measuring around to find anything else obvious, and then power up (with a proper step-down converter). Adding to a larger component order (need to do this during the weekend), I'll also buy some spares of the nearby components (next to the burnt resistors in the schematics) like Q11, Q9 and perhaps the opto-coupler U3 too? Also some electrolytics, but I am not bothing a full re-cap yet. At first I'd like to see if replacing the obvious faults would give me any signs of life. Now my main question is; has anyone experienced a similar 120/220V over-voltage repair? How much was damaged etc. Any other pointers on what to keep an eye on?
  2. Well, I'm in tears again over my own foolishness. I've been shooting a video that focuses on recapping of 400K floppy drives. I hadn't begun the actual recapping but was doing some preliminary tear-aparts and testing. I had my 400K floppy drive mechanism connected via ribbon cable to my 512K motherboard, but I had the drive mechanism pulled outside the back (with the back case off) and sitting on some plastic floppy disk cases. I had a single jumper wire with alligator clips at either end connected to the metal chassis of the Mac and to the metal chassis of the floppy drive. All was going fine until I switched on power and noted there was no Bong sound! I looked down in horror to see one end of my alligator clip wire had fallen off the floppy drive and onto the 512k motherboard, shorting one or two pins of the SYP6522 (about where the red dot is shown below) to Chassis ground (connected to Earth via wall socket). With my heart racing and sweat on my brow, I immediately switched off the machine and removed the jumper wire. When I switched on the machine, to my delight I was able to hear the startup bong! And when I put in a disk, the 400K drive would spin the disk and move the head to try to read from it. It spit out the disk, but the drive had been spitting it out prior to the Epic Blunder because I think the disk was bad. Anyway, I then booted from my FloppyEMU (which was also attached at the time on the external Floppy connector), and it booted to the Desktop just fine. Thinking that all was well, I put in the same disk into my 400K drive, but the drive motor didn't spin. Basically nothing happened, just as if I had the 400K drive disconnected and inserted a disk. I then shutdown the machine and powered on, then put the disk back in, but the drive still wouldn't spin the disk or move the head! And yet, when I power on each time, I do see the head move a few millimeters as it normally does at cold boot. Even so, disk insertion results in no motor spinning and no head movement at all. Yet my FloppyEMU works perfectly every time I try it. I have another 400K floppy drive, known good, so with the machine powered off, I disconnected my dead 400K drive and I connected that other known-good drive via the same ribbon cable to the motherboard -- it too is an internal 400K drive mechanism. That 400K drive accepted my floppy, tried to read it but couldn't, then spit it out. So I booted from my FloppyEMU (still connected), and at the Desktop I inserted my floppy again. Sadly, this second drive has now stopped spinning the motor! I powered off and on, then inserted the floppy again, but it still won't spin and the head won't move. But like the other drive, when I power on, I see the head move just very slightly as it normally does (which happens even when no floppy is inserted). So why would the head move a little at power-on, but then give me no motion at all when I insert a floppy? And why would both of these drives accept the floppy the first time, try to read it, then spit it out (perfectly normal when a bad disk is inserted), but then after booting to the desktop (via FloppyEMU) suddenly stop working? If the above schematic is to be believed, it would appear I may have shorted one or more of the address lines (pins 36 and/or 37??) to Ground with that stupid jumper wire. But why would a short there ultimately kill both of my 400K floppy drive mechanisms? I have another 512K motherboard, but I'm a bit scared to test my 400K drives with it for fear that whatever now plagues the 400K drives could harm that motherboard too. I would certainly appreciate hearing your thoughts and suggestions, especially yours, @Bolle. Thank you.
  3. Hi all, I'm trying to get a 512k (intl analog board) up and running again, and I think I've tracked the problem down to the power supply. The initial presentation was a dead mac (no video or chime, no HT as far as I could tell) with a rapid clicking/chirping when power was applied. I measured the 12V supply to be peaking around 4V, and 5V to be around 1.2V. I started off by recapping all the electrolytics, with no change. I also followed the suggestions in the Dead Mac Scrolls (rectifier replacement, video cable continuity) to no avail. After some poking around on the 240V side of the board (with the help of Thomas Lee's excellent notes), I found R53 (1.2R, 1/2W) was an open circuit, so I replaced that with a 1W equivalent, and got what I think is the infamous flup flup flup noise (slower, louder, and lower pitch than the chirping before). I scoped the 12V and 5V rails, which showed the crowbar was kicking in, even with the voltage turned all the way down. The feedback circuit seems to be working (output of U1 is going negative as the supply voltage passes 12V), and I replaced the opto-isolator just in case, but the problem persists. At this point I suspect the SCR Q12. It tests fine to a multimeter, but I understand it's quite a sensitive part (hard to replace, too). Before I go hunting for a replacement for the SCR, I thought I'd see if anyone had any other ideas. Looking forward to your thoughts! Tom
  4. It’s been long in coming but I finally kicked it out today. Yes, even your working order Mac 128K through the Plus can use a recap. A video INDEX is in the text description on YouTube to help you easily refer to different sections of this 1 hour video. Even if you aren't interested in a recap, check out the bad Flyback segment where it lights up in the dark!
  5. macfan2350

    Rom Question

    Hey guys, I just have a simple question to ask. I have a Macintosh 128k with what I think to be a 512k upgrade board. It even says 512k on a little sticker on the board. However, it is missing the Roms to it. It just displays a checkerboard. My question to you guys is, what roms should I purchase? 512k roms or 128k roms. Thanks again, any help is welcome.
  6. TimTheEnchanter

    Macintosh 512k sad Mac error help

    I had a good look through the “Sad Mac” error codes web page and couldn’t decipher the code. On startup every time I get a 01C000 code and I have no drive drive activity despite having a good boot disk (verified on another machine) if anyone can tell me what this means that would be great! Thanks.
  7. Yes, even the Macintosh 128k/512k KEYBOARD needs to be recapped: But does it really need to be 63V? Here's the keyboard schematic, with the 1uF cap showing in the upper right area nearest U2: And U2 is the 74LS123 shown here: Sure, I can find a Mouser $3.23 replacement, but why is the stock cap rated at 63V? Is it because people might be stupid and connect the keyboard to a phone jack, or is there some other reason? The reason I even wonder about this is because if lower voltage 1uF caps can safely be used in this keyboard, then more replacement options present themselves that are better and cheaper too. I look forward to your insightful replies!
  8. DesignComplex

    512k Mac’s-a-Million Upgrade

    Hey all, I bought a pallet of old macs from a warehouse sale, and one of the machines was an old 512k with some weird upgrades. It looks like someone added more RAM and a SCSI port (which was threaded through the external floppy port hole). I can’t tell if this is one upgrade or two. I’d like to get this little machine working again, but it looks like whoever upgraded this machine made some strange changes to the motherboard, so I’m not sure if they can be undone. Is anyone familiar with these upgrades? The RAM upgrade is called Mac’s-a-Million by Sophisticated Circuits. The SCSI upgrade board seems to be from Relax. Both are circa 1986, and I haven’t been able to find any info about either company. Is anyone familiar with these, or the companies that made them? I’m not sure if I want to keep the upgrades, so I may just want to disassemble them completely, but I’d like to get more info before I make any decisions. When it powers up, there are no chimes, but I there is something on screen which suggests that there is a problem with either the RAM or ROMs. Any pointers would be greatly appreciated. Photos are attached! Thanks!
  9. I thought about putting this in peripherals, but it seemed better here since this type of floppy drive mechanism is exclusive to the 128 and 512K Mac. It is also found inside the guts of M1030 400K external floppy drives. As posted earlier (see links in this post), I have an early 128K Mac that is now fully functioning apart from the fact that it came to me with a non-working floppy drive. After a good bit of puzzling, I discovered that it was an original Sony OA-D34V 400K floppy drive (originally shipped with a stepper motor bearing the round sticker which should work in the 128K Mac with the Version A ROMs) with a stepper motor bearing the square sticker (more commonly found on the later OA-D34V-22 drives, and known NOT to work with the Version A ROMs). Since the drive itself bears a Feb 1984 production date, which predates the introduction of the square sticker stepper motor in summer 1984, I hypothesized that someone replaced the stepper motor on the drive at some point. Apple's textbook fix for this problem is to swap Version A ROMs for Version B ROMs, since Version B ROMs can read both types of drives. I have acquired a set of Version B ROMs, and the ROMs are socketed and easily swappable, so I could put in the Version B ROMs, keep the Version A ROMs stored with the machine for authenticity, and call it done. I don't intend to sell the machine anyway. But my OCD brain really wants the original type of drive in the original Version A 128K, and Science brain wants to take things apart. Frankenstein project: I have now acquired off ebay a collection of 5 400K drives, all pulled from 128K or 512K machines, all sold as non-working/AS IS (it was not totally clear to me whether the machines or the floppy drives had been tested and rated as non-working; possibly both, and I have visually examined the drives but not tested any of them yet). I paid more than I probably should have for this science experiment but I am measuring its value in hours of bench repair entertainment. The drives are a strange mix, as follows: April 84 - labeled OA-D34V - square sticker (I was disappointed to see this, as I knew one of the drives was an original OA-D34V and hoped it would have the round sticker) October 84 - labeled OA-D34V-22 - round sticker October 84 - no label where the OA label should be (?) - round sticker November 84 - labeled OA-D34V-22 - round sticker October 85 - labeled OA-D34V-22 - square sticker [this is the only "normal" drive out of the bunch] What I am wondering is this: can I remove the stepper motor from one drive and install it on another without highly specialized equipment, or will I end up with a non-aligned head mechanism that won't work on any Mac? It would be fun to rebuild my original floppy drive with a working round sticker motor. Another alternative is to see if the drives with the round sticker will work in my Version A Mac in spite of their OA-D34V-22 label. If the stepper motor is the only source of incompatibility, and Apple knew they had fixed the problem by instructing techs to install Version B ROMs in all machines with floppy drive incompatibility problems, they may have gone on for some months using up the "incompatible" stepper motor type in the Version B 128K machines they were selling up through late 1984. Nobody would ever know the difference since both types of drive worked with the Version B ROM machines. I would welcome advice on the wisdom of moving stepper motors around before I attempt radical surgery. Otherwise, I will report back here on my progress!
  10. I am having issues with my Macintosh 512k. The machine will usually boot with the checkerboard pattern shown in the pictures. Sometimes it will make a very distorted sound on boot. The issue is not with the crt as it has been tested with other boards. Occasionally the checkerboard pattern will change. I suspect the the issue is with the roms installed. I have tried cleaning the roms but this does not change the issue. I am curious if any one else has ever had a problem similar to this.
  11. cbmeeks

    New Favorite, Mac 512K

    So I just bought a (new to me) Macintosh 512K for $60 (USD). It came with the 512K (dur), keyboard (original), mouse (IIc mouse) and 400K external floppy drive. Oh, and a non-Apple bag to carry it all in. The computer has a small crack in the case on the top-right but I think I can eventually fix that or even replace it. It's also VERY yellowed so I got some retro-brighting to do. I will post some pictures later. The first thing I do is power it on. The seller showed a picture of it working. I don't have any software for it so all I got is the disk with a flashing ? on it. Which is a great sign! The startup tone was great too. The screen is superb. I cannot believe how great it actually looks. In fact, it's so bright that I have to turn DOWN the brightness to a comfortable level. The next thing I do is open it all up to see what damage it has. There is a SMALL amount of battery corrosion on the terminal leads. But it's so minimal I think I can literally put vinegar on it and scrape it off. When I opened the case, I was amazed how clean it was! Other than a little dust, there is NOTHING wrong with it. Almost mint. As you know, there are only three electrolytic capacitors on there. I will be replacing those soon. But they show no signs of leakage. I still cannot believe this board is all THT. Oh, even the ports on the board (DE-9, etc.) are super clean with no rust. I swear this board looks new. On to the analog board. Again, aside a little dust it's pristine. I will certainly want to re-cap it. I should start on that after Christmas. None of the caps look to be bulging. But I'm going to replace them anyway. So, as you can see, I'm very excited about this find. I think with some hard work I can make this computer almost new and mint with a few dings here and there (just like me...lol). Now, I have a few questions. 1) I attempted to remove the annode wire (I think that's what it's called) from the CRT. I made sure to properly discharge it first by connecting a long screwdriver to the ground wire of the CRT and slowly sliding it under the suction cup. I never heard any kind of pop. But I'm 100% sure I touched the metal under it. The problem is that I couldn't get it to come off. I didn't want to pry very hard but that wire seems to be bolted on tight or something. Is there a safe way to pry that thing off without cracking the tube? I've pulled them off on other Macs before. Not sure why this one has a death grip like it does. BTW, the suction cup is black and not red/maroon like someone mentioned in a previous thread. I thought they were all red/maroon too until I saw this one. 2) I'm pretty sure I have an 800K floppy as a spare. I have a super drive on a non-working SE/30 that I might be talked into using on this computer. But the fact of the matter is, 400K is going to be a problem. HOWEVER, since I have literally 0 disks/programs for this, is it possible to just buy some 400K software somewhere and use it? I just want to play a few games, mess with a few music programs and type a few letters. Nothing major. And since I have the external drive (also 400K) maybe the disk swapping won't be that hard. What are your suggestions? Do I need to upgrade the ROM if I use >400K drives? If I upgrade that drive, seems then that the external drive would be worthless. 3) Are there any recapping kits for the analog board on this computer? So that I don't have to manually trace down each size? Thanks!!!!!
  12. Hi All, I recently bought a 512k and It worked when powered on once after it was delivered. I unplugged it & spent a few weeks learning about the system & preparing to refurbish it. I plugged it in yesterday and there was a pfft and it started smoking. I unplugged it so no other harm was done. I've tried to look for description of a similar occurrence online, no luck. I've consulted the Dead Mac Scrolls & Macintosh Repair & Upgrade Secrets. Anyone have any ideas? Thanks
  13. dochilli

    Mac 512 Mainboard repair

    Hello! I bought a Mac 512 that has a problem with the mainboard. When I got the Mac, the ROM chips (low, high) were interchanged and the MAC did not start. I changed the ROM chips and the the MAC started somtimes. Sometimes I got a sad MAC with the error 05FFFF. Sometimes I got no Image and sometime the MAC started up to the disk picture. At every start I do not get a chime. When I put in a disk the picture begins to wooble and then the MAC crashes, sometime there can be heard some sounds. I can not read a disk without crashing. What I did up to now: - Changed the ROM against a ROM from as Plus => mainboard did not start (I tried this only one time, so I do not know if the mac would start, when I try it more often) - Changed the whole mainboard against a Plus mainboard => computer starts (analog board seems to be ok). - Controlled the voltages: +5, +12 and -12 are ok! - resoldered the mainboard connector from the analog board - changed the electrolytic capacitors. One of the capacitors (33mF, C5) could not be measured when it is soldered. Before soldering it shows 33mF after soldering it was not possible to measure. The other two could be measured when they were soldered. The polarity of all capacitors is correct. I do not have another diskdrive, so I could not test, if the drive is the problem, but I think there must be a problem on the mainboard. There is no chime, starting did not work every time (sometimes no picture, sometime sad mac, sometimes "disk mac"). If I do not connect the disk drive the problem occurs too. When I opened the Mac I saw that that the shield of the mainboard (metal sheet under the mainboard) had no paper card on the mainboard side, there was no isolation! So I think that there could been a short on the mainboard caused by the shield. Ok, I hope you can understand, what I wrote. I am from Germany... Has anybody an idea what I can do to repair the mainboard? It would be very nice to see this machine working again. Greetings Martin
  14. Macintoshguy1984

    Macintosh 512k RAM replacement?

    I have a macintosh 512k and keep getting sad mac error code 024280, I have found out i need to replace the ram. I did a google search of it, but couldn't find the right ram. RAM= NEC d41256c -20
×