Jump to content

davidg5678

6502
  • Content Count

    201
  • Joined

  • Last visited

1 Follower

Profile Information

  • Location
    USA

Recent Profile Visitors

826 profile views
  1. davidg5678

    RaSCSI Development Thread

    Your documentation is coming together very nicely! I look forward to being able to read it all when you finish. I have only ever had limited success understanding whatever it is google translate generates, so this will be a great alternative!
  2. davidg5678

    Broken Macintosh II Repair

    Thanks for the advice! I removed UB1 and UB2 and checked for continuity throughout the entire power circuit. I found no broken traces in the circuit (apart from a few that I was already aware of -these were fixed before testing, of course). The traces and functionality of the rear power switch are normal. I replaced the UB1 and UB2 chips with brand new parts; however, the computer now seems worse than before. When plugged in, it turns itself on and off and seemingly random intervals, each time without chiming or displaying a picture on the screen. The power buttons no longer have any effect on the computer. This one has me stumped. Any ideas @Bolle@techknight? Thanks!
  3. I'd be happy to do some testing for you! I have a restored SE/30 that I could test things out with. I'm located in Pennsylvania if you are interested.
  4. davidg5678

    Issues with Mac SE/30 display (and more?)

    Hmm... I think this may indicate that you have a failing power supply. It likely also needs to be recapped or replaced with a modern alternative. I found the video where I previously saw a similar-looking issue: If you take a look at the beginning of this video (about 50 seconds in), I think the issue the computer in the video has is similar to yours (at least as far as I can tell from your photos and descriptions). There is the same loss of horizontal deflection/lightning bolt pattern on the CRT. (The video below is about replacing the PSU entirely, but if you'd rather recap yours, the same channel has another video about that too.)
  5. davidg5678

    Issues with Mac SE/30 display (and more?)

    Are you able to verify the voltages produced by your power supply are correct? I think I once saw a similar pattern on screen when a computer had a faulty power supply.
  6. davidg5678

    Issues with Mac SE/30 display (and more?)

    All of the electrolytic capacitors on the logic board leak over time and cause corrosion which can result in video problems, among other things. These need to be removed and replaced with new ones. It is possible that some of the things you read about in the Dead Mac Scrolls are also true, but many issues are caused by these capacitors, which were not as big a problem the book was written. It is important to replace the capacitors on the logic board as an initial troubleshooting step, because there is a near guarantee that they are not working as they should. I also think moving the capacitor on your analog board is an important thing to do, as I also remember placing my capacitor in another location when I recapped it. These videos explain how to properly recap a Mac SE/30 Analog board and how to recap logic boards, so you may find them useful resources if you haven't seen them already. Good luck!
  7. davidg5678

    Apple IIGS

    IIGS's are really quite fun machines to work with! I think the pattern that you have on the screen may be indicative of a bad RAM chip somewhere. I've heard that RAM chips made by Micron fail frequently in Apple IIs. (This could be wrong, so if it is, feel free to correct me, anyone!)
  8. davidg5678

    Broken Macintosh II Repair

    I've decided to try replacing UB1 and UB2, along with the Z53C80 SCSI controller chip. Surprisingly, all of these parts are still for sale on Mouser.com, even the ancient SCSI controller. I have suitable replacement SMD diodes and transistors on hand, and I may also swap these out too. Hopefully, these replacements are all I need to make things work again! I'll keep this thread updated with further developments once I swap the chips. If you have any ideas or experience in fixing Macintosh II power circuits, I'd love to hear from you!
  9. I am working on a Macintosh II motherboard which will not boot up. It has been recapped, cleaned, and has had new batteries installed. Using this excellent article, I checked for continuity throughout the entire power circuit, and I have patched all of the broken traces I could detect. I have confirmed that there is a connection between R3, R18, and C6, as I read that this often goes bad. For good measure, I also added a patch wire from C14's positive side to UI14's pin 10. I desoldered UB1 and UB2 and cleaned their pads before reattaching them to the board. When I press either power button, sometimes the PSU turns on, but sometimes nothing happens at all. The power button on the back of the computer turns the machine off, but it then immediately turns itself back on. There is never a boot chime and nothing ever appears on the screen. I verified that the PSU voltages are normal. Sometimes I can make the PSU turn on with a jump-start, but the computer still does not boot, and even the ability to jump-start is intermittent. When working on this same board a few years ago, (with significantly worse equipment and skills) @AwkwardPotato recommended that I check pin 8 of UB2's voltage while pressing the keyboard power button. Apparently, the voltage is supposed to drop to 0v from 5v when the button is pressed; however, I have never measured a voltage at this point that is higher than 0v. The pin always seems to be pulled low. (assuming this is the correct terminology) I also measured voltages from the NAND gates 3 & 4, but they seem to be behaving abnormally. Instead of changing from 5v to 0v when a power switch is pressed, their voltages remain at 5v. I think this is part of why the computer is not turning on, but I am not sure how to proceed. (Maybe a component is defective, but I don't really know how to tell.) At least Q3's emitter is measuring within the right range. The computer doesn't chime -even on the rare occasion I can manage to get the PSU to turn on, nor is there is not a video signal. I am unsure whether or not this is a related or separate issue from the power circuitry problems. If anyone has any ideas or advice about how I can fix this computer, I would love to hear it! Thanks! I've placed AwkwardPotato's quote below along with a few links to some other, older posts for context.
  10. davidg5678

    Well Crap (SE/30)

    I think Y1 is a 32.768Khz Crystal, like this one: https://www.digikey.com/product-detail/en/ecs-inc/ECS-327-6-13FLX-TR/XC2128CT-ND/5875611 D1 and D2 are 1N914 Diodes. I found some for sale on Digikey, but they are all through-hole instead of SMD. If you can't find any SMD diodes somewhere else, these should still work just fine. There are three pads on the SMD package, but only two are used, so these two-legged diodes will work either way as long as they are installed with the proper polarity. https://www.digikey.com/product-detail/en/on-semiconductor/1N914/1N914FS-ND/978749 I gathered these values from the SE/30 Schematic re-creation PDF, which you may also find of use in repairing your motherboard. https://drive.google.com/drive/folders/10VO6n72vsn52xqMyOgSZpi11tbyv7_Yx
  11. davidg5678

    New SE and Miniscribe deep-dive

    For a bit more reliability, you could try adding a drop of oil to the bearings on the drive's stepper motor. This could have been what needed to get broken in when you first received it. I recently saw a video detailing this process on a similar hard disk, and it looked fairly promising. These huge physical drives definitely make some great noises while they are operating!
  12. davidg5678

    Troubleshooting SCSI2SD in SE/30.

    @PotatoFi I'm looping you in, as requested!
  13. davidg5678

    Troubleshooting SCSI2SD in SE/30.

    To confirm, the SE/30 you are working on has been recapped and otherwise is functional, right? If not, I would recommend getting the electronics sorted out before tinkering with a SCSI2SD, as it is difficult to know which problems are the computer's fault and which are the SCSI2SD's. I'm using a 16GB microSD card from PNY. It's nothing special, and I bought it in a two-pack for $9. I wrote to the SD card by downloading a premade disk image from the savagetaylor website, and by using the Balena Etcher program to copy the image to the card. I am running macOS High Sierra, but this should not matter as Balena Etcher is cross-platform. I use a single (slightly less than) 2GB partition on my SD card. Even though it is 16GB, and it would be nice to have access to additional space, I think it is best to stick with a simple configuration while troubleshooting. If you get things working, it is possible to access the rest of the card later on. To configure the adaptor, you should use the configuration information from section 3.1 on the savagetaylor website. (Setting up the SD card as a single drive) I opted for a slightly more advanced configuration and tweaked some of these settings for my machine, but there is nothing particularly wrong with how the guide states to do things. If things still aren't working, I would try to start over and follow the guides from the beginning again, just to rule out the possibility of a minor mistake somewhere down the line. While I personally never have had any issues with using SCSI bus power, I have read that it has fixed things for some people, so it couldn't hurt to try powering the SCSI2SD with USB or Molex if nothing is working. Good Luck!
  14. davidg5678

    Macintosh Plus (M0001AP) boot chime loop

    Many SCSI drives have rubber bumpers inside of them that turn into a sort of goo over time. When the drive head hits the bumpers, it gets stuck and prevents any additional data from being read. This is a common point of failure for many hard disks. It is possible that this has happened inside of your drive, however, the issue may also lie with corrupted software. If you don't care about the data on the drive, I would first try reformating it with something like the LIDO program to rule out a corrupted filesystem. Maybe @cheesestraws can include some sort of disk formatting program on the disk they are sending you?
  15. davidg5678

    SCSI2SD SD Card Extension

    I actually tried this exact same product previously but I returned it because I couldn't get it to work. I assumed that it was defective and bought some more from a different brand. I wonder why yours works and mine does not? The product I am now using came with two extension cables. I just tried the other one in the package, and I observed the same results. It works with my modern computer but not with my SCSI2SD. As far as I can tell, all of the different extension cables available online are the same product, but with different branding and lengths. I wonder if there is a different supplier somewhere that sells a different product that is more reliable. I could probably fabricate my own extender using these, some wire, and hot glue, but I am not sure how strong it would be without going through the effort of designing a PCB to attach things to securely. At the very least, I'd be able to twist the wires together for some shielding. Obviously, I'd prefer to avoid going this route if possible.
×