Jump to content
MikeatOSX

PowerBook 540c PRAM battery problem

Recommended Posts

Hi there,
I own 3 PowerBook 540c and I'm very happy with them. One has a SCSI2CF and another has a SCSI2SD built in, everything works but all 3 have a little problem: after a few minutes without power supply, my PRAM settings disappear. Date & time and energy store are deleted.
Date & time I can restore with Vremya or SetDate, but the PowerBook also wants to put the SCSI2SD to sleep after a short time loose it's own SCSI connection for a 3 or 4 seconds. 
So I also have to adjust the PowerBook control panel each time. 
Now I've disassembled a PB540c to add a new PRAM battery, but the old batteries show 5.62 volts! 
The new ones are 2x3 = 6 volts.
Is the old battery still ok and there's a different reason?
Can anyone give me a hint?IMG_1094.thumb.JPG.bd068dc1131481572ab6146bd345dfa5.JPG

IMG_1086.JPG

IMG_1093.JPG

Share this post


Link to post
Share on other sites

No difference with the new batteries. As I don't have a working main battery for my PB 540c, I let it sit provided with the power supply. Maybe after some hours I notice a result. 

Share this post


Link to post
Share on other sites

Maybe PB 500 series. 

I tried this with several PowerBooks 5300, as all of their main batteries leaked and are dead. 

All PRAM batteries of them are charged by the power supply board, when they are sitting for hours connected to the power supply. 

Share this post


Link to post
Share on other sites

After hours of connected to the power supply the PowerBook 540c now holds all it's PRAM settings, when disconnected for some time. [8D]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×