Jump to content
davidg5678

SE/30 Logic Board with broken SCSI and ADB for mouse movement

Recommended Posts

I recently purchased a new (to me) broken SE/30 motherboard to replace my overworked board that stopped booting correctly. The board I bought had been recapped; however, upon testing, it made the sad mac boot noise and displayed no video apart from a garbled mess onscreen. To troubleshoot, I scrubbed the entire board with vinegar to remove the little corrosion I saw and then rinsed it off with water. I then scrubbed the board with Isopropyl alcohol to clean it and blasted all of the liquid off with canned air. This solved some of the issues as the computer now booted with a normal chime and displayed a blinking floppy disk, although the video was still quite garbled.

 

I came across the capacitor replacement guide below and decided to double check the work done by the previous recapper (is that a word? :)). I found that connections from C1, C8, C9, and C10 were not as they should be. When I probed capacitor C1, I found that the pads on the board are opposite what the diagram says they are. This either indicates an issue with the board or the diagram, but I am unsure which one. I decided to leave it the same for now. For C8, C9, and C10, at least one of the pads on each was either missing or disconnected from its trace. I ran wires from each capacitor to the points listed in the diagram below. --Is this okay for the board or is it bypassing the resistors for each capacitor as stated in the bottom left of the diagram?

 

2098711859_SE30RecappingGuide.png.56f59090c58d0a4e022becc463ccc321.png961852046_SE30BoardTop.thumb.jpg.2b38c39b841d6be41056212b98a7e182.jpg1069295358_SE30BoardBottom.thumb.jpg.63febdf12bf45a3dacbd34ffe556b6f3.jpg

 

After all of this, the computer now turns on with a normal boot chime and displays a blinking floppy disk icon. The garbled video signals have disappeared for now, but I am not sure what caused them in the first place. All of the system voltages are normal enough (I measured roughly 4.8v and 11.83v at the floppy connector).

 

The blinking floppy icon is unusual as I have a working SCSI2SD plugged into the motherboard. (Tested on another computer) Nevertheless, when I insert a boot disk, the machine boots normally into my System 6 Installer. My SCSI2SD is not detected once the computer has booted either.

 

Strangest of all, my ADB keyboard works fine (as I tested with some keyboard shortcuts), but no matter which mouse I use, I am unable to move the cursor. I am able to click and open the Apple menu where the cursor is initially located on boot, but it does not move anywhere.

 

There are several pads missing under the UL11 ADB chip, but according to the schematic, all of the pads which actually were used still remained connected. I was able to confirm this with a multi meter.

 

Attached are pictures of both the board and the view underneath the UL11 chip.

 

Please let me know if you have any ideas as to how to fix this computer.

 

Thank you!

 

MVIMG_20190722_213338.thumb.jpg.5f7ac26204b8a40061512e1068784aae.jpg

 

 

Share this post


Link to post
Share on other sites

To summarize the brick wall of text I wrote above, I am trying to repair a recapped SE/30 motherboard which has partially functional ADB. I am able to use a keyboard and click the mouse, but I cannot move the mouse cursor. I have tried to troubleshoot this using different mice and ADB ports, but I can't get the cursor to budge. Should I try to swap the UL11 ADB IC as my next troubleshooting step, or should I do something else?

 

The pads for C8, C9, and C10 were all broken, so I ran patch wires from the capacitors to the locations described in the diagram above. I am not sure whether or not I bypassed resistors as referred to in the bottom left corner of the chart. Can anyone verify this?

 

I have confirmed using another motherboard that C1's positive side is connected to Pin 12 of J12 and that its negative side is connected to ground. This is the opposite of the diagram above, so I think it should be a non-issue on the board I'm fixing.

 

If you have any ideas about how to fix this computer, please let me know.

 

Thanks!
 

Share this post


Link to post
Share on other sites

I have swapped the UL11 IC with a working part from another board, but the mouse cursor still does not move. Are there other parts involved in the ADB circuit that I could check?

Share this post


Link to post
Share on other sites
On 8/16/2019 at 12:12 PM, Compgeke said:

Have you tried a different mouse in case the one you’re testing with decided to die?

I have tried using several different working mice, but the cursor will not move. Clicking and typing still work normally though.

Share this post


Link to post
Share on other sites

From the online searching I have been doing, it seems that most computers with broken ADB have completely nonfunctional ADB and not the partially functioning ports I have. However, I found this forum thread from a number of years ago about a somewhat similar issue:

 

I took a look at the book referenced in the forum thread ("Troubleshooting your Macintosh") and it recommended checking the RF Choke filter and Pico Fuse on the board for continuity. I was able to confirm that they were working normally on my logic board using my multimeter. I also measured 4.8v and a solid ground connection from the ports.

 

After reading the section on how ADB works in Apple's "Guide to Macintosh Family Hardware", it seems as if the issue I have should not be happening. From the diagram below, it looks like both the mouse and keyboard are relying on the same chips to work on an ADB level and that their functionality should be interconnected. Maybe something further down the line is not working correctly.

 

If anyone has any ideas, please let me know.

 

Thanks!

1973107571_ScreenShot2019-08-22at10_08_48AM.png.49a3182f91e4658c06904271f6718589.png

Share this post


Link to post
Share on other sites

I’m interested in the solution to this ADB issue as I’m currently troubleshooting the reverse situation in which my SE/30’s mouse works fine, but the keyboard is unresponsive.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×