Jump to content
Byte Knight

Netatalk SD Card Image?

Recommended Posts

VI (vim) has two modes, command and insert.

 

In command mode, move the cursor left right with j and k, up down with h and l.  Then delete characters with x, and then type i to get into insert mode, and enter what you want, then ESC to go back to command mode.  Then :w to save and :q to quit.  That should get you through it.  

 

If you get stuck and want to quit without saving :q! will get you out. 

Edited by pcamen

Share this post


Link to post
Share on other sites
23 minutes ago, LaPorta said:

I'm trying to read a vi tutorial....I'm liable to burst an aneurysm with this stuff

Unless you particularly want to learn vi as a general skill, try using nano instead of vi.  It has useful features like 'showing you what the keypresses do before you do them' and 'not being modal'.

 

Personally, I love vi, but it can be an acquired taste :-)

Share this post


Link to post
Share on other sites

When I was in college it was a battle between the VI crows and the Emacs crows.  Once you learn the key strokes for one or the other, it stays with you. I won't use an editor now that doesn't support the VI command set as I am so used to it and am very productive without ever having to take my hands off the keyboard. 

Share this post


Link to post
Share on other sites

So, I have yet to experience the a2server showing up in the chooser as an Appletalk server for any Mac.  Under OS 9, I can use the network browser to mount an Appleshare server via an IP address. Under OS 8, there is an option in the chooser for this as well, but it was not able to mount the share for some reason.  But under OS 7, I have not found this option.

 

Does anyone know what this might be about?  Shouldn't the a2server advertise itself as an Appletalk server so that Macs can readily browse to it? 

 

I should say, so far I am just trying this on Macs that are connected via Ethernet.  I have:

 

A Mac Mini G4 running 9.2.2 that can connect via IP from its native Ethernet jack.

A G3 Lombard via its native Ethernet jack.  I believe this one connects fine like the Mini. 

A PB 540c that I can't connect with the server as there is no way to select a share via IP.  It is connected to the network via the AAUI port Ethernet and an AAUI adapter.  Fetch on this machine can see my FTP server, so I know the network is functioning. 

Edited by pcamen

Share this post


Link to post
Share on other sites

Progress.  If I select Appletalk under the control panels on system 8, I found that I had to choose the Ethernet network, which was part of the solution for setting things right. 

 

67597320_Appletalkscreenshot_540c.JPG.33119f88b7d650ff096c3c82e4d2f411.JPG

 

And it found the a2server zone.   Then in the chooser it could see the Appletalk server.

 

Appletalk_screen_shot_2_540c.JPG.7ed95066ce56460b4a8562497d906a5c.JPG

 

However, it could not mount it. 

 

Appletalk_screen_shot_3_540c.JPG.b761ab508843ac276a0a32962a8ba91d.JPG

 

On the Lombard, a similar procedure.

 

Appletalk_Lombard_2.thumb.JPG.69ca27443c9f81c7d0acc6588c7c6d3f.JPGAppletalk_Lombard_1.thumb.JPG.b6a15880f818d5c1ee1ce98d3cca08d8.JPG

 

But as you can see, the Lombard with 9.2.2 asked for the credentials, whereas the PB 540c under 8.1 did not.  I suspect that is the reason it is giving me the no response error.  Or could it be something else?

 

 

 

Share this post


Link to post
Share on other sites

I had this error as well. I never tracked down what the problem was, only that re-installing it and using it with little to no modification made it work. system 6, 7, 8, 9 And OS X can all connect for me. Have you changed any settings?

Share this post


Link to post
Share on other sites
11 minutes ago, LaPorta said:

Have you changed any settings?

Well, yes, to get the Mac share running, but that is all.  Did you modify yours to create a Mac share? 

Share this post


Link to post
Share on other sites
1 hour ago, pcamen said:

However, it could not mount it. 

FWIW, I got this error when connecting to an AFP server that was trying to prefer IP, but IP wasn't enabled.  Check that TCP/IP is enabled and using the same port as AppleTalk?

Share this post


Link to post
Share on other sites
1 hour ago, cheesestraws said:

FWIW, I got this error when connecting to an AFP server that was trying to prefer IP, but IP wasn't enabled.  Check that TCP/IP is enabled and using the same port as AppleTalk?

Well, this is an a2server, so as a server it only has TCP/IP.  And I've connected to it via TCP/IP from my G4 Mini just fine; it does prompt me for the user and password like on the Lombard when I selected it via the Appletalk browser.

Share this post


Link to post
Share on other sites

Basically I just left it stock as-is. The share works perfectly fine. Even System 6 will read/write to it correctly (even though it won’t correctly display space used/space remaining since it is over 2 GB in size).

Share this post


Link to post
Share on other sites
10 hours ago, pcamen said:

so as a server it only has TCP/IP.

a2server does not only have TCP/IP, it does AppleTalk as well.  That's part of the point.  That's also why it's a bit picky, because the AppleTalk support in the Linux kernel is a bit hit-and-miss (mostly miss).

 

10 hours ago, pcamen said:

And I've connected to it via TCP/IP from my G4 Mini just fine

Yes.  I'm talking about the client running OS 8 that you were having "Server not responding" with.  Some versions of AppleShare will do service discovery over AppleTalk, then change to IP for the data connection, apparently.  If AppleTalk on the client is working but IP is not, then I got that error message.  This was a client-side fix for me.  That said, there are hundreds of reasons why the server might randomly stop responding so this is very much offered up for what it is worth.

Share this post


Link to post
Share on other sites

Hmm, well @cheesestraws other than adding a new share and enlarging the disk of the default a2server VM, I haven't made any other changes to the configuration.  I would assume then that it has Appletalk enabled, that seeming to be the point of the a2server setup.  But I'm just guessing.  I'll have to dig in and see if I can find some info about that.

 

But I did fire up another a2server VM that has not had any changes from the distribution to see if that makes a difference (and thusly I screwed something up in my changes). 

 

What is strange though is that if I have both running, in the Appletalk control panel, it won't let me choose between the Appletalk zones (as I renamed the zone in my modified one to include my server name).  But if I turn the modified one off, reboot, it seems the new (default config) one. 

Share this post


Link to post
Share on other sites

Yeah, I meant that you need to make sure that IP is enabled and working on the OS 8 client, not on the server.  But if you haven't changed anything then, well.  AppleTalk on Linux is a bit of a mystery honestly :-/

Share this post


Link to post
Share on other sites

What are your VM network adapter settings? How about the IP settings inside the Linux server?

 

I can always look at and compare my stuff with yours, if necessary.

Edited by LaPorta

Share this post


Link to post
Share on other sites
5 hours ago, pcamen said:

as I renamed the zone in my modified one to include my server name

If you have two things claiming to be a router and supplying zone info on the same network, weird things might happen?  That's a wild guess, I don't have a2server here, so I can't check what it's claiming

 

Sorry my suggestions are a little woolly :-)

Share this post


Link to post
Share on other sites
5 minutes ago, cheesestraws said:

If you have two things claiming to be a router and supplying zone info on the same network, weird things might happen? 

Well, I've been reading up a little on Appletalk Zones, and I think this is the way it works.

 

- Apple talk zones allow you to segment stuff on your network to make it more manageable.  But it isn't a physical separation like a VLAN or different sub-networks, it it just a naming separation.

 

- You can name stuff to belong to a particular Appletalk zone, and then when you select that zone, only the things named with that zone will show up.  Convenient if you have 50 printers in a building and only want the ones near you (engineering zone) to show up, for example.

 

If that is really how it works, then in theory, both of my zones should be available, and I should be able to select either of them.  I should also be able to change my modified a2server back to the standard a2server zone and have both servers show up under that zone. 

 

I'll have to do some more playing around. 

Share this post


Link to post
Share on other sites

Well, that may be a just plain wrong now that I found this:

 

https://developer.apple.com/library/archive/documentation/mac/pdf/Networking/Introduction_to_AppleTalk.pdf

 

Quote

A zone is a logical grouping of nodes in an AppleTalk internet. The use of zones allows a network administrator to set up departmental or other logical groupings of nodes on an internet. A single extended network can contain nodes belonging to any number of zones; an individual node on an extended network can belong to only one zone. Each zone is identified by a zone name.

Ok, so far so good.

Quote

An AppleTalk nonextended network is one in whichnthe network has one network number assigned to itnthe network supports only one zonenall nodes on the network share the same network number and zone nameneach node on the network has a unique node ID

An AppleTalk extended network is one in whichnthe network has a range of network numbers assigned to itnthe network supports multiple zonesneach node on the network has a unique node ID (Nodes can also have different network numbers that fall within the network number range and different zone names.)

Ah, ok.  So everything on the same non-bridged network has to be in the same zone.  So I guess running two a2servers with different zone names is a no-go then.  I'll have to change my zone name back to just "a2server" and give the server itself a different name to differentiate it from the stock one I fired up. 

Share this post


Link to post
Share on other sites

Yes, but the zone information for what nodes are available for a given network is stored by a canonical node which speaks the full Zone Information Protocol, as far as I know (I'll have to go and dig out Inside AppleTalk to check).  Even though they do not separate traffic (except multicast! which is surprisingly important...) they are still centrally defined objects, not an emergent property of the network.


So, my guess here is when you set a zone name explicitly, netatalk is going "well, nobody else is managing zone names on this network, I'd better do it", and firing up a ZIP listener (??).  If you end up with two in this situation, it might break stuff.

Share this post


Link to post
Share on other sites
1 minute ago, pcamen said:

So everything on the same non-bridged network has to be in the same zone

On an extended network (e.g. EtherTalk) there can be multiple zones per segment.  But a single node has to be responsible for maintaining the list of what zones are available.  On a non-extended network (i.e. LocalTalk, LToUDP etc), all machines must be in the same zone.

Share this post


Link to post
Share on other sites

Well, I now have two a2server instanced, both with the same zone name (in /etc/netatalk/atalkd.conf) and different host names (in /etc/hostname) and with the A2SERVER zone selected, I can see both servers.  So at least we know _that_ part works.  Now to fire up the 540c and try it with the stock a2server. 

Share this post


Link to post
Share on other sites

Oh, and BTW, I had to downgrade Virtualbox from the 6.1.x release branch to the 6.0.18 release as there is a bug that won't let a Virtualbox VM create a bridge with a thunderbolt ethernet adapter that was introduced in the 6.1 branch. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×