Jump to content
Sign in to follow this  
BL!

ASANTE MacCon+ TK/TP problem

Recommended Posts

As I've repaired the SE/30 I've started looking at my ASANTE MacCon+ TK/TP (Rev B) card. I can't get this going. As I'm no expert on MacOS etc. I'm struggling both with get the drivers on a diskette but also installing.

 

I found an diskette image (High Density) which is version 5.1.2 but it doesn't matter how I install it, I can't get card running (I see different evidence of drivers/applications being installed). 

 

The latest diskette with drivers I've found is version 5.6.1 but these images are in ".hqx" format and I've yet to find a method to extract them and create a diskette under Windows.

 

Of course, I don't know if the board is faulty or the card that is connected to the mainboard but at least there is activity when I connect it to a switch (green LED blinks).

 

I've tried several OSes so that isn't the problem at least.

 

So, any advice on how to expand and write .hqx images in Windows onto a HD diskette? If so, where do I download the correct software?

 

I've attached a picture of the MacCon+ TK/TP card connected to my switch.

 

TIA!

 

Asante_MacCon+_TK-TP.JPG

Share this post


Link to post
Share on other sites

I think you need the 5.6 driver.

Can you show the settings in OpenTransport or MacTcp? Perhaps we can find an error there.

The little switch must be set to the right position (RJ45 or AUI).

TPL= Twisted Pair, Link integrity enabled

TPN= Twisted Pair, Link Integrity not enabled

Tk=Thick Ethernet (10 Base 5)

Tn=Thin Ethernet (10 Base 2)

I can look at my SE/30 where the switch is positioned. I think it should be Tn.

Do you use a 10Mbit Hub to connect to your router? Modern router may have problems with the direct connection of old networkcards.

 

 

Edited by dochilli

Share this post


Link to post
Share on other sites

As dochili said, this could be an issue with a new network device not seeing the Mac properly...

 

 

ants had a same blinking green light - the culprit was that the card was unable to auto negotiate, so setting the device he was using to connect to 10 mbps half duplex manually allowed him to connect

Share this post


Link to post
Share on other sites

If you have a working copy of the 5.6.1 drivers I'm very interested.

 

I've managed to test the 5.2.9 drivers and the installer says that it cannot find the card. I have 6.0.8 OS installed right now. I haven't been able to run any other tool(s) which can scan the bus for the card.

 

The Mac Con for IISi SE30 card (the 1st card), if that is installed (only) would the Asanté installer see that as the "card" or does the installer only detect if the 2nd card is attached via the ribbon cable? Since this machine was owned by someone who shouldn't have tried to repair it I'm a bit unsure if it is working properly even though the network activity light blinks on the 2nd card. I'm also thinking that it could be a PSU issue (haven't measued the +5V yet though), maybe if I take out a few RAM modules and switch from a harddisk to a SCSI2SD card I might get some extra amperage.

 

But, a known good 5.6.1 drivers diskette would be a good step forward.

Edited by BL!

Share this post


Link to post
Share on other sites

OK, I looked at my networkcard: The switch is in position TPL. I use OS 7.5.3 and Open Transport 1.1.2. I connect my SE/30 to a 10MBit hub and this is connected to my router. The green led lights up and the yellow will light up, when there is traffic (with the green led off).

My settings in TCPIP can be seen in the attachement. With these settings I can browse in the internet.

I do not know which asante driver I am using, because I can not see any asante program on my SE/30.

Perhaps it would be a good idea to use OS 7.1 or 7.5.3.

TCPIP.JPG

Edited by dochilli

Share this post


Link to post
Share on other sites

You don't necessarily need the Asante driver. The card is based on the ST NIC chipset and will work with the generic Apple drivers that come with the system software as well.

The card has to be present in the Mac while the system software is installed though, otherwise the drivers won't get installed.

 

The installer should see the card without the breakout board attached.

As the others said if you have a driver installed you should see an ethernet device in OpenTransport TCP/IP panel (or MacTCP if you have got that one installed)

If you got that it is most likely a problem between your network equipment and the old Mac. Those cards back then did not support any kind of auto negotiation and most modern switches or home routers fail to see that they should fall back to 10mbit/s.

 

Normally I would say take a step back and see if TattleTech or Newertech SlotInfo shows if there is a card installed just to see if your card is good at all.

Might be a problem to get that one onto your SE/30.

 

You might want to set up Mini vMac on your Windows machine. That way you can extract all kinds of archived files that you downloaded and shove them into small disk images that you mount inside vMac.

If you're doing it right you can dd those images onto real floppies afterwards.

Edited by Bolle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×