Jump to content
Sign in to follow this  
ClassicMac

Bad caps leading to slow performance ?

Recommended Posts

I've never seen compute/task performance listed as a sign of bad caps or indicated as something that changed when caps were replaced.

 

What machine? What kind of tasks? Does it feel different than you expect?

 

Most 68k Macs are "not very fast" so it might just be that you're looking at and using a slow computer.

Share this post


Link to post
Share on other sites

Recapping isn't going to hurt at all but I also have never noticed a decrease in performance.  Maybe quiet or dead audio or a machine that won't boot but not just slow.

 

Many times a simple memory upgrade or a faster hard drive will produce dramatic results.  I remember when I upgraded my LC630 from 4MB RAM to 8MB, then 20, then 52, then a full '040 upgrade, overclocked to 40MHz and finally to 148MB RAM.  Those major jumps were like dropping a new machine on my desk... especially that first memory upgrade.

Share this post


Link to post
Share on other sites

The only time I've seen caps affect speed is when the SCSI bus was affected and got lots of errors due to capacitor problems. I couldn't see any issues in Mac OS, but in NetBSD I'd get SCSI errors in a constant stream. Recapping fixed the SCSI, and disk access went from painful to what we typically expect (mediocre).

Share this post


Link to post
Share on other sites

Dumb question here, what machine is it? I know my LC was woefully slow on System 7.1. Didn't take much use or software to drag it down more and more as I used it.

 

I downgraded it to 6.0.8 and it was positively spritely in comparison. 

 

But yes if you see "visible damage", and if you got the means and/or skill to repair it, don't waste any time. Atleast wash the PCB thoroughly and carefully.

Share this post


Link to post
Share on other sites

Your LC475 is not an LCIII or even close to equivalent. 

 

I suspected that it was an LCII for some reason.  SimCity 2000 is not going to run well on that, and it never will unless you found a Presto upgrade or something like that.  

 

LC's and LCII's were just notoriously slow from the get go.  System 6.0.8L is actually not bad, but once you load system 7, it just goes downhill.  I remember typing class in 9th grade - we had a lab of LCII's and like 2 or 3 LC475's.  We would just about fight to get on the "good" computers.  Even typing in ClarisWorks was painfully slow on an LCII. 

Share this post


Link to post
Share on other sites
Quote

LC 475 (AKA LC III has no issues)

A Performa 475 is NOT an LC III.  The Performa 475 is a 68LC040 and despite also running at 25 MHz, it will absolutely crush an LC III at everything.  It's not even close.  As Gorgonops pointed out, there is a 5x difference in performance from the 475 to the LCs.  That isn't an exaggeration. 

 

The LC and LC II are the slowest color Macs.  They were slow the day they were made and they are slow now.  Appreciate them for what they are and don't expect too much from them.  

Share this post


Link to post
Share on other sites
5 hours ago, eraser said:

A Performa 475 is NOT an LC III

Woah, I'd sort of missed the equating an LC475 to an LC III part.

 

Even an LC III would be a pretty good improvement over the LC II, mind you, in the ballpark of twice as fast. But it truly is no contest with the LC 475. The latter is just as fast as a Quadra 700 except for floating point ops, while the LC/LCII are, as noted, significantly slower than the original Macintosh II. Quite a large delta in between them.

Share this post


Link to post
Share on other sites

I learned something today: performa 475 is not an LC III! 

 

Makes sense why the game is so slow. Everything else is fine on it, the word processing, after dark screensavers etc. Its the raw lack of speed.

 

I did not know you could put System 6 on the Performa 400. I was under the impression that the Performa shipped after introduction of Mac OS 7 (although it should be identical to the LC which can boot system 6). I will have to try to boot off a system 6 floppy (6.0.8? right?) later tonight. 

Share this post


Link to post
Share on other sites
Quote

I did not know you could put System 6 on the Performa 400. I was under the impression that the Performa shipped after introduction of Mac OS 7 (although it should be identical to the LC which can boot system 6). I will have to try to boot off a system 6 floppy (6.0.8? right?) later tonight. 

 

The Performa 400 did indeed ship after 7.0 was released BUT "Performa" is only a name.  All Performas are repackaged Macs in a "consumer friendly" way.  That is, a Performa is a base model Mac (LC, Quadra, PowerMac, etc) that is given a Performa name and number and packaged with a collection of software and hardware meant to appeal to consumers.  The actual logic board is identical.  So, even though the Performa 400 shipped with 7.0, that Mac is electronically indistinguishable from an LC II and therefore can run any OS that the LC II can run ... because it's an LC II with a different name tag. 

Share this post


Link to post
Share on other sites

To add: LC and LC II are indeed fine at productivity software, simple/older online software, and simple contemporary games. The other thing to note is that simcity 2000 specifically is a couple years newer than the LC/II.

 

19 hours ago, Unknown_K said:

I think one of my LC 3's has a 68040 board (with FPU and heatsink that barely allows the cover to close).

A 475/605 motherboard installed in an LC III or an LC III with a PDS '040 upgrade?

 

Idle curiosity: Does anybody know what Maxis listed as the requirements for SC2000?

 

If I'm remembering the gameplay correctly, it should still be "usable" even if it's slow, but it was originally released in 1993, so I wouldn't be surprised if the LC/II meet the requirements.

Share this post


Link to post
Share on other sites
4 minutes ago, Cory5412 said:

Idle curiosity: Does anybody know what Maxis listed as the requirements for SC2000?

Macintosh Garden claims the system requirements were "68030/33 MHz, Mac OS 7.0 or higher, 256-color display". Their picture of the box doesn't seem to have the CPU speed requirement on it, but considering the Windows system requirements were a 25mhz 80386 or higher it's not unreasonable to think that 33mhz number is in the right ballpark.

Share this post


Link to post
Share on other sites

Maxis lists the color classics and LCs that leads to 16mhz being considered as acceptable, and Moby Games lists 68020 as base. :huh: 

 

Might not handle large cities well though if you went with base requirements.

 

83019-simcity-2000-macintosh-front-cover.jpg.bbcbc44cd647d78267fd88aad390ed55.jpg

early box

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×