Jump to content
Sign in to follow this  
jupo

SE/30s with dim CRTs

Recommended Posts

Hey, all. I have four SE/30s out of a large stash that have been in storage (long story) for years. I started going through them this week and I think all four logic boards are generally in working order after a thorough cleaning (apart from obviously needing recapped). But what seems to be new is that all four of them have terribly dim screens. I tried playing with the brightness pot on the analog board on one of them and although it did raise the brightness, it also became blurry and introduced diagonal lines unless I turn the front brightness knob back down to about half to 1/3 as bright as the Plus or SE sitting next to it.

 

I've been digging around but haven't seen any clear answers. I don't see visible issues with the capacitors on the analog boards, but is this where I should start anyway? Or the flyback? Or is scavenging a tube maybe from one of the SE's my only option?

 

Appreciate any and all advice...

Share this post


Link to post
Share on other sites

No improvement from swapping everything else from a bright and clear SE with the SE/30 that was otherwise most stable. I guess it is the tubes and I was mistaken on their past status, it was a long time ago. One has obvious burn in, but the others... I dunno.

 

Well, dim or not, these little workhorses are going to be my first logic boards to recap regardless. I can't keep procrastinating, I've already got a Mac II with significant damage and I can only blame myself. :( 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×