Jump to content
ants

Wifi Extension Development Thread

Recommended Posts

Vonets has another product (VAR11N-30) basically the same item, but this time you have a casing around, no antenna needed and a reset switch on one side.

 

Tested this afternoon, working.

 

This unit is a bit cheaper also and be carried around for a Powerbook for instance.

 

 

IMG_0820.jpg

IMG_0819.jpg

Share this post


Link to post
Share on other sites

Cool, I wonder if it's the same firmware? You could try the wifi extension and see if it works. I haven't compiled a PPC version yet though - do 68k extensions work on a PowerPC?

Share this post


Link to post
Share on other sites
1 hour ago, ants said:

do 68k extensions work on a PowerPC?

I know next to nothing about that, but logically, I assume that it should work in principal, as even the newest classic Mac OSes have a fair amount of 68k code in them, not to mention the very low level 68k emulation every version since 7.1.2 has included.

 

It *may* have issues with the newer Open Transport extensions, though.

 

c

Share this post


Link to post
Share on other sites
4 hours ago, techknight said:

out of curiosity, how does this work with Ethertalk? 

Good question - I don't know. A while back I tried to get AppleTalk working between my two Mac's over wifi, but to no avail.

 

From what I understand, modern routers do not forward the extra packets that AppleTalk sends over TCP/IP. So the problem might be solved by using an AirPort router which supports AppleTalk - however I don't know if the Vonets card supports the AppleTalk packets or not...

 

If I ever get my hands on an AirPort router I'll try it out.

Share this post


Link to post
Share on other sites
Quote

Vonets has another product (VAR11N-30) basically the same item, but this time you have a casing around, no antenna needed and a reset switch on one side.

 

Tested this afternoon, working.

Tested in an SE/30, working as well, slow but working.

Share this post


Link to post
Share on other sites
11 hours ago, bibilit said:

Tested in an SE/30, working as well, slow but working.

Great, thanks for the info. I'm super keen to know if my wifi extension works with the VAR11N-30. If you get a chance, please download the extension and try it out on your SE/30?

 

Stuffit File of extension is here:

https://github.com/antscode/MacWifi/releases/download/v1.0/MacWifi.sit

 

Cheers.

Share this post


Link to post
Share on other sites

Wooo!  Mine came in only a week!  That's ridiculously fast for ePack from China.  I gave it a go and it works great.  I'm going to test the extension, now and report back.

Share this post


Link to post
Share on other sites

OK, I gave it a try.  I get an "ERROR" in the menu.  It can't connect to it.  I did change the default login & password, however.  I'm guessing that's the reason?

Share this post


Link to post
Share on other sites
17 minutes ago, olePigeon said:

I did change the default login & password, however.  I'm guessing that's the reason?

I'm impressed that you manage to change the password using ResEdit - did you have to sift through the CODE resource? Perhaps for the purpose of testing, you could try setting the password back to its default via the Web Interface on the VM300 and see if that works.

 

The network scan takes about 10 seconds - but I presume you waited longer than that?

Share this post


Link to post
Share on other sites

This is probably riding the border of off topic, but what does the ethernet port on the vonets board do? I can’t seen to see any documentation for it.

Share this post


Link to post
Share on other sites

@markyb86 the VM300 can also function as a WAN router - that's what the onboard Ethernet port is for. It's unused when used as a wifi bridge.

Share this post


Link to post
Share on other sites

@ants Yeah, I waited several minutes but it never populates.  Probably something broke when the hex was shifted.  I'll try it again tomorrow with the default password.

 

Maybe it should be a control panel, then you can enter in custom options like login and password.  Or maybe a preference file you can edit from which it draws the login and password.  It'd be a good thing to do security-wise since you wouldn't want to leave it set to the default.

Share this post


Link to post
Share on other sites

Yeah the password should be configurable. If you're able to get it working with the default password then I'll look at adding a config dialog or prefs file.

Share this post


Link to post
Share on other sites

I had the same issue.

 

Try to reset the board (you need to short two pins IIRC)

 

Concerning the other problem, had a similar issue also, had to change the channel in my own setup:

 

 

 

Share this post


Link to post
Share on other sites
53 minutes ago, bibilit said:

I had the same issue.

Sorry was this an issue with the Wifi Extension stuck on "Scanning Networks"?

Share this post


Link to post
Share on other sites
Quote

It connects over ethernet, it shouldn't need to see the SSID.

It connects over ethernet for setup.

 

Quote

 you plug in the Ethernet cable and connect to your Wi-Fi network via it’s inbuilt web interface:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×