Jump to content
Sign in to follow this  
VinDuv

Mac SE/30: no boot and garbled display

Recommended Posts

Hello everyone, this is my first post on this forum.

I’m currently trying to repair a Mac SE/30 which hasn’t been working for a long time.
At one point it was working fine, but it started randomly rebooting and failing to boot properly, and eventually stopped booting at all.


I recently got another SE/30 (which works well except for some display instability and very faint sound volume) so I figured I might be able to used it to figure out what was wrong with the other one.
Well, upon opening it, I noticed that the battery had started leaking :-( The battery holder was very damaged, but fortunately the logic board itself didn’t seem to have suffered. (I dont’t think this is the original cause of the problem – I believe the battery was fine at this time).
I cleaned the logic board the best I could and recapped both the analog and logic boards.
I booted it up and got this (with no boot beep):

IMG_0475.thumb.jpg.7bcc9e50a473f77ddeb2668c8239047c.jpg

 

I think that’s the problem I had with it previously, so apparently replacing the capacitors didn’t help.
I’ve confirmed that the analog board is good by connecting the known-good SE/30 logic board.
Any ideas what I should be looking for?
I’ve attached a picture of the logic board:

IMG_0478.thumb.jpg.e63332fe65af2a8f2a99185d9bfa796b.jpg

(this is without the RAM, ROM and video ROM; I removed them to see if the display would change, but it didn’t)

Share this post


Link to post
Share on other sites

Also check the traces and vias aruond where the battery was.

Pic is a bit blurry there but I think I see some rusty/greenish vias and a few traces where the stopmask seems to get lost due to corrosion of the traces underneath.

A lot of address and data lines between ROM, RAM and CPU passing along right there.

Edited by Bolle

Share this post


Link to post
Share on other sites

Oh yea I forgot, this is a battery damaged board. 

 

and Bolle is right, but, ALL of the ROM/RAM/CoPro traces run there. they are likely broken which is why its not booting. 

Share this post


Link to post
Share on other sites

I would also look at C2, the amount of solder looks meager. I would check continuity on all the caps but definitely C11 has no holder at all.

Screen Shot 2018-01-15 at 1.25.57 PM.png

Share this post


Link to post
Share on other sites

The Dead Mac Scrolls, an invaluable resource for any ancient Mac aficionado, pre Quadra as the book came out when the majority of Quadras were under warranty.

 

I tried to find the precise symptom described by the photo of the screen but was unable to. 

 

On 1/14/2018 at 10:14 PM, VinDuv said:

 

IMG_0475.thumb.jpg.7bcc9e50a473f77ddeb2668c8239047c.jpg

 

 

 

The_Dead_Mac_Scrolls.pdf

Edited by Alex

Share this post


Link to post
Share on other sites

I tried to sharpen the image up a little more for anyone who believes a sharper image might help. I can't get rid of the slight shaky look of the image around the image, perhaps from a little bit of camera shake.

 

Also, I would like to point out a few things, if the tantalum caps were added by the previous owner, it might be a good idea to remove all the caps to verify the condition of the pads underneath and clean them up with flux and isopropyl alcohol followed by a continuity test. You could then also check if those caps are still good, they should be and I say this only because they are tantalum but worth checking when they are out.

 

Also, many traces have very dull looking solder joints and some of the joints on the tantalums look particularly poor and raises some questions about their reliability.

 

I know it's a lot of work to consider but it if the attitude is right, it could make for a fun afternoon, maybe not all fun but potentially rewarding but you will need to very careful view the board (read the board) section by section under a magnifying glass or other instrument to determine the real condition.

 

You might even consider cleaning it under isopropyl alcohol but very carefully as some of the solder joints if they are pointy could act as hooks, especially if using a q-tip. If pads or other exposed traces have solder joints that have pointy, hook like joints cotton can latch on and pull an already loose part or a cap and pad can just come right off. Be very careful not to life pads during any process as it does require procedures that are time consuming, require skill and care to reconstruct. I don't mean to discourage you but to ask you to consider taking care when handling a board of this vintage and condition as it can only add to more work on your part.

 

You might look into getting board ultrasonically cleaned as an alternative. This is a great process, especially as there has been battery leakage confirmed because it is very good at cleaning underneath components that you will not easily be able to get at. There may be a service local or mail-in that can simply perform an ultrasonic cleansing of the board which can give you some more assurance that the board is as clean as it can get. Do not use water, I've seen this done and water is not friendly to logic boards in my opinion. Yes, there are youtube videos of people doing it but I wonder how their boards behave a month later.

 

I have watched and read quite a bit on this, I don't purport to being an expert, nor am I formally trained but I hope these comments gear you in the right direction.

 

Attached are images of areas that appear to have bad soldering joints and or areas that need some cleaning. A sharpened image of the logic board as well.

IMG_0478.jpg.3eb998513bd64eecd95aa9b1eb49bdef.jpg

Screen Shot 2018-01-17 at 10.09.01 PM.jpg

Screen Shot 2018-01-17 at 10.09.19 PM.jpg

Screen Shot 2018-01-17 at 10.09.27 PM.jpg

Screen Shot 2018-01-17 at 10.10.00 PM.jpg

Share this post


Link to post
Share on other sites

Thanks for your replies! Sorry it took me so long to respond, I needed quite some time to check things.


To answer some comments: I was the one who replaced the capacitors. I agree I didn’t do a very good job soldering the tantalum caps so I redid it; it’s a bit better now :-) For C2 and C11, I soldered the new ones on the other side of the board only.

 

To help me check the traces, I downloaded the SE/30 logic board diagrams from this site.
I started checking for conductivity on components near seemingly damaged traces (around the battery holder and the serial ports), but I eventually gave up and checked each and every connection indicated by the diagrams.

 

It took some time… Here’s what I found and how I attempted to fix it:

  • No conductivity between C4 and R12: soldered a wire between them, going though the nearest mounting hole
  • No conductivity between pin 35 of the ROM SIMM connector (A12 line) and the other components: soldered a wire between this pin and pin 2 of UK6, on the back of the board
  • No conductivity between pin 41 of the ROM SIMM connector (A18 line) and the other components: soldered a wire between this pin and pin 30 of J13, on the back of the board
  • No conductivity between pins 10,13 of UI3 (A12 line) and the other components: soldered a wire between pin 10 of UI3 and pin 35 of the ROM SIMM, going though the mounting hole from the dead battery holder (probably not the best idea but well…)
  • No conductivity between pins 3,6 of UJ4 (A18 line) and the other components: soldered a wire between pin 3 of UJ4 and pin 41 of the ROM SIMM, going though the nearest mounting hole
  • No conductivity between pin M11 of UK8 (D9 line) and the other components: soldered a wire between this pin and pin 96 of J13, on the back of the board
  • The PU (?) line had conductivity between pin 12 of UB12, pins 4,12 of UC12, but not with other components: found a contact on the back of the board connected to pin 12 of UC12 and another connected to pins 8,9 of UG12 and soldered a wire between them

I checked that the newly made connections matched the ones on my “good” SE/30 board and they seem fine.

 

Unfortunately, it didn’t seem to help much. When the SE/30 boots up I still get the same pattern on the screen.

However, I noticed something interesting:

  • When the SE/30 is powered up, it only displays the weird pattern on the screen. No boot beep.
  • If I press and hold the reset button, the screen goes black and stays that way (sounds reasonable…)
  • When I release the reset button, the same pattern reappears on the screen instantly but I also hear the boot beep. It doesn’t seem distorted or anything. The Mac doesn’t seem to do anything else though (no floppy drive activity). 

So apparently some things still work on this logic board…

 

Meanwhile, I started testing the rest of the SE/30 by using the working logic board, and I found another strange issue: The screen is too bright (black pixels are grey), and the brightness control does nothing. I tried adjusting the max brightness setting on the analog board but I found out I had to set it to zero to get a reasonable image, still quite bright; even with this the brightness control does seemingly nothing.


I changed the capacitors on the analog board but it didn’t change a thing. However, I swapped the little board on the back of the CRT (not sure about its name?) with the one in from the working SE/30, and it started working fine, brightness control included.


I checked the connections on the board but they seem fine. I suspect a faulty contact in the round 7-pin connector but I haven’t checked it yet.

 

On a more positive note, I replaced the capacitors on the other SE/30 logic board, which was working but produced almost no sound (nothing from the internal speaker, and a very low sound on the headphone output), and it seems to have fixed this problem!

 

So I now have 2 working analog boards, 1 working CRT board and 1 working logic board. Enough to get one working SE/30 but I wouldn’t mind raising this number :-) 

Share this post


Link to post
Share on other sites

Keep up the great work :) There are a lot of SE/30 repair threads in the forum at the moment!

 

I have a dead logicboard, a working one, and one that's somewhere in between... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×