Jump to content
stretch

Powerbook G3 Obnoxious Battery

Recommended Posts

Given: A G3 Lombard with two batteries. I also have a stand alone battery charger.

 

The machine recognizes the presence of battery #1. It runs on it and charges it with no issues.

 

The machine does not recognize battery #2. This eliminates a problem with the machine. I've tried both batteries in both bays. The problem follows the suspect battery. I've tried that Battery Reset program from Apple. No dice. Battery #2 charges fine on the stand alone charger. It currently shows four green lights. If I unplug the power cord with battery #2 installed, the machine will die within 30 seconds.

 

I had a third battery that was boat anchor dead. It wouldn't do anything anywhere. So, I broke it apart to see the innards. Since I really damaged the case in the process, I'm not going to do that again.

 

Does anyone know of a pin-out for the battery? I'm thinking that maybe if I momentarily short the proper contacts, I might be able to reset the controller board internal to the battery without breaking it open.

 

Anyone have any other grand ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×