Jump to content
Sign in to follow this  
TheMacGuy

iBook G4 not-Auto Connecting to Preferred Networks

Recommended Posts

I've run into a small dilemma on my iBook G4. Every time the system either reboots with the adapter plugged in or looses power when I disconnect it, when I turn it back on, it says that none of the preferred networks are available, even though my network shows up on the list. I check Network Prefs. and it has my network in there with the correct password. Here are network and system specs:

 

3 AirPort Extremes, 1 Express (1 Extreme is the main router, Express and 2 Extremes are network extenders)

Broadcasts 2 networks, a 2.4GHz (for the iBook) and 5.0GHz (for my Intel machines)

WPA2 Personal password

 

 

1.42GHz iBook G4 14"

512MB of RAM

Integrated AirPort Extreme card

Running 10.5 Leopard

Share this post


Link to post
Share on other sites

My imac G5 did this alot, In system settings, network, choose airport. Pick the network there to connect to preferred, then hit the lock for that and it should remember. It worked for me, hope it helps you.

Share this post


Link to post
Share on other sites

Thanks I'll try that. I went ahead and did an OS reinstall anyway, since I think I may have screwed up some files when deleting unneeded languages and Intel binary files.

Share this post


Link to post
Share on other sites

I figured out what its doing. I put in my password to the network (which is 10 digits), and I rebooted, looked at it again and it was showing 8 digits. Anyway to fix this?

Share this post


Link to post
Share on other sites

Try opening up Keychain Access (Application Folder > Utilities Folder), Trash the key pertaining to your Airport password in the System Keychain, then reconnect to your Airport, it'll prompt for the password, then type it in. Voila!

 

Sounds like also the PRAM battery is getting old or low. You may want to see about replacing it, if possible.

 

73s de Phreakout. :rambo:

Share this post


Link to post
Share on other sites
Try opening up Keychain Access (Application Folder > Utilities Folder), Trash the key pertaining to your Airport password in the System Keychain, then reconnect to your Airport, it'll prompt for the password, then type it in. Voila!

 

That was part of the problem. Keychain wasn't picking up the password and it had no entry in Keychain Access, so after some Googling, I found (from the MacWorld forums) how to manually enter the info. It works for the most part, just needing to help to remember what network it should be apart of. Just click the network, enters in the password automatically and click OK.

 

Sounds like also the PRAM battery is getting old or low. You may want to see about replacing it, if possible.

 

The ibook G4 doesnt have a pram battery.

 

In some way, yes the iBook does have a PRAM battery. It relies on a capacitor that holds the PRAM info, that is charged off the battery.

Share this post


Link to post
Share on other sites

Yes I figured it out! I got it completely fixed and it was pretty simple. Heres my remedy for the next person:

 

Go to Applications>System Preferences

Move System Preferences (SP for short) from Applications to Applications>Utilities (will ask for admin password)

Move SP from Applications>Utilities back to Applications

Go to SP>Network>AirPort>Advanced. Click on your network, and click the minus to remove it

Turn Off AirPort

Go to Applications>Utilities and open Keychain Access

Under Keychains select Login

Under Category select All Items

Remove anything with your network's name on it

Leave Keychain Access open

 

Go back to System Preferences

Go to Network>AirPort

Click Advanced

Under "Preferred Networks", click the plus sign

Type in your networks name (what the public sees, also called an SSID)

Select the type of security your network has and enter the password if needed

Make sure "Remember this network" is checked

Click Add

 

Go back to Keychain Access and the password should be there. Turn on AirPort and try rebooting your computer to see if it works.

 

It's easier then it sounds.

Share this post


Link to post
Share on other sites

Hey again,

 

It is looking like my problem is more involved than just a simple corruption of preferences or anything software wise.

 

I first posted my problem on the MacRumors site, and somebody posted a link to this:

 

http://reviews.cnet.com/8301-13727_7-10332007-263.html

 

I haven't opened it up yet to look inside, but I have made some reliable observations:

 

After a cold start, or having had the Airport off overnight, I can get 30 minutes of use first time out, before it drops a connection.

 

Then, after it drops a connection, if I turn it off for at least 10 minutes, I can then turn it back on and get 5-10 minutes of connectivity before it drops again.

 

So, it looks like a mechanical fault caused by heating/cooling. Interestingly, according to the article, this was only reported in the 2005 iBooks, the 1.42GHz model (the last, and "top-of-the-line") so others may be unaffected. I am supposed to get another family members 1.33GHz 2004 model, so when I receive it, I'll be able to make some comparisons.

 

So, right now, I'm doing fine with a USB wireless modem...better than nothing, I suppose. Ugly as sin, though!

Share this post


Link to post
Share on other sites

This is a completely different issue then what I was having. Mine wouldn't auto connect when rebooted, but would see the Wi-Fi networks.

 

From what the article said, that problem sounds like software.

 

But from your explanation, it sounds like your issue is hardware.

 

What OS are you running? I'd try a reinstall of the OS first. If that doesn't work, I would think about replacing the AirPort Card. Even though it came factory installed, I think there is a way to replace it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×