Jump to content
Sign in to follow this  
commodorejohn

Pismo G3 - won't return from sleep mode in 9.2.1/2

Recommended Posts

Since I got my Pismo working again, I've wanted to start putting it to more use, especially in a travel context (thanks to the two battery bays - why don't more laptops have this option?) But I've discovered something aggravating: with OS 9.2.x installed, it won't come back from sleep mode. It just sits there at the blank half-tone screen indefinitely; no disk activity, no nothing. It won't respond to the three-finger salute, I have to power it off by holding down the power button.

 

I know it's not a hardware thing, because I tested it during the reinstall phase with 9.0, and it worked just fine. I've read about the OS9 "sleep of death" bug, but everything I've found on it has been contemporary with the release of 9.2, and I can't find if there was ever any conclusive cause/fix discovered for this. I tried Sleeper 3.5 from St. Clair Software, which is supposed to be an Energy Saver replacement, but all that seems to do is replace the actual sleep mode with a customizable set of power-management options - you can enable proper sleep, but it lets you know that that's just falling back to the default sleep functionality and won't fix a non-functional sleep mode, so no dice there :/

 

I'll roll back to 9.0 if I have to, to get proper sleep-mode functionality, but I'd really rather not. Is there a better way to address this?

Share this post


Link to post
Share on other sites

In addition, can you boot it into Open Firmware mode and tell me what version of ROM is running? IIRC, the last firmware update put it to version 4.1.8f5. I think that version may fix the sleep issues; reading the descriptions tells me the update improves overall stability and performance issues. Whilst in there, try also typing in the following incantations (minus quotes):

 

reset-nvram [Return]

set-defaults {Return]

reset-all [Return]

 

If the firmware is not up to 4.1.8f5, do a search for the update on Apple's support pages, reboot into OS 9 and install the update. To recall, Apple shut off software updates for anything earlier than OS X Tiger, so a manual search and install would be in order.

 

73s de Phreakout. :rambo:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×