Jump to content
Schadenfreude

Mac Classic Server for Retro Challenge - Need Some Help

Recommended Posts

Hello 68kmla,

 

:?:

 

I'm looking for a little help to get my entry up and running.

 

I'm planning on taking part in the Retro Challenge coming up in about a week. What am I doing? Well... I can't spill all my secrets... but I want to host my progress site on my blazing fast Mac Classic. So far I have the software set up and working okay. I'm having a slight problem with having the domain I registered with DynDns.org to resolve properly.

 

The Macintosh Classic is running MacHTTP 2.5.1 to serve the site on port 80. It is connected via an Asante ENSC to the network with a static IP of 192.168.10.105. My router is set up for Dynamic DNS through DynDns.org to resolve the address thismac.is-a-geek.com (the "is-a-geek.com" is one of DynDns.org's free domain options). The router is running a virtual server to direct traffic coming in on port 80 and to the Macintosh Classic.

 

Sending a ping command in Terminal to thismac.is-a-geek.com returns the IP address of my router. A quick DNS Lookup on any search engine returns this too.

 

I have tried changing the port settings on my router and MacHTTP to 8008, 8080, and a few others with little luck. The address thismac.is-a-geek.com won't resolve properly. I believe that my ISP may be blocking these ports (it is a university connection... ssshhh). Is there a way around this issue?

 

What does work? Typing the IP address 192.168.10.105 on my network to access the Mac Classic. Changing the port settings and typing 192.168.10.105:xxxx also does work. Accessing the server from an external network does not work though.

 

Any help would be greatly appreciated!!!

 

Some of the hardware I may be using...

Unpacking Collection in Progress

Share this post


Link to post
Share on other sites

Obviously MacHTTP is configured correctly if you can access it locally... I would try setting up your router to do port forwarding. Set the private port to 80 and the public port to 8080, but leave MacHTTP running on port 80. Then try http://thismac.is-a-geek.com:8080.

 

Good luck... and don't forget to get your entry submitted!

Share this post


Link to post
Share on other sites

ok erm.. this is my deal.

i have my router forwarding port 80 traffic to my 540c with a fixed ip and running mac http as you are.

i have the haddodock.no-ip.biz domain - from there i run the no-ip app on the 540c, which syncs my ip to the no-ip service and traffic gets to me.

i have not played with nor ever needed to play with the dynamic dns settings in my router, which i have always found to be a pain to set up.

my way is easier i think. however if your machine ip and your external (visable to the internet) ip is static then you can do without the no-ip app.

Share this post


Link to post
Share on other sites
ok erm.. this is my deal.

i have my router forwarding port 80 traffic to my 540c with a fixed ip and running mac http as you are.

i have the haddodock.no-ip.biz domain - from there i run the no-ip app on the 540c, which syncs my ip to the no-ip service and traffic gets to me.

i have not played with nor ever needed to play with the dynamic dns settings in my router, which i have always found to be a pain to set up.

my way is easier i think. however if your machine ip and your external (visable to the internet) ip is static then you can do without the no-ip app.

In general, the dynamic DNS (DDNS) settings in the router simply do the same job as the no-IP app that you're running on the 540c. Generally you just have to enter your username/password and domain name and the router handles all of the automatic IP address updating with the DDNS service. I've used it on Netgear and SpeedTouch routers without a problem.

 

Anyway, back to the original question. It sounds like the DDNS is working just fine and redirecting to your router, and also that MacHTTP is running just fine on your local network. Therefore, logic dictates that there must be a problem somewhere in between! What make of router are you using? There's usually an option called "port forwarding" which will achieve what you're trying to do. I'm not familiar with the "virtual server" settings, so I guess this could be the same thing...

 

The other thing to watch is that your machine has a fixed IP address assigned to it's MAC address on the router. If not, it may well take a different IP address when you restart and break your port forwarding set up. There's usually an option to permanently assign an IP to a specific MAC address in the router's control panel.

Share this post


Link to post
Share on other sites
There's usually an option called "port forwarding" which will achieve what you're trying to do. I'm not familiar with the "virtual server" settings, so I guess this could be the same thing...

It is. I have a D-link router that does port forwarding via the virtual server settings.

Share this post


Link to post
Share on other sites
Anyway, back to the original question. It sounds like the DDNS is working just fine and redirecting to your router, and also that MacHTTP is running just fine on your local network. Therefore, logic dictates that there must be a problem somewhere in between! What make of router are you using? There's usually an option called "port forwarding" which will achieve what you're trying to do. I'm not familiar with the "virtual server" settings, so I guess this could be the same thing...

 

The other thing to watch is that your machine has a fixed IP address assigned to it's MAC address on the router. If not, it may well take a different IP address when you restart and break your port forwarding set up. There's usually an option to permanently assign an IP to a specific MAC address in the router's control panel.

 

I'm using a Trendnet router. Oddly there is no specific area entitled "Port Forwarding," but the Virtual Server does allocate which machine on the internal network is the server. Here's a link to an emulator of my router. Virtual Server is located under the "Access" option. http://www.trendnet.com/emulators/TEW-432BRP_B1/adv_virtual.html

 

I do have both the IP and MAC address for the Classic set as static numbers. I will play with the port settings a bit more today and see what I come up with.

 

Thanks!

Share this post


Link to post
Share on other sites

Pretty similar set-up to my D-link... nicer interface though ;-)

 

One thing you can try (if you suspect your router settings are the issue) is to set the server as the DMZ host. That leaves all ports open, then if you still can't hit port 80, try changing it in the MacHTTP config.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×