Jump to content


Photo

Mac IIfx turns on but no chime


  • Please log in to reply
9 replies to this topic

#1 Pitou

Pitou
  • 6502

Posted 07 February 2017 - 04:30 PM

Hello,

 

I have a Mac IIfx that I just recapped. I now turns on, but I get no chime/sound at all.

 

I tested the ROM SIMM and RAM simms in another Mac and it's fine.

 

Any ideas/pointers?

 

Thank you.

 

Pitou!



#2 mac-man6

mac-man6
  • 6502

Posted 09 February 2017 - 02:17 AM

Are you sure the speaker was reconnected after recapping?


iMac 17" intel 1.83ghz, Quadra 840av, PB150, iMac G3 266hmz ATX hack, SC20 HD.

#3 Pitou

Pitou
  • 6502

Posted 13 February 2017 - 02:06 PM

Yes the speaker was connected. I am lucky enough to have another logic board. I replaced many logic chips and still no luck. I'm thinking the main 68030 CPU might be blown. It happened before on another Mac II. I played around with the scope, but it's a bit hard without the schematics.

 

I'll hunt for a new CPU.

 

Do you know if I should at least get the startup chime *without* the 68882 co-processor?

 

Also, to get it, I must have at least for banks of RAM filled. Is that right?

 

Thank you.

 

Pitou!



#4 CelGen

CelGen
  • 68000
  • LocationKamloops, Canada

Posted 18 February 2017 - 05:06 PM

Minimum of one bank of ram filled but no idea bout the missing processor.

Verify you don't have leak damage somewhere.



#5 zuctronic

zuctronic
  • 6502
  • LocationChicago

Posted 22 February 2017 - 09:57 PM

Any update on this? I have the same issue with a Mac IIfx.



#6 Pitou

Pitou
  • 6502

Posted 24 February 2017 - 07:11 PM

I replaced the CPU but still the same. I'm about to try a new 68882 FPU.

 

My guess is that the fx needs both the CPU and FPU in order to boot what's in the ROM SIMM.

 

Will let you know.

 

Pitou!



#7 zuctronic

zuctronic
  • 6502
  • LocationChicago

Posted 25 February 2017 - 11:39 PM

Ah, in my case it turned out to be the ROM. I tried a ROM-inator II from BMWOW and it's working now.

So now the question is: Is it possible to repair the bad ROM? How do I go about troubleshooting it? I don't see any replacement Mac IIfx ROMs available anywhere but I'm interested in restoring OEM parts as much as possible..



#8 techknight

techknight
  • 68LC040

Posted 27 February 2017 - 01:16 AM

if the ROM is bad, then it COULD be suffering from bit-rot if it started life as a PROM so it works exactly like EPROM but with no window. So you burn it and its done. 

 

if its mask-ROM its likely something different like failing buffer circuits etc internal to the IC. 


Edited by techknight, 27 February 2017 - 01:20 AM.

Main PC: Intel core I7 920, MSI x58 platinum, Radeon4850
PB: tibook G4, ibook G4, ibook g3x2, Lombard, 160, 165, 180, 180c Duo 2300x2, Duo 270c x2, 520cPPC, 3400c, 1400c
Desktop: G3AIO, SE, SE/30, 512k, plus, LCIII, iMac G4, iMac intel, 6400/225

#9 zuctronic

zuctronic
  • 6502
  • LocationChicago

Posted 27 February 2017 - 01:28 PM

I took a closer look at the Apple ROM SIMM and noticed the contacts were looking pretty dull. I wiped them down real good with some IPA and now it's working fine!

P.S. - A/UX doesn't boot with ROM-inator II


Edited by zuctronic, 27 February 2017 - 01:29 PM.


#10 Pitou

Pitou
  • 6502

Posted 09 March 2017 - 05:50 PM

I'm now getting the startup chime.

 

However after a couple of seconds, I get another sound/chime.

 

I tried the RAM simms in another MAC and they are good.

 

Can you tell me what it could be related to?

 

Thank you.

 

Pitou!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users