Jump to content


Photo

G4 L3 Chache failure


  • Please log in to reply
3 replies to this topic

#1 Bolle

Bolle
  • 6502
  • Location.eu

Posted 21 December 2016 - 11:56 AM

Since a few days my Sawtooth with an OWC upgrade 1.3GHz 7455 and 2MB L3 is failing the power on self test and gives an error for external CPU cache.

NVRAM resets and different clock settings on the upgrade card do not change anything. The cache keeps failing on POST.

The Samsung SRAM chips which are used for L3 cache are specified for up to 333MHz. CHUD Tools say the L3 speed registers are set for 1:5 operation, so plenty of headroom there.

 

Is it possible that those SRAM chips fail? Unfortunately it seems to be hard to still get the same Samsung chips as replacements.

Next thing I am going to try is to reball those little BGA153 buggers and see if it was just a bad connection. Waiting for a correct reballing mask to arrive from china.

 

Any other ideas on this? Could the CPU itself also be the cause for this? I noticed that the CPU die seems to have a little damage on one edge, but it has been this way since I got the CPU with the warranty sticker on the heatsink still intact - so it must have been coming from the factory like that.

 

Can the L3 cache be disabled somehow to get rid of the annoying POST failure message when booting Mac OS 9? Removing the cache chips at all is still giving me an error message btw.  }:)


Bluets and Granola Bars, Make a chewy snack.

#2 IlikeTech

IlikeTech
  • 6502
  • LocationSomewhere very cold and snowy, USA

Posted 21 December 2016 - 12:04 PM

Are you sure you mean L3 cache? I think it is L2 cache. I am really not sure, but does the computer run fine with the accelerator removed?

Main Computers:  Q6600 Based Desktop, Mac Mini 2009, MacBook Pro 2011 15inch.

Vintage: iBook G3, iBook G4x2, Mac Mini Core Solo, iMac G4, Mac SE, and a Quadra 650 In the process of an ATX Conversion.


#3 TheWhiteFalcon

TheWhiteFalcon
  • 68030
  • LocationArizona

Posted 21 December 2016 - 12:27 PM

It's possible the cache chips failed, yes. You're sure the jumpers are correct?

Desktops: Cube, iMac G4, 128k, 512k/Plus, SE/30, IIsi, Q700 PVT. Laptops: 180, 3400c, Pismo, TiBook, iBook Clamshell, MBP 15", MBA 13", Unibody MB, '15 MBA13 Portables: MP 130, 2100, eMate.


#4 Bolle

Bolle
  • 6502
  • Location.eu

Posted 21 December 2016 - 12:37 PM

The board only has jumpers for Bus/CPU multiplier. I tried settings between 600MHz and 1.4GHz but the cache is not working on any setting.

 

 

Are you sure you mean L3 cache? I think it is L2 cache. I am really not sure, but does the computer run fine with the accelerator removed?

 

Yes. The 7455 has on chip L2 cache and an L3-backside-external-whatever cache that usually consists of one or two DDR SRAM chips.

The machine is running ok without the L3 cache but gives an error message early in the boot process of OS 9 and shows something along the lines of "self diagnosis failed: external cache" in system profiler in OSX.

Unfortunately I do not have another CPU module to test in this machine as I got it with the upgrade already installed.

 

 

Edit: ouch, just saw the typo in the topic. Can someone of the mods correct that?


Edited by Bolle, 21 December 2016 - 12:40 PM.

Bluets and Granola Bars, Make a chewy snack.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users