Jump to content
galgot

The cursed Clamshells

Recommended Posts

Got a lime Clamshell with broken screen some time ago, that one :

Except the screen, the thing is in good condition , and could even boot and display part of the desktop were the screen was ok.
anyway , got another good screen from Bibilit, an IBM with the good cable. The broken one was a Samsung. So I had to disassemble to change the cable too … Did that, and thought it would be Ok.
It boots, but to a grey screen :-/ there is the chime, and can hear the disk as it starts the OS and all, but only grey screen. Tried all the usuals, zap PRAM, NVRAM, boot in OF, reset-all… no joy.
 
Ok … I also have a Blueberry Clamshell with a failed backlight screen. Thought at least all is not lost, I’m gonna try the new IBM screen on the Blueberry. Lucky that Blueberry failed screen was an IBM too, so didn’t had to change the cable.
Guess what ? NO BACKLIGHT :-/ Even though that screen is good. 
 
Okay Then… so maybe it’s the inverter… took the inverter from the Lime (At least I know that one works cause it gives me a bright GREY screen…) 
Nahh… Still no backlight.
 
Okayyyyy... let's try another inverter then. Took one for a working Tangerine...
!%$£&##... STILL NO BACKLIGHT !
 
From my frustration, These two stayed locked in the closet for few month.
 
But would see these Clamshells each time I opened that closet, so recently got another good screen. A Samsung, knowing the one from the Lime was an Samsung too, and maybe cause of that grey screen was that it didn’t liked IBM…
 
Nahhhh… same thing…
 
So , I have two good screens , each of the correct brand that could work on these Clamshells, but it doesn’t . I’m out of ideas and frustrated.
 
Should I trash these Clamshells ?

Share this post


Link to post
Share on other sites

First, If I'm not mistaken there is a fuse somewhere on the logic board for the backlight. Second, for the lime Ibook I'd start by reconnecting the original screen to make sure that still works.

Share this post


Link to post
Share on other sites

Without the original screen, we dont know what was ACTUALLY in there. 

 

Even though you stuck an IBM or another samsung in there, back in these days LCD manufacturers were horrible at re-pinning the displays for each and every model run. Even within the same exact model number but different type number! it was horrible. 

Share this post


Link to post
Share on other sites

galgot, I feel your pain!  I picked up a cheap keylime iBook with cracked LCD and had plans to install the requisite Samsung 12" 1024 x 768 display (pulled from a PowerBook 12" I think), going by the information found on this site:

 

http://ibookmod.livejournal.com/559.html

 

But it had the wrong cable.  I had a junker graphite iBook SE for parts, it had the cable I needed ... and as you know having two Clamshells in pieces is hard work.

 

Put the right cable in the keylime, with the XGA LCD ... no backlight (can see image with a torch).  Pulled it all apart, switched the known working inverter board and same thing - no backlight.  Had enough and put it all back on the shelf for another day.  However, going through the links above (and macrumors/macnn threads), it might be a firmware issue or PRAM issue - when I've enough time I'll get it to boot to desktop, check firmware, and see if moving the brightness keys lets the backlighting fire up again.

 

JB

Edited by Byrd

Share this post


Link to post
Share on other sites

Thks all for these suggestions. Yes maybe a firmware problem or that fuse ,still have to found were it is on the board though.

Anyway, Clamshells are back in the closet now. 

The more I work with them , the more I love the Pismo...

Share this post


Link to post
Share on other sites

I had an Indigo (or something?) with a no-backlight problem, and after changing the inverter, I discovered that somehow the actual connector on the logic board had rotted. There was no other evidence of damage, and the board worked fine otherwise (I could see the display if I shined a light at it).

 

That shouldn't happen!

 

c

Share this post


Link to post
Share on other sites

Necropost!

 

I ran across this thread and a couple others while looking up suitable replacements for bad clamshell iBook LCDs. I’ve found a few non-Samsung VGA units (made by Torisan) that should be a direct fit but with better contrast ratio. I also found the XGA upgrade info linked above. Research has led me to find a number of panels that will fit with the OE Samsung cables so that the unobtainable LG cable isn’t required. However none of them have so far had mount points identical to the original VGA screens; they’re either in different spots or are the slim near-frameless types for the iceBooks or 12” PB G4. Im still working on it but if anyone is interested i can make a new thread regarding my adventure including a list of displays. 

Share this post


Link to post
Share on other sites

Hi . I'm still here :)

thanks for these infos. Sure you can start a thread documenting your researchs.

very interesting.

I did manage to make that Lime Clamshell work, but the hard way :/ ie, changing the main board, so it wasn't a screen problem... I suspect its some broken connections on the screen data connector , as last time i tried the original mainboard , the screen would light grey and i could hear the clamshell booting and hd doing hos things...

but dunno how to fix that data connector, so i exchanged the board with a working 336 mhz one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×