Jump to content
Sign in to follow this  
fyndr

LC III Hard Drive Failure

Recommended Posts

I recently collected and assembled all the parts needed for an LC III, which I put together yesterday. This included the hard drive, a Quantum ProDrive ELS with 80 MB of space and a SCSI connector. Everything seemed to be working properly, and I was able to install System 7.5.3 on the machine last night without issue.

 

However, when I booted up this morning, I got a flashing floppy disk icon with a question mark in it. I put in the Disk Tools floppy and neither Disk First Aid or the Apple HD SC Setup utilities recognize that the hard disk is present at all in the machine. I double-checked the connections and everything, it all seems to be okay on that front, and while the machine is running I can sense the actual physical hard drive spinning without any issues that I can tell (no unusual sounds, clicking, etc.).

 

I know that old SCSI drives like this tend to seize up and die, so I was wondering if this is the case for this particular hard drive as well. If so, then does anyone have recommendations for a reliable SCSI drive that would be compatible with this machine?

Share this post


Link to post
Share on other sites

Always check for termination, and then the cable first.

 

But a hard drive that over 20 years old can have other issues as well. Leaking caps for one, the head sticking is another. If you tap it on the side with a hammer (lightly) you can free up the head for now, but it will stick again. Some other members seem to know what to do to fix this. But at this day and age for a 20 year old drive, it's time for a new drive, even if it is solid state.

Share this post


Link to post
Share on other sites

Mmmmmm given that it is a Prodrive ELS i would not get hopes up as far as resurrecting it. They are a rubbish piece of equipment all told. I have IBM drives of that era going strong after more than 20 years, whilst a large portion of my Quantum Prodrive units had already gone pearshaped a good 10 years ago. :(

Share this post


Link to post
Share on other sites

Thanks for the responses. Although I can't explicitly check the SCSI cable, the timing of the failure given that the hard drive had previously been working is suspicious, so I'm thinking the hard drive is the likely culprit in this case.

 

As far as a replacement drive is concerned, as long as it is 50-pin SCSI it doesn't matter from the machine's perspective what hard drive I get, right? I'd be inclined to get a more up-to-date hard drive, but are there any considerations to take into account with that (e.g., issues with sizes larger than 4 GB)? Any recommended brands or specific drives?

Edited by fyndr

Share this post


Link to post
Share on other sites

I have the same drive and I have figured out how to get mine to work. The needle gets stuck in the park position and so I take the cover off the drive and turn the machine on, then move the needle off the park position and the machine boots. Keep in mind if you turn the machine off you most likely will have to do this again. This is temporary and do this at your own risk. Please screw the cover back on the drive when you are done moving the needle. You don't want the cover to be off for too long

Edited by SuperToaster

Share this post


Link to post
Share on other sites

I checked out SCSI2SD, it seems like a fine product and compatible with the LC III, but do you know if it is any hassle to install and get working as compared to a traditional hard drive? For the drive I had previously, it was just a matter of connecting the power/SCSI cables and initializing the drive using Apple HD SC Setup. Are there special considerations for SD card formatting or anything like that, or can it be just plugged in and formatted as if it were an ordinary HDD?

Share this post


Link to post
Share on other sites

It should be the same as installing a spinning disk, just stick it in and format with HDSC setup (You may need the patched version, although the scsi2sd had a option to report as a drive supported by HDSC setup one or two people have found this doesn't always work)

 

The only thing you really pay attention to is that 68k's have a 2GB limit for partitions (There is nothing to stop you having multiple 2GB partitions though)

 

Your other option is using a modern server SCSI hdd with a appropriate adapter (However these drives can run a little hot as they are typically 10 or 15k rpm drives)

Share this post


Link to post
Share on other sites

I agree the IBM drives are better but I've not had that may issues with the Prodrive compared to the miniscribe. I like the aztecmonster SCSI to CF adapters as they are more a finished product rather than a community effort WIP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×