Jump to content


Photo

9600 to be dying? CUDA etc.


  • Please log in to reply
12 replies to this topic

#1 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 03 March 2012 - 08:58 AM

It´s the 2nd night I played with my 9600/300 my workhorse and daily desktop Mac.

The problems are irreproducible for me, nevertheless I will write down what I tried – maybe someone else got further ideas, even if at all the other threads nobody had some.

It´s equipped with:
Sonnet G4 800
an Adaptec 29160 (3 x 73 GB)
1GB RAM (8 x 128 EDO)
Voodoo 5500
Acard 133 IDE (2x 250 GB Seagate Barracuda)

(and an "LMP All in One" as a Keyspan USB that were not in use tha last months)

That config worked for years. The Ultra160 just in the first PCI slot, but no other strange issues. Since I installed the ACARD a few years ago the machine had always to be booted twice, to avoid several minutes of waiting until it starts up. As well the battery was empty for more than a year now without too huge problems. There were no machanical issues, no changes at all (just some dirt and smoke). That 9600 is sitting for years under my table at the same place.

The Mac bagan to behave strange this summer. Problems began with a often corrupted IDE HDs a few months ago. Later the machine sometimes didn´t want to boot at all. Mostly that behavior (occured 4 or 5 times during the last year) was gone when I unplugged the power over night.

The last two month I didn´t use it, and when I now wanted to get it up and running again, I got the biggest problems I ever faced with Macs. First no chime at all. Power up worked, HDs began to spin up, green power LED is present, but no video, and no chime at all.

In very few cases I got a grey display, but no Happy Mac, and no chime. So I got a new PRAM battery yesterday. Same behavior, no chime no video signal. Than I began to plug off everything; onboard SCSI, PCI-Cards, Floppy, Zip, CD-ROm, even RAM and even the processor. I dissassembled the whole 9600, cleaned the motherboard, had a look at the capacitors if they look well (ok that doesn´t mean anything how they appeare), I plugged on/off the PSU, the RAMs, kicked all of them and kept just 2.

Than I started to kick everything , used the CUDA several times (before kicking the battery again, after reinstalling the battery, ...). I even tried several times to reset the board (like explained inside the service manual). Once I got the mac - by chance as I think - to find the ACARD IDE HD again. I could reset the PRAM, and got even the Bootupscreen with MacOS 9.2.2, but than it hang again. Than I tried to use the onboard Fast-SCSI (Adaptec not attached of course) with t´s original 2GB HD that contains a backup 9.1 system, and was thrown back to the "no video - no chime" situation. I again tried to keep it without battery and PSU for 30 minutes - 3 times, nothing.

Now the motherboard is at my glass table, it makes no difference what I try - no chime, no video, no ALT-COMMAND-P-R possible. But I got the power LED, the Voodoo is ok, the HD is spinning up, and the ACARD is getting Power as well. Even the Sonnet seems to be ok, as it once worked this night, and the CPU fan is always powering up.

Strange issues:

• it seems that the ADB is not working after I power the 9600 up. Therefor the PRAM zapping doesn´t work, but I can always power it up with my ADB keyboard. That could be connected to the CUDA as well, but how?

• There is no beep even if I have no RAM installed? Shouldnt there bee an error beep?

• It looks absolutely random to me, if I get a video or not at bootup. The last two days I had 2 times a chime (out of 300 tries or something). Some more times I could reset the PRAM and got a chime, or could soft reboot and got a chime. Sometimes I could reset the PRAM, but no chance to get it booted.

That all seems very crazy to me. I have no real ideas anymore what to try, and I cannot reproduce anything, ... 2 whole days for nothing.

I have only 3 further theories

• the PSU is gone, but I have no idea how to simply test if it is confsing the motherboard? Any advice?
• some capcitors are gone. Can they beexchanged? Did somebody of you it successfully?
• The motherboard has some still some dirt/smoke somewhere, and needs to be washed. Did somebody ever wash a Kansas, and not just a 68k Mac?

Well and my last point, I would love to clear that CUDA issue for the 9600. There are various informations when and how long to push it. Before pulling the battery out, after pulling it out and waiting 30 minutes, before pulling it in again, after pulling it in again, for 5, 20, 40 or 60 seconds, ...

Any further idea what I could try is highly welcome. Sorry if that whole issue is written confusing, but thats how it appeares to me as well.

Just for the records, i found that hint to use the original Video Card. Of course I din not get the 9600 back than with it, and have no other card. As I sometimes got a gery screen and once even the Mac OS Bootupscreen I don´t think that would help.

#2 johnklos

johnklos
  • 68000
  • LocationEarth

Posted 03 March 2012 - 10:15 PM

Have you tried it with the original 300 MHz 604ev? I had a Sonnet G4 (the 700 MHz version) become flaky, then die, but the rest of the computer was fine.

#3 Byrd

Byrd
  • 68000
  • LocationMelbourne, Australia

Posted 04 March 2012 - 09:44 AM

Also you have lots of nice upgrades on the machine, one or more of which may be flaky - try stripping the 9600 down to the basics just to get it to boot - known working 1 stick RAM, basic video card, boot up off external HD - remove everything else and add one by one until you find the culprit. Also check the CPU card is seated well, and clean the contacts with electronic cleaning solvent (a must for any 68KMacer, I'm not one to promote "one quick fix", but it has saved a few Macs I once thought near dead recently).

JB
:: Current project Mac: PB1400 resto

#4 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 04 March 2012 - 01:08 PM

Thanks for the replies.

The machine is working again, after another 15 hours of trying this and that, ... ;)

I thought I explained it correctly, but of course I put out everything.No success even with just the motherboard and processor, than nothing with motherboard/processor and RAM, ...
As well I swapped back in the original 604e, nothing. Well first issue - that is still unsolved - is an totally fucked up internal Fast-SCSI bus. I don´t know why, but it´s not attached now (and solvable without too huge problems).

But the real thing that caused all the problems:

You´ll never guess, ... it is a mechanical problem! I recognized that I got a chime sometimes when the cards are not directly in an 90° angel attached to the board. Than I remembered that I was not always using the srews for PCI cards. So I pushed all the necessry PCI cards (the Acard 6280M, and the Graphiccard) AS the processor daughtercard to the left - in the direction they would normally look slightly when the Mac is standing around. And: tataaa! ;) Tha machine booted immediatly.

So I got a theory: over the years, the contact pins of the slots got pushed up in one direction by the weight of the cards itselves. If not all cards sit inside whith 2 or 3 degrees to the side (or down when the 9600 is installed normally), there is no contact and the machine does not boot.

It´s a little bit crazy to have to do something that feel wrong, but at least it makes some sense. What supports me with my theory is that the slots where the heavy cards (the Voodoo, the Adaptec) were installed allow a bigger angle, than the ones with smaller cards like the Acard. ;) The crazy thing that I would have never found out if not everythign would have been right in fromt of me at my table, is that even the ZIF slot and the PCI slots seem to got this problem. All cards have to be pushed to one side (down).

So, it seems to become an Happy End for now. Next steps are to follow your advice with the electronic cleaning solvent, as to clean some parts with Isoprpyl. Than I´ll try to solve my SCSI troubles at the internal Fast-Bus and subsequently will try to reassemble everything. Perhaps I´ll even get some Papst fans for the Voodoo and the Sonnet ;)

#5 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 07 March 2012 - 12:20 PM

I was able to increase stability again, with taking some care about the Sonnet CPU Upgrade:

http://www.98-shop.c...72011092003.jpg

I took off the heat sink with care, and cleaned the PCB from all the dust everywhere that got there the last 8 years. Aditionally I took off the fan of the heat sink and cleaned it as well. I used an antistatic brush for that. I have no idea if it was a simple heat problem, or if the BGA and SMDs got maybe some contacts they shouldn´t because of the dust?
As well I went back from the Crescendo drivers 3.1 to 2.3.1 - the system is very stable again, as I knew it the last decade. I am writing right now with it.

Nevertheless I would love to discuss that CUDA issue, and get approved informations of how long and when it is to be used.

#6 Outlander

Outlander
  • 6502

Posted 05 April 2012 - 08:07 PM

Hello, I've been away for awhile. Anyway, I came across this thread and this guys slowly progressing problems sound exactly like what happened to my 9600 a little while ago.

My setup was:
9600/350
1 Ghz Sonnet G4
512MB ram
36GB wide scsi drive
Ati 9200 video card.

When I first installed the sonnet G4 card, everything worked wonderfully! Mac OS 8/9 booted and ran fine, and Mac OS 10.2 and then 10.3 worked wonderfully too. But after a year or so of use, the 9600 started flaking out. Sometimes I'd get random Type 11 errors, sometimes the machine wouldn't boot all the way, sometimes it ran fine. Then I started getting all kinds of corruption on my wide SCSI drive (wide scsi to 50 pin adapter). I'd repair it, but then there would be more corruption in a few days. Then my Mac OS X partition started refusing to boot at all. I changed the cache settings, re-installed, etc. Nothing worked. A few weeks later, Mac OS 8/9 stopped booting, including off of CD-ROMs, my 9600 was dead :(

It turned out that the on board SCSI controller had gone bad, I went into the open firmware and it couldn't see the bus any longer! I said to myself "what the hell?!?" At first I suspected the wide SCSI to 50 pin adapter, but then I found the real culprit, the Sonnet G4 card! I had always wondered why sonnet pulled the G4 card off the market so quickly, and I'm pretty sure I found out why... the hard way.

Anyways, 2 new motherboards later (yes I killed a second 9600 board with the G4 card also), I'm back in business with a 450mhz G3 card. It's not a G4, but it works and no more abnormal behavior, or ruined SCSI buses. It's been working now for months with no issues... so far. I miss the G4's speed, but there's something VERY wrong with the sonnet G4 card, or with using G4's in the 8600/9600 workstations. That's my 2 cents. :p

#7 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 05 April 2012 - 09:15 PM

I cannot confirm any problems at m 9600 with the Sonnet G4. Are you sure you killed your MBs by using the Sonnet??
As well I think to remember the G4 1GHz were long at the market, and even heavyly price reduced (as I thought about upgrading from 800 to 1 GHz), and so not taken off the market quickly (but I can be wrong).

I really ha just the mechanical problems described above. But ok it´s a G4 800 not a 1GHz version. My 9600 is running very well since the operation, and is in daily use as main computer again.


And after all I really would love to solve the CUDA questions that occured to me. Nobody around with real techical expertise?

#8 gobabushka

gobabushka
  • 6502
  • LocationPalm Bay, Florida

Posted 06 April 2012 - 01:44 AM

ok, i am jealous of y'alls 9600's
"I reject your reality and substute my own!!!"

#9 Outlander

Outlander
  • 6502

Posted 06 April 2012 - 07:14 PM

Hmmmm.. I mean, it could have been a coincidence that both boards died the same way (and other users reporting abnormal operation), but I'm just not willing to trust that G4 in my 3rd motherboard ( They're getting a little rare now-a-days ) I think I'm probably going to sell it, no idea why I even hold onto it. I'll be more than happy to trade it for a 1ghz, or 1.1Ghz Powerlogix G3 upgrade :-)

As far as the CUDA issue, I never really use the CUDA, except when all else has failed, just never had to. I assume it's the CUDA reset switch you're referring to? The CUDA switch has always been just a bios clear jumper for me and nothing more. Press it in for 30 seconds or so and everything should be erased from the NVRAM. It really doesn't do anything else, as far as I know :-/

Oh well, best of luck.

#10 uniserver

uniserver
  • Banned
  • LocationSouthfield, Mi

Posted 06 April 2012 - 08:25 PM

yeah i find my self jealous of your 9600's That voodoo 5500 was the cats meow when it came out!

i really liked 3DFX,
too bad the 6xx never made it to market!
2_v6k_Foro.jpg

or the 7xx
voodoo77000.jpg

#11 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 28 October 2012 - 08:43 PM

I wanted to report again about my 9600 that does not like to pass away! ;)

When I did the last "operation" and everything worked fine again, I had the 9600 for several weeks lying on the desk without any housing. Than one day in late May I put an entire cup of coffee over the uncased electronics, ...

What a pity after I solved most problems!

I had 200ml of milkcoffe at my motherboard the sonnet, my HD (the backside with PCB!) and the RAM, ...

Gladly I could immediatly unplug the PSU and put out the battery, ... I tryed to clean it with towels as far as possible. Than I did nothing the last months. But I saw, that the coffee is at the SMDs and like a 2nd surface. Of course the computer didn´t boot up, it was dead. Late August I thought to give it another try and started to read how people washed their motherboards.

So I went out to get cheap 5 liters of distilled water. I simply heated that distilled water in the microwave up to about 50° Celsius. Than I took my 9600 Motherboard, put it to the washbasin an started to completely wash it with my antistatic brush and the destilled water (nothing else).

An totally strange feeling to wash a PCB, ... ;)

Subsequently I used the hair-dryer (with cold air!) for more than an hour asnd tried to get all the water out of the RAM and PCI slots as out from between the SMDs and PCB surface. Than I put it away for 4 weeks to be absolutely sure that there is no more water anywhere.

And: It worked! My 9600 is back again, and kickin!

After I put back the battery and pushed the CUDA (I still do not exactly know how it should be used) it booted up.

Totally crazy story! ;)
I never thought it will work, but gave it a try as it was already "dead". 1 € for the destilled water, and nothing else. I am totally happy now! Great computer, and even if there are some minor problems due to the age (15 years this summer!), it seems to be unbreakable.

#12 beachycove

beachycove
  • 68020
  • LocationOntario

Posted 30 October 2012 - 12:17 AM

Wir washen logic boards in Canada, too. It does them no harm.

#13 Mathias

Mathias
  • 6502
  • LocationVienna

Posted 30 October 2012 - 12:35 AM

Thanks for your german sentence! ;)

I know that PCBs get washed, normally with Isopropyl, what would have been to expansive for me. But I was unsure about simpe destiled water. As well I never thought that that coffee didn´t harm my 9600. I thought it is gone, that there had to be some fatal short-circuit fault. That is the main fascinating issue!
But nothing, it is totally ok again! ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users