Jump to content

pcamen

68000
  • Content Count

    1134
  • Joined

  • Last visited

1 Follower

About pcamen

Contact Methods

  • Website URL
    http://vintageapple.org

Recent Profile Visitors

955 profile views
  1. pcamen

    SE/30 project

    Ah, I see it is called raspberrypi / ApplePi, so I'm guessing A2SERVER.
  2. pcamen

    SE/30 project

    @Byte Knight what are you running that AFP server on, out of curiosity. Are you taking any public. facing precautions?
  3. Anyone? Anyone? Bolle? Anyone?
  4. pcamen

    Netatalk SD Card Image?

    Well, I grew the disk without issue, so that wasn't the problem. Perhaps it is the hostname change that screwed things up. Anyways, I am going to just use the new VM with the larger disk; copying my files over now.
  5. pcamen

    Netatalk SD Card Image?

    Yes, it works fine. I am now on the process of applying all my changes to the stock one to see where it might go bad. So far I added the MACFILES share and it works fine. Next step making the disk larger.
  6. pcamen

    Netatalk SD Card Image?

    I just checked all the config files in /etc/netatalk and there are no differences other than server name. I did set up my modified a2server with a static IP address, so I tried changing it back to DHCP but this made no difference. It is really baffling. Not sure what might be causing the issue. I've verified with another 540c that I can get the login prompt with the stock server but not with my modified one.
  7. pcamen

    Netatalk SD Card Image?

    Okay so from the 540c running 8.1, it *can* access the stock a2server but I have the same problem on my modified one. So something in my settings is causing the issue. I'll keep poking around. And 8.1 on the 540c can see both servers now that they are on the same zone.
  8. Ok, so, a couple of things to report. The good: I downgraded the v6 firmware from 6.28 to 6.25 and now I can copy to it from the 540c. I'll let codesrc know. The bad: I played around with two other 540c's and _just_ swapping the ram boards seems to have borked two of them. Not sure WTF is going on, but on one of them, it now starts up with a gnarly sound, and the other, my goto one for some time, simply won't boot; does nothing when you press the power button. Anyone aware of any sensitivity around replacing the RAM board and how to deal with the issue?
  9. pcamen

    Netatalk SD Card Image?

    Oh, and BTW, I had to downgrade Virtualbox from the 6.1.x release branch to the 6.0.18 release as there is a bug that won't let a Virtualbox VM create a bridge with a thunderbolt ethernet adapter that was introduced in the 6.1 branch.
  10. pcamen

    Netatalk SD Card Image?

    Well, I now have two a2server instanced, both with the same zone name (in /etc/netatalk/atalkd.conf) and different host names (in /etc/hostname) and with the A2SERVER zone selected, I can see both servers. So at least we know _that_ part works. Now to fire up the 540c and try it with the stock a2server.
  11. pcamen

    Netatalk SD Card Image?

    Well, that may be a just plain wrong now that I found this: https://developer.apple.com/library/archive/documentation/mac/pdf/Networking/Introduction_to_AppleTalk.pdf Ok, so far so good. Ah, ok. So everything on the same non-bridged network has to be in the same zone. So I guess running two a2servers with different zone names is a no-go then. I'll have to change my zone name back to just "a2server" and give the server itself a different name to differentiate it from the stock one I fired up.
  12. pcamen

    Netatalk SD Card Image?

    Well, I've been reading up a little on Appletalk Zones, and I think this is the way it works. - Apple talk zones allow you to segment stuff on your network to make it more manageable. But it isn't a physical separation like a VLAN or different sub-networks, it it just a naming separation. - You can name stuff to belong to a particular Appletalk zone, and then when you select that zone, only the things named with that zone will show up. Convenient if you have 50 printers in a building and only want the ones near you (engineering zone) to show up, for example. If that is really how it works, then in theory, both of my zones should be available, and I should be able to select either of them. I should also be able to change my modified a2server back to the standard a2server zone and have both servers show up under that zone. I'll have to do some more playing around.
  13. pcamen

    Netatalk SD Card Image?

    Hmm, well @cheesestraws other than adding a new share and enlarging the disk of the default a2server VM, I haven't made any other changes to the configuration. I would assume then that it has Appletalk enabled, that seeming to be the point of the a2server setup. But I'm just guessing. I'll have to dig in and see if I can find some info about that. But I did fire up another a2server VM that has not had any changes from the distribution to see if that makes a difference (and thusly I screwed something up in my changes). What is strange though is that if I have both running, in the Appletalk control panel, it won't let me choose between the Appletalk zones (as I renamed the zone in my modified one to include my server name). But if I turn the modified one off, reboot, it seems the new (default config) one.
  14. So, the thing is, my internal SCSI2SD is flawless. I've never had issues with that one. It is only when trying to copy to the external v6 on that It has issues. And the system is never trying to sleep, as I have that turned off. I can't help but wonder if I flashed a newer version of the firmware a couple of months ago and that is what started this problem. I suppose I can try to flash older versions of the firmware, look for something a year or more old, to see if that fixes it. I did fire up another 540c and it has the same problem. So this is some type of compatibility issue with the 540c not a 540c hardware problem it seems.
  15. pcamen

    Netatalk SD Card Image?

    Well, this is an a2server, so as a server it only has TCP/IP. And I've connected to it via TCP/IP from my G4 Mini just fine; it does prompt me for the user and password like on the Lombard when I selected it via the Appletalk browser.
×