• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Well it used to work: 128k woes

Hi everyone. So my recently acquired 128k with the 512k socketed upgrade won't boot now.

20210901_060841.jpg

I had the caps replaced and upon return I get no bong on power up and a screen of vertical lines.

Installed a Plus logic board and it boots fine.

So far I've reseated all the RAM chips. Cleaned the ROM pins and reseated and reseated that chip that controls the memory upgrade.

Still the same problem.

Any ideas? I'm guessing memory problem based on the Larry Pina books, but I'm just an amateur.
 

LaPorta

Well-known member
Who put these in that installed one backwards? Did you ask them if they touched anything else? Do you have an ESR meter to verify that the caps are in good shape?
 

cheesestraws

Well-known member
I'd try swapping the memory chips at F6 and F7, since they're socketed, and see if the error moves. If it does, it's the chip; if it doesn't, it's something else, perhaps the traces to the chip?
 
Switched F6 and F7, installed my Plus ROMS and it booted.

Put the original ROMS back in and the same problem.

Tried it a couple more times and it seems that I've got bad original ROM or ROMS.
 

mg.man

Well-known member
Could be bad ROM(s)... worth checking the pins on the originals to make sure they are clean and "crud"-free... Sounds like progress tho!
 

cheesestraws

Well-known member
ROMs do sometimes go bad. It's not particularly common—not like RAM going bad, which happens all the time—but not particularly rare either. But so do cruddy legs on the chips, so as @mg.man says, check those before despairing of the ROMs. :)
 
I've scrubbed the pins, they were tarnished a lot. Still no go.

In good news I got the 400k drive working!

I bought a NOS felt pad for the drive off ebay, installed it, and now it works well. The old pad was almost totally gone.
 

dochilli

Well-known member
ROMs can be burnt into Eproms. Here is an instruction for a Plus:

For a 128 27C256 Eproms could work.
 
20211023_224857.jpg
New ROMS installed and all is well. Boots and runs fine. Floppy Emu has a version of system 1! Fun times.

My first Macintosh experience was in 1985 on a similar machine at work. It was an astounding revelation, and this brings all those memories back.
 
Top