• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

TiBook 1GHz w/ OS 9.2.2 — anyone got RTL8169x PC Card working?

MacTroy

New member
For reasons, I've been on a quest to get a second gigabit Ethernet adapter running on my TiBook running OS 9. Theoretically this is possible; there is a readily available file named RTL8169xV111.sit out there with Mac OS 9 drivers and the following text in the Readme:

2. Adapter requirement for PC Card

2.1 The NIC on your PC Card must be RTL8169 series and the Vendor ID must be 10ec

      and the Device ID must be 8169.

       * You can contact your PC Card provider to get the Vendor ID and Device ID of your

          PC Card.

2.2 If the Vendor ID and Device ID is not 10ec,8169, please contact your PC Card provider

      to get the driver for your PC Card or follow the following steps to patch our driver to

      work with your PC Card.

      - Get a binary editor to edit the driver.

        *** You can use "General Edit Lite" editor You can download "General Edit Lite" from 

              ftp://physgi.phy.ncku.edu.tw/pub/mac/editor.

      - Use this editor to open the driver file "RTL8169 Driver".

      - Select "Unlock Data" from the "View" menu item to unlock data of the driver file to

         enable the editor to modify the driver file.

      - Click on the lower frame to activate the lower frame.

      - Replace all the pci10ec,8169 items with your pcixxxx,yyyy whree xxxx is the Vendor

        ID and yyyy is the Device ID of your PC Card by using the "Replace" function provided

        in the "Replace" menu item in the  "Find" menu item.

      - Save the driver file.

      note: "Quadrivio General Edit Lite" is a product of Quadrivio corporation. Please read

               the text file within the "Quadrivio General Edit Lite". You can contact Quadrivio

               corporation for more information.


This sounds great, but it isn't working for me. I've now procured FIVE different 8169 PC Cards (toldja it was a quest), three of which have the standard 10ec,8169 ID, and they all almost work. Driver loads, card is recognized, I can choose it in Open Transport AppleTalk & TCP/IP, plug in a cable and the lights blink, and…nothing. Won't pull an IP from DHCP, I can hard-code but no traffic is flowing. 

Has anybody out there ever made this work? If so, I'd love to know the details — thanks!

View attachment RTL8169x Readme.rtf

 
Last edited by a moderator:

jeremywork

Well-known member
I haven't tried using an 8169 PC card, though I have tried a PCI card version in a 9600 using the driver attached (likely identical to the one you have.) It seemed to hang up the first time I tried it, but after some general troubleshooting (reselecting the default extension set, cold boot, PRAM reset) it seemed to work fine, though in that machine there was no performance advantage over the 10/100 card with OEM drivers so I abandoned the idea. I confirm I was able to browse the internet and connect to AppleShare servers through it.

View attachment mac9x-8169(100).zip

 
Top