• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SE FTP issues


Well-known member

My Macintosh SE has a Farallon EtherMac SE card in it. This installation of System 7 has been used on and off for about 8 years, with no hardware changes.

I have 4 MB of RAM installed, running 7.0.1 .

I have used Fetch 2.1.2 many times in the past to download or upload files to my FreeNAS server. It's running FreeNAS 8.3.2.

Lately, I have not been able to complete a download. I can poke through directories and never run into any issues. But when I start a download, it will begin to download the file at like 4096 bytes a second, get about 70k of the download, and then the download seems to stop, while the speed counts down slowly one or two bytes at a time, until the download is aborted because "the pipe was broken".

I have been experiencing issues like this this year and I can't seem to figure it out. It does this on any FTP server I try as well. Any program that uses the internet behaves in a similar way, but Fetch is the only one where I can actually see this disconnect and the download speed drop off. Reminds me of internet explorer 4's downloads back in the dial up days.

Anyone fix something like this before? I hope the card isn't bad. I have tried different cables old and new and a few different switches of different eras.

Last edited by a moderator:


Well-known member

I will list off random things you can try, none of these suggestions are in a particular order so I suggest you read them first and decide which is the least disruptive. So things like resetting PRAM or NVRAM are quick. Ping can be quick as well to check for time outs etc.


Is the download speed drop isolated to the SE or do other computers downloading from FTP also suffer a similar fate?

Since this began to occur have you changed any of the files or added any new extensions etc to the SE System Folder?

Is the SE provided a static IP address on your router and the SE setup to use DHCP to obtain the said IP address?

Can you ping from another computer to the SE?

Can you try minimizing the extensions/control panels on the SE to just those that are needed to ensure there isn't a conflict?

Not knowing anything precise about your FreeNAS, can you identify is an update to FreeNAS may correlates with the issue?

Is the issue isolated to FTP?

Can you visit sites like Macintosh Garden (I think the site will reduce itself down enough to support old browsers)? The point here is to understand if the SE can establish any other connection, FTP, HTTP or otherwise and keep a sustained download rate.

So for now I have no way of knowing if the Farallon Card is at fault, I suspect it is a network issue of some sort.

You could also try resetting PRAM or NVRAM (whichever term applies to this model of Mac) and potentially moving any related preferences files to a folder on the desktop, restart and this will compel applications to recreate those preferences files that are backed up on the desktop. If things work with new preferences files in place you will know it was one of those preferences files that could have gotten corrupted.

Have you changed the network topology or configuration and perhaps these changes are the cause of the speed dropping?

Are you running the latest software for the Farallon card that is compatible with System 7.1?

You could also try to run Disk Doctor as it can fix things. 

Let us know what you tried and what might have worked. I will keep my eyes on your call for help. I would be inclined to believe it is a software issue rather than a hardware one.

Last edited by a moderator:


Well-known member
Sorry that I never got back to this post! I haven't had a chance to get back to the SE. Hopefully I will get some time soon to try your troubleshooting. I really appreciate the time you took to give me all of these ideas to try!