• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

RaSCSI, Pi's, and cheap PSUs - A Cautionary Tale

Tom2112

Well-known member
The TL;DNR version:
Don't use a cheap power supply for your external RaSCSI/Rasperry Pi combo. The just-good-enough-to-power-up power won't be enough for running the RaSCSI and termination too and it won't have proper termination and you'll spend hours trying to figure out why it doesn't work.

The long version:
I spent almost 1/2 a day trying to figure out why my PowerBook 165 would NOT communicate with my RaSCSI. I won't bore you with all of the nitty gritty details, but suffice to say, had the Pi not been headless, I would have known it wasn't getting enough power. But with it being headless, there isn't an idiot light to tell you. In my case, the Pi (a Pi 3B+) had enough power to boot and run the RaSCSI scripts, connect to my wifi, and make it look like it was working just fine. But the Mac it was connected to just wouldn't see it. Since the PowerBook was new to me, the RaSCSI was new, as was my newly purchased HDI-30 to DB-25 adapter, I went through a lot of fruitless troubleshooting, until finally giving up and pulling out a known-working Mac SE and start troubleshooting there. Also it helped that the SE had files/tools on it I could use to help troubleshoot, where the PowerBook was an island to itself. It was on the SE that SCSI Probe 4.3 finally told me that the SCSI bus wasn't terminated! (Thank you SCSI Probe author! You're a genius, and I wish I could buy you a beer.) Other tools I used didn't tell me diddly (I'm looking at you LIDO). I was beginning to think the RaSCSI was bad. But once I had a good way to see if it was terminated or not, I found that the switches on the RaSCSI weren't doing anything... which didn't make sense. Finally I hooked the Pi up to a monitor (I had installed the desktop version of the OS on this particular one) and immediately saw its low power indicator (lightning bolt) in the corner of the display. Once I grabbed a better quality power supply (I used a good USB power bank), the whole thing worked exactly as it was supposed to work.

I need to wire it up with the old power supply and check the amperages with my meter to see at what amps it creates a problem. The too-low-power PSU was labelled at 2.1 amps, but I don't know what it was actually putting out. The power bank I used says it only outputs 2.1 amps at 5v, so...? I'm betting the cheap Chinesium PSU is literally over-rated.
 

Tom2112

Well-known member
It hasn't been a good week for me and RaSCSI. After I got the external Pi-3-based RaSCSI working with my PowerBook, I set to getting the internal powerbook edition RaSCSI (soldered to a Pi Zero) working. It was also a nightmare. I did not provide the Pi Zero external power, as it was supposed to get enough power through the SCSI bus and the RaSCSI. I ran into some very strange problems with this RaSCSI. The RaSCSI would show the images mounted, but the PowerBook simply wouldn't recognize that there was a drive there. I tried all sorts of things, such as different images, ISOs, etc. But I simply could make the RaSCSI work. I have a BlueSCSI PowerBook edition lying around, so I went to swap it with the RaSCSI and found that the Pi Zero RaSCSI was hot to the touch - almost too hot to handle with bare hands. That's not good. That makes me wonder if I somehow got a bad one...

When I put the BlueSCSI in the PowerBook it worked fine on the first try. No problems at all, as if to say "You fool! You should forsake that demon spawn RaSCSI for the true path to PowerBook happiness: the BlueSCSI!" OK, that's a little over the top, but you get the point. I'm a but frustrated and annoyed at the RaSCSI line-up right now.
 
Thanks for sharing your story. I've also been down that path, with the RaSCSI running seemingly ok but certain functions being unreliable. In my case, it was particularly the network interface that did not work reliably. The most clear-cut way to detect an undervoltage situation is to observe the syslog on the Pi and look for "Under-voltage detected" warning messages.

When I read up on Pi power supplies, the official and recommended ones are rated at 5V / 2.5 amps, so it makes sense that your 2.1 amp one just didn't provide enough juice. Once I picked up a power supply that met these standards, my undervoltage problems went away.

BTW, to help future RaSCSI users avoid this pitfall down the line, I added a troubleshooting section to the wiki. Please feel free to add to it!
 

Tom2112

Well-known member
Thanks SlipperyGrey! I had a bad weekend with my RaSCSI's and Macs. I'm sure most of the frustrations were ID-10T errors, and the fact that we're so spoiled now with modern computing devices. Working with stuff from 30 years ago is a real eye opener. I don't remember them being this difficult back then! LOL

One thing I really struggled with over the weekend was that images I'd copy over to the RaSCSI wouldn't be recognized by the host Mac as a valid drive/partition. I could have probably initialized them and used them, but initializing them would delete the contents and thus defeat the purpose of preparing an image ahead of time. I couldn't find a common denominator between the images that worked and the images that didn't. All of them worked under BasiliskII, and I had used some of them with other devices (BlueSCSI, MacSD, SCSI2SD). That said, I didn't have ANY problems with images that I created on the RaSCSI (they're blank, but they work no problem). So maybe I'll try creating them on the RaSCSI, then copy the file over to my PC and use BasiliskII to put data into them.
 
I've not had much consistent luck using hard drive images created by Basilisk II on real Macs either. Somewhere I read that Basilisk II doesn't embed a hard disk driver that real Macs need to recognize the drive. One idea to try would be to initialize the image within Basilisk II using, say, a patched Apple Drive Setup, then copy files over and mount the resulting image with RaSCSI.

These days, my go-to solution for getting files onto vintage Macs is through running a Netatalk AppleShare server. I've written a guide on how to run Netatalk in parallel with RaSCSI that you might want to check out, if you haven't seen it already. While it's not as fast as transferring files between drives directly inside Basilisk II, one neat feature of Netatalk is that you can actually connect to the AppleShare on the emulated Mac (using TCP only), unstuff and organize files right on the AppleShare drive, which is then available conveniently to the vintage Mac. Just an idea that you can try out!
 
Top