• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Powerbook 190 dying after PRAM battery replacement

doctormistral

Active member
HEEELP!! I restored my Powerbook 190 cs it 2 years ago, it was working perfectly until yesterday. Only problem was the PRAM battery to be replaced. After I replaced the battery (identical to the original) it worked for a while then stopped to boot. No way to restart. After several trials I reopened it and this is the stable situation (with non PRAM battery nor HD).

1. Connect the power adapter (checked ok)
2. Immediately emits a kind of white noise (like a radio) at strong or light level.
3. Pushing the reset button, the noise stops and the green led gets on stable (no blink)
4. Pushing again the reset button, the green LED turns off and noise restart as in step 2.
Check the video, please. Moreover:

- Already done to reset PRAM and POWER MANAGER several times.
- Connecting the HD, it does not start.

I don't have PB 190 schematics, any ideas about? What can I check?

Thanks for any suggestion.
 

Attachments

  • IMG_1299.m4v
    41.4 MB

joshc

Well-known member
Hmm. Seems power/PRAM related. Is it worth leaving it plugged in for a bit? I have no idea how this stuff works on the 190, but do wonder if it just needs a bit of time to right itself? I appreciate that sounds completely unscientific, but may be worth a try.
 

doctormistral

Active member
Hmm. Seems power/PRAM related. Is it worth leaving it plugged in for a bit? I have no idea how this stuff works on the 190, but do wonder if it just needs a bit of time to right itself? I appreciate that sounds completely unscientific, but may be worth a try.

I think so, it is probably power/PRAM related. I tried to leave it for a while but no changes :(
 
Top