• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

PM7300 and G3 Power Supply Issues


New member
Hi All from Los Angeles!

I am a newbie to the forum. Found you looking for answers to my PM 7300 power issues. Ran great for years and sat for six weeks. When I came back it would not power on. I bought two used Astec replacement power supplies from a parts supplier two days ago. They said both had not been tested in awhile. I did not think to change the PRAM battery or remove.

I installed the first power supply and the system came up and I used it for approximately an hour. The next morning it would not power on from keyboard or switch. So I installed second power supply, this only clicks when power on is pushed from keyboard or switch. I Did remove PRAM battery and reinstall but did not check its voltage. (I’m new at this). However, I was getting the loss of Date and Time notice prior to my issues and did not change battery.

I bought a desktop beige Power Mac G3 yesterday with no hard drive but powered up and had disk with question mark when connected to the sellers vga monitor and had a vga adapter connected to video port. I bought it with intention to install my Seagate drive from the 7300 with OS 8.5. The G3 came with a Zip, CD and 3.5 drive but no keyboard or mouse. I thought I could simply install drive as there was no hard drive in the G3.

I attached my extended apple keyboard and Kensington track ball and attached my Samsung display that worked perfectly with my 7300 and directly attached to the G3 having removed the vga adapter that was attached to the G3, as I had a correct video cable. I powered up G3 but no video at first. So I turned off G3 and the display. Disconnected video cable and reconnected and it powered on with disk with question mark. I powered off and I installed my hard drive using the power supply cable and SCSI cable into the top shelf left of the 3.5 drive although I saw there was a second scsi connector for a drive when you lift the shelf. I then powered on again, drive powered on but not seen as boot drive. I turned off and held down Option key and powered back on from keyboard but nothing happened. No power on. I then Unplugged power cord to G3 and reinstalled and made sure power strip was on, still nothing. Now I have two dead Power Macs. Whaaaa!

Panic! Did I do something wrong? Did I kill the power supplies or did I short something? I opened the original PM7300 supply and the first Astec power supply that worked for the short while to see if there was any obvious visual issues, smoked board or bulging caps out of curiosity. Although I not sure where to start as there appears to be a lot of them. And needs to electro wash it. The Astec is clean and seems to have fewer components than the original Delta Electronics power supply but I don’t know how best to test these. I see they also have a white glass fuse. Are there new or refurbished power supplies available?

I am going to I get two new PRAM batteries today as both are bad and measure under 1v. And I see there is a logic board and Cuda test or reset mentioned and I downloaded the Apple 7300 service manual and will follow steps.

Does anyone one have Any tips as how to best to go forward. It would be appreciated as I love my old Apple I have had for 20 plus years and would love to get both the 7300 and G3 up and running and find a drive for the G3 and clone my original if possible.




  • B39BFE1B-E5FC-42F7-9325-AE62FC37785F.jpeg
    2 MB · Views: 3
  • 3C600CE4-E594-42FD-A432-41C777893844.jpeg
    1.6 MB · Views: 3


Well-known member
I can't remember if either of these machines need a good PRAM battery to boot, my assumption is that they don't.

What are the exact symptoms now, no sign of life at all with either power supply?

These are old power supplies - I would personally carry out an ATX conversion as you'll end up with a much more reliable power supply. It's also a good way of verifying that your logicboards are working.