• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Need help with a IIc monitor

fimbulvetr

Well-known member
So, I really screwed up. Sometime in early December I used my IIc and when I was done I turned it off, and then didn’t look at it or go anywhere near it until a couple days ago, when I noticed I forgot to turn the monitor off. Ugh. It sat there cooking away for over a month. It worked perfectly before I did that, but now it starts off really bright on the right half of the screen, and dim on the left. If it runs for a while, the brightness evens out somewhat, but it is never perfect. Can this thing be repaired? If so, what is the most likely issue?

I feel really stupid for having done this. Those little green monitors are getting harder to find, and the prices are getting eye watering.

Here is what it looks like when it is first turned on:

B1C8A863-5173-447D-AD44-159CB33F03C2.jpeg

And after it has had a while to warm up:

5C7316C4-F1C5-4107-8F5D-B02D4FC82C89.jpeg
 

LaPorta

Well-known member
First, has this thing had any work done at all prior? It probably needs some components replaced is all, I would venture.
 

fimbulvetr

Well-known member
I stick to “if it ain’t broke, don’t fix it” policy. It worked perfectly before, so nothing needed fixing.
 

bibilit

Well-known member
As things are improving on the long run, i will say at least a cold solder joint, but hard to say without having a look inside.

Those cute monitors are a bit tricky to get inside, everything is a bit tight.
 

joshc

Well-known member
I stick to “if it ain’t broke, don’t fix it” policy. It worked perfectly before, so nothing needed fixing.
Sounds like it was potentially on its last legs if nothing has ever been replaced inside the monitor before. The capacitors are probably due for replacement, and like @bibilit says there may be bad solder joints, especially with it being left on things will have gotten toasty in there.
 
Top