• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

My short PDQ story

macjalm

Member
It's not really that I made some awesome customizations or hacks, like you guys here, but I decided to write a short post about my experiences with my newly acquired PDQ.

The choice

I chose the PDQ because of two reasons:

  • I needed the most powerful portable Mac that would be capable of sharing data with my SE (serial / floppy) out of the box and yet modern enough to be able to talk to my MacBook Pro.
  • When I was a kid, I always wanted to have one of "those black G3 PowerBooks".


The setup

It's a regular 233 MHz PDQ, except for extended RAM (384 MB) and a bigger HDD (9 GB). I also got it a floppy drive, a WLAN PC card and a PC USB adapter.

The system(s)

I currently triple-boot Mac OS X (10.2. 8) , Mac OS 9 (9.2.2) and Mac OS 8 (8.1). Apparently, the USB adapter wouldn't work with Mac OS 9 and below. Also, I still have some really old stuff that wouldn't run on anything above Mac OS 8. That's why I came up with this configuration.

The problems

I came across several problems getting to where I am now. I'm now going to briefly describe each one of them.

The USB adapter

Even though I was convinced that any OHCI-compatible PCMCIA USB card would work under Mac OS 9 (which was initially the only OS I intended to use on my PDQ), I found out that it was not necessarily true. I bought an AKE USB 2.0 CardBus BC168 and it wasn't even recognized by OS 9. I described it in detail in another thread. Trying a bunch of different USB drivers didn't pay off. I tried several methods that I found on the Internet (none of which were dedicated to this specific card, by the way), but I ended up installing OS X to be able to use it at all. My guess is that if I had managed to get a known-to-work card, I would have spared myself a whole lot of time and the need to install OS X. Nonetheless, the USB adapter works out of the box under OS X. And for the record, Mac OS 9 is limited to USB 1.1 speeds (the Apple's drivers wouldn't allow for more).

The WLAN card

This one was a more fortunate purchase. I got a Lucent Technologies WaveLAN Silver, which, after installing the AirPort drivers for the OS 9, was successfully recognized as an AirPort PC card. That made it really comfortable to use... until I installed OS X! There are a few options when it comes to custom WLAN PC cards under OS X. Firstly, I found IOXperts drivers but it is a commercial product and I really wasn't into any additional (and unnecessary) expenses. That's how I found the WirelessDriver, which sounded like the perfect solution. And in fact it was, but not without hassle.

The package that I got from the repository (1.0.0b5) wouldn't even install. I figured out that it was caused by the preference pane sub-installation. I fixed it by installing it in my home directory and then moving it to /System/Library/PreferencePanes/. But it wasn't over yet. The card still wasn't recognized by the Network preference pane (there was no new interface corresponding to the card). I figured out that the kext (Kernel EXTension) wasn't loaded, so I tried loading it by myself:

Code:
sudo kextload -t /System/Library/Extensions/WirelessDriver.kext
Indeed, there were some problems with the kext and it could not be loaded. The "-t" switch told me that the permissions / ownership of the extension were invalid. That was easily fixed by issuing the following command:

Code:
sudo chown -R root:wheel /System/Library/Extensions/WirelessDriver.kext
The other problem lied within the Info.plist - one of the keys had a value of an inappropriate type. That required a quick inspection of the mentioned file and the solution was also straightforward:

Code:
sudo vi /System/Library/Extensions/WirelessDriver.kext/Contents/Info.plist
(Look for the key denoted by the following key path: IOKitPersonalities:Baystack 660 Wireless Network:IOKitDebug)
(Now change the consecutive entry - VALUE - to - VALUE)
(Save and exit - ESC, :wq, ENTER)
Now kextload should finally get the job done and a new network interface (named en1, most likely) should appear in the network preferences. In other words, you should be good to go.

The triple-booting

Unfortunately, my PDQ seems to be unable to boot from ANY CD. I've tried about 5 different installation discs (I know that at least 2 of them were successfully used to boot from before). No methods that I know of were of any help in this matter. I tried things like:

  • holding the C key during boot,
  • setting the CD as the startup volume in the Startup Disk control panel,
  • holding Command+Option+Shift+Backspace during boot,
  • resetting the PRAM / PMU.


As my PDQ came with only one partition, I needed to boot from a different medium to be able to repartition it. My temporary solution was to use a RAM disk to store a minimal System Folder along with some utilities. It in fact did work flawlessly but then I found out that the Mac OS X installer ran under Mac OS 9 was capable of forcing the PDQ to boot from the installation CD. That's how I finally managed to get my HD partitioned.

When I got OS X up and running, I gave the Startup Disk preference pane a try and set the Mac OS 9 installation CD as the startup volume. It failed just like before so I was forced to install OS 9 using the Classic Environment (and installing OS 9 for it first). The installation went smoothly but I wasn't able to boot into the freshly installed system. This is what happens when I try to simply switch the startup disk under OS X and reboot:

1. The PowerBook reboots and the pre-OS X gray background appears. A moment later the Happy Mac icon shows up and stays on for a while.

2. Right when I'd expect to see the "Welcome to Mac OS" screen, the PowerBook reboots again.

3. Mac OS X starts loading.

The solution I came up with maybe isn't comfortable, but at least it works every time - I simply choose the Mac OS 9 installation that is dedicated to the Classic Environment and boot into it (that magically succeeds) and then use its Startup Disk control panel to finally switch to either OS 9 or OS 8. Going back to OS X from OS 9 is not a problem, but going back to OS X from OS 8 requires booting OS 9 first.

The AFP networking

Due to significant changes in the AFP (Apple Filing Protocol) implementations across the Mac OS versions, I was unable to set up file sharing between my MacBook Pro (10.8.5) and the PDQ (9.2.2) using AFP - both sides reported incompatibilities. As a temporary solution, I decided to use FTP - I set up an FTP server on the MBP and connected to it from the PDQ using Transmit. However, when I installed Jaguar the problem was gone.

The photos

There is nothing special about these photos but I decided to post them anyway :)

GNQ2gyT.jpg.8dd468d31b08be439c78ca9159cd8300.jpg


BKN3Vz8.jpg.12154799cf67e865fa4bfa2655d504e5.jpg


wdWYNzN.jpg.242f417d9ac0ab951a1c0532f0cac157.jpg


The epilogue

I hope that maybe someone sometime will find this micro-guide useful and it will spare him a bit of his precious time. Feel free to throw in any suggestions - I may have as well missed out something obvious.

 

bibilit

Well-known member
my PDQ seems to be unable to boot from ANY CD
I had no problem booting from my 10.2 CDs (when i get my Wallstreet, Mac OS 9.2 was not working properly) but i have some issues with Mac OS X (contrast is not working at startup and the screen is dark) don't know if this is due to X or the PRAM battery being toast.

Also, the CD drive is not the same as the Lombard or Pismo's one, and pretty finicky (tried to install Panther at some point using Xpostfacto...but the CD drive was never able to install 10.3 properly)

 
Top