• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

MkLinux DR3 installation errors -- what am I doing wrong?

I'm trying to get MkLinux DR3 installed on my PowerBook 3400. It's a supported machine, and I can get as far into the install as the point where it formats the partitions. When that's done, just before it's supposed to start copying files, it throws a "mount failed: Invalid Argument" error with no further details.

My best guess is that this has something to do with my partitioning scheme, but I'm not sure what would be wrong with it. The 3400 has its original 2GB drive, and I've partitioned it as such:

Code:
Device		Size	Partition type		Mount point

/dev/hda7	512000	HFS (Mac OS partition)
/dev/hda8	163840	UNIX - root			/
/dev/hda9	245760	UNIX - opt			/opt
/dev/hda10	512000	UNIX - usr			/usr
/dev/hda11	81920	UNIX - var			/var
/dev/hda12	409600	UNIX - home			/home

/dev/hda13	81920	UNIX - swap


I picked these partitions and sizes based on the MkLinux install guide. I made sure to keep the swap partition small (I went with 80MB to match how much RAM is in the system) since I've read MkLinux can't handle anything bigger than 127MB. I'm also picking the default install options (not trying to install all the packages off of the CD).

Any ideas?

 
Thanks, I'll check out R2rc5. Late last night I did manage to get DR3 working -- I created just swap, root and home partitions and the installer went smoothly. Not sure if it was the fewer partitions, or putting swap first, that did it.

 

johnklos

Well-known member
There's no benefit and a few downsides to trying to divide up your disk that way, but it's good to hear you got it running.

If you'd prefer a modern OS on the PowerBook 3400, NetBSD can run on it.

 
Top