• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Macintosh Classic Issue - floppy disks not working in OS 7.X (Working in 6.0.7)

JohnnyPhantom

New member
Hey Everyone.

I recently got a Macintosh Classic ( Click here for more info and photos ) that I took apart, and restored (cleaned up, new caps, repaired drive (for now, soon will be a Blue SCSI once the parts arrive from Mouser) cleaned and re-lubed floppy drive, etc. Has the 4MB of RAM upgrade, original mouse, keyboard, power cable, and a Targus carrying bag. I love it so much!

Here's the issue, the floppy drive works, I've created several new system install disks using my Windows XP PC and OmniFlop and MacDisk. If I boot and install OS 6.0.7, I can wipe the drive, install the OS, boot to desktop, pop in another floppy, open the disk and play the game (or whatever the floppy is).

If I load anything OS 7 it seems (tried 7.0, 7.1, 7.5.0, 7.5.3, 7.5.5) I can install the OS, but now any floppy disks no longer work when booted to the desktop. I pop them in, nothing mounts, nothing happens. if I force the floppy out with a paperclip, I'll get a "unrecognized disk" error message.

The issue was the same with the original SCSI drive as well as when I replaced the drive with a BlueSCSI

I tried with both a wipe of the drive and a fresh install of System 7.X as well as upgrading from 6.0.7 to 7.X, seems to behave the same

Is there an extension I need to enable? or something I'm missing? Not sure if it matters, but the machine has no PRAM battery installed.

I tried using the Drive image of 7.5.5, from savagetaylor site, on the BlueSCSI (incase it was a driver issue, I'm not too confident in the 7 installer disk images I found online) so figured I'd try a pre-built image. Assuming it's fully intact and with drivers, I booted it on my Classic and same issue. :( If it's the logic board what would be the most likely chip? I have a spare logic board from another Classic I can swap chips from (the other board was very damaged from the battery, the current board in the machine had no battery damage, but leaky/bad caps before I swapped them all).

In System 6.0.7 the floppy works great and as it should. On 7 I discovered if I put the disk into the drive while the system is booting and once it passes the smiley mac icon, the floppy disk will mount and read. If I eject the disk, it ejects, but stays on the desktop.

I tested with another floppy drive, memory expansion board with RAM, Floppy drive and HDD cables, no changes in behavior.

(Growing up I started with a G4 PowerMac with OS 8.6 and went up from there, became a Apple Authorized Tech, and serviced hundreds of Macintosh machines, but never had a or used 68K or OS 6/7 machine until a few weeks ago, So it's possible I'm missing something)

I tried posting this on a few other sites, and so far no luck with repsonses.

Thanks everyone in advance for all your help on this!

REPLY
 
Top