• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Mac SE/30 cannot initialize internal or external floppy drive

I have a Mac SE/30 with Rominator II and SCSI2SD drive. I have a 1.44MB superdrive as the internal floppy drive. I can sometimes read an application or formatted disk, but most times after opening a file or writing a file to the disk the Finder shows an error that the disk "<disk name>" cannot be found and the disk icon disappears from the desktop while the disk is still in the drive. When I try to format a 1.44MB disk I get an Initialization Failed error. I have tried a second 1.44MB disk drive and get the same errors. I have even tried a FloppyEmu as the internal drive and as an external drive and get the same errors. The SCSI2SD drive always boots to System 7.1 fine and reading and writing files to the SCSI2SD drive works fine without errors.
Has anyone had a similar issue?
I am thinking that my SWIM chip is bad. I have looked at the motherboard and cleaned the motherboard to remove any possible dust/contamination and cannot get good performance from any floppy drive.
Has anyone successfully removed/replaced the SWIM chip?