• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

"Link Error: Error creating new file" MetroWerks CodeWarrior 10 Gold


Well-known member
So I am developing 68k applications under MacOS 8.1 and I recently decided to upgrade from MetroWerks 8 Gold to MetroWerks 10 Gold. At first, I found that nothing at all would link. I would always get this error:


I tried everything I could think of to resolve the problem:
  1. Tried creating brand-new projects
  2. Tried rebooting several times
  3. Tried removing binaries from projects and recompiling
  4. Tried the Reset File Paths menu option
  5. Tried the Synchronize Modification Dates
  6. Tried disabling extensions
  7. Tried saving projects to different drives
  8. Tried freeing up space on the drive
I was about to give up and resign myself to trying another version of CW, until suddenly a project that had failed to link before linked and ran. Now every project I create seems to work (although projects that I had created before that failed still fail). I don't know what changed, as I went from a 100% failure rate to a 100% success rate.

I guess I can just shrug it off and be happy that everything is working, but it's a bit frustrating that I do not know what caused it in the first place. I am just posting here in case someone recognizes the error and can maybe enlighten me as to the cause!


Well-known member
There seems to be some relationship to having the "CodeWarrior 10 Gold Tools" CD mounted (maybe the tools on the CD conflict with the ones installed on the hard disk?). If you compile with the CD in, the problem will start happening, but significantly the problem will not resolve itself if you simply unmount the CD. It seems to "contaminate" projects from that point on and I haven't worked out the series of actions to restore it, although running a project that previously worked does seem to trigger future projects to work. It's weird. I think the problem can be avoided by not having the CD mounted, however.