• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Lc ii not chiming, recapped, was working fine


Well-known member
Ok, so this lc ii was recapped and cleaned. Was working fine. After my move i was going through and testing some of my systems and this one isnt chiming, no display etc. powers on.


Different psu known to be good
Different memory known to be good
Different roms known to be good
Different vram known to be good.

I touched up all my caps pads, and still no difference. I pulled off the egret and sound chip and cleaned pads. Going to check traces, and put egret / sound on and again tomorrow. Any ideas?

Also had a few recapped psu from lc not working now, man was it just the moving lol?


Well-known member
Traveling across the world with a PB100 and 180 made them both check out, unsure why - both worked fine and were in good shape.
To be thorough: yes, moving causes things to jolt and flex, which causes solder joints to sometimes break, sometimes whole traces - try finding that kind of fault without wasting weeks. @Phipli has a whole box of graphics cards that worked before being mailed, and subsequently required extensive rework.

Get a tiny (suggestion: dental) pick and go over the CPU and V8 ASIC pins, attempting to gently wiggle them (at the base, not the 'shoulder')


Active member
I also have a re-capped LCII, SCSI2SD inside and BlueSCSI plugged into the back. It would act up, I had to flip the power on and off and wait for it to even chime. I replaced the internal battery, and it hasn't given me trouble since. I didn't think the LCII had this kind of battery issue, but it has worked for me.